highlighting-kate-0.5.1-1.1.el6.i686.rpm


Advertisement

Description

highlighting-kate - Sourcecode syntax highlighting library

Property Value
Distribution CentOS 6
Repository EPEL i386
Package name highlighting-kate
Package version 0.5.1
Package release 1.1.el6
Package architecture i686
Package type rpm
Installed size 5.90 MB
Download size 738.45 KB
Official Mirror dl.fedoraproject.org
Highlighting-kate is a syntax highlighting library with support for
over one hundred languages. The syntax parsers are automatically
generated from Kate syntax descriptions (http://kate-editor.org/), so
any syntax supported by Kate can be added.
The package provides the Highlighting commandline program.

Alternatives

Package Version Architecture Repository
highlighting-kate-0.5.1-1.1.el6.x86_64.rpm 0.5.1 x86_64 EPEL
highlighting-kate - - -

Requires

Name Value
ghc(array-0.3.0.2) = f538acad67d0b6696484da310d5949cf
ghc(base-4.3.1.0) = 4582a5bc64f22f03f6d960b4f15c981f
ghc(blaze-builder-0.3.1.0) = d928657909dd765d101c4957bad0f75d
ghc(blaze-html-0.4.3.4) = 3932f7773cc6d219e64222556a5e9cc8
ghc(bytestring-0.9.1.10) = 3854cb01149a317dd7949605f3224792
ghc(containers-0.4.0.0) = f1307d32d8f4b51a1487c01f0997b6d9
ghc(deepseq-1.1.0.2) = ce16381c4a634f8997917e5081cb960a
ghc(filepath-1.2.0.0) = 956a4b0c127b8c317f6cac3946b0b803
ghc(ghc-prim-0.2.0.0) = 6bf7b03ebc9c668817e4379b6796c0c2
ghc(integer-gmp-0.2.0.3) = 4c5ab8b517f0b5d4ecf2153d5dfb7f41
ghc(mtl-2.0.1.0) = 3e464329054b7660133198d73c31aca5
ghc(parsec-3.1.1) = 2c865593139c5f6458072364965b72ff
ghc(pcre-light-0.4) = 599f8a47a1ab700e4debb9237d6d0b10
ghc(text-0.11.1.5) = 31deeb358cda307d04a8d099064a02eb
ghc(transformers-0.2.2.0) = 89265f646be3aed4f502cfc5eccd7c93
libHSarray-0.3.0.2-ghc7.0.4.so -
libHSbase-4.3.1.0-ghc7.0.4.so -
libHSblaze-builder-0.3.1.0-ghc7.0.4.so -
libHSblaze-html-0.4.3.4-ghc7.0.4.so -
libHSbytestring-0.9.1.10-ghc7.0.4.so -
libHScontainers-0.4.0.0-ghc7.0.4.so -
libHSdeepseq-1.1.0.2-ghc7.0.4.so -
libHSfilepath-1.2.0.0-ghc7.0.4.so -
libHSghc-prim-0.2.0.0-ghc7.0.4.so -
libHSinteger-gmp-0.2.0.3-ghc7.0.4.so -
libHSmtl-2.0.1.0-ghc7.0.4.so -
libHSparsec-3.1.1-ghc7.0.4.so -
libHSpcre-light-0.4-ghc7.0.4.so -
libHSrts-ghc7.0.4.so -
libHStext-0.11.1.5-ghc7.0.4.so -
libHStransformers-0.2.2.0-ghc7.0.4.so -
libc.so.6(GLIBC_2.0) -
libdl.so.2 -
libffi.so.5 -
libgmp.so.3 -
libm.so.6 -
libpcre.so.0 -
librt.so.1 -
rtld(GNU_HASH) -

Provides

Name Value
highlighting-kate = 0.5.1-1.1.el6
highlighting-kate(x86-32) = 0.5.1-1.1.el6

Download

Type URL
Binary Package highlighting-kate-0.5.1-1.1.el6.i686.rpm
Source Package highlighting-kate-0.5.1-1.1.el6.src.rpm

Install Howto

  1. Download latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/i386/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install highlighting-kate rpm package:
    # yum install highlighting-kate

Files

Path
/usr/bin/Highlight
/usr/share/doc/highlighting-kate-0.5.1/LICENSE

Changelog

2012-06-26 - Jens Petersen <petersen@redhat.com> - 0.5.1-1.1
- skip building the ghci .o file for ppc64
2012-06-10 - Jens Petersen <petersen@redhat.com> - 0.5.1-1
- update to 0.5.1
2012-03-23 - Jens Petersen <petersen@redhat.com> - 0.5.0.5-2
- add license to ghc_files
2012-03-05 - Jens Petersen <petersen@redhat.com> - 0.5.0.5-1
- update to 0.5.0.5
2012-02-13 - Jens Petersen <petersen@redhat.com> - 0.5.0.3-1
- update to 0.5.0.3
- patch to use pcre-light and fix version
- new depends on blaze-html
2012-02-10 - Petr Pisar <ppisar@redhat.com> - 0.2.10-3
- Rebuild against PCRE 8.30
2012-01-05 - Jens Petersen <petersen@redhat.com> - 0.2.10-2
- update to cabal2spec-0.25.2
2011-10-21 - Marcela Mašláňová <mmaslano@redhat.com> - 0.2.10-1.2
- rebuild with new gmp without compat lib
2011-10-11 - Peter Schiffer <pschiffe@redhat.com> - 0.2.10-1.1
- rebuild with new gmp
2011-07-22 - Jens Petersen <petersen@redhat.com> - 0.2.10-1
- update to 0.2.10

See Also

Package Description
hitch-1.4.8-1.el6.i686.rpm Network proxy that terminates TLS/SSL connections
hokuyoaist-3.0.1-1.20120729git69df78b.el6.i686.rpm Hokuyo Laser SCIP driver
hokuyoaist-devel-3.0.1-1.20120729git69df78b.el6.i686.rpm Header files and libraries for hokuyoaist
holland-1.1.8-2.el6.noarch.rpm Pluggable Backup Framework
holland-common-1.1.8-2.el6.noarch.rpm Common library functionality for Holland Plugins
holland-commvault-1.1.8-2.el6.noarch.rpm Holland plugin for Commvault
holland-lvm-1.1.8-2.el6.noarch.rpm LVM library functionality for Holland Plugins
holland-mongodump-1.1.8-2.el6.noarch.rpm Mongodump backup provider plugin for holland
holland-mysql-1.1.8-2.el6.noarch.rpm MySQL library functionality for Holland Plugins
holland-mysqldump-1.1.8-2.el6.noarch.rpm Logical mysqldump backup plugin for Holland
holland-mysqllvm-1.1.8-2.el6.noarch.rpm Holland LVM snapshot backup plugin for MySQL
holland-pgdump-1.1.8-2.el6.noarch.rpm Holland Backup Provider for PostgreSQL
holland-xtrabackup-1.1.8-2.el6.noarch.rpm Holland plugin for Percona XtraBackup
hostapd-2.6-7.el6.i686.rpm IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
hostapd-logwatch-2.6-7.el6.i686.rpm Logwatch scripts for hostapd
Advertisement
Advertisement