perl-PCP-MMV-3.10.9-9.el6.x86_64.rpm


Advertisement

Description

perl-PCP-MMV - Performance Co-Pilot (PCP) Perl bindings for PCP Memory Mapped Values

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename perl-PCP-MMV-3.10.9-9.el6.x86_64.rpm
Package name perl-PCP-MMV
Package version 3.10.9
Package release 9.el6
Package architecture x86_64
Package type rpm
Category Development/Libraries
Homepage http://www.pcp.io
License GPLv2+
Maintainer -
Download size 28.32 KB
Installed size 44.30 KB
The PCP::MMV module contains the Perl language bindings for
building scripts instrumented with the Performance Co-Pilot
(PCP) Memory Mapped Value (MMV) mechanism.
This mechanism allows arbitrary values to be exported from an
instrumented script into the PCP infrastructure for monitoring
and analysis with pmchart, pmie, pmlogger and other PCP tools.

Alternatives

Package Version Architecture Repository
perl-PCP-MMV-3.10.9-9.el6.i686.rpm 3.10.9 i686 CentOS
perl-PCP-MMV - - -

Requires

Name Value
/usr/bin/perl -
libc.so.6(GLIBC_2.2.5)(64bit) -
libpcp.so.3()(64bit) -
libpcp_mmv.so.1()(64bit) -
libpcp_mmv.so.1(PCP_MMV_1.0)(64bit) -
pcp-libs = 3.10.9-9.el6
perl(DynaLoader) -
perl(Exporter) -
perl(Time::HiRes) -
perl(strict) -
perl(vars) -
perl(warnings) -
rtld(GNU_HASH) -

Provides

Name Value
MMV.so()(64bit) -
perl(PCP::MMV) = 1.00
perl-PCP-MMV = 3.10.9-9.el6
perl-PCP-MMV(x86-64) = 3.10.9-9.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package perl-PCP-MMV-3.10.9-9.el6.x86_64.rpm
Source Package pcp-3.10.9-9.el6.src.rpm

Install Howto

Install perl-PCP-MMV rpm package:

# yum install perl-PCP-MMV

Files

Path
/usr/lib64/perl5/vendor_perl/PCP/MMV.pm
/usr/lib64/perl5/vendor_perl/PCP/server.pl
/usr/lib64/perl5/vendor_perl/auto/PCP/MMV/MMV.so
/usr/share/man/man3/PCP::MMV.3pm.gz

Changelog

2017-01-23 - Nathan Scott <nathans@redhat.com> 3.10.9-9
- Added pcp-iostat precision reporting capability (BZ 1297498)
- Fixed a pcp-iostat argument checking stack trace (BZ 1414257)
2016-11-02 - Frank Ch. Eigler <fche@redhat.com> 3.10.9-8
- Fix pmwebd css content-type (BZ 1324964)
2016-10-27 - Nathan Scott <nathans@redhat.com> 3.10.9-7
- Fix pmlogconf probing of base XFS metrics (BZ 1358972)
- Resolve SIGFPE in pcp-atop with missing metrics (BZ 1373590)
- Support pcp-iostat uninterpolated PCP archive replay (BZ 1293661)
- Resolve several reporting issues in PostgreSQL PMDA (BZ 1304619)
2016-02-10 - Lukas Berk <lberk@redhat.com> 3.10.9-6
- Update pmdanamed testcaes (BZ 1303005)
- Fix possible fd leak in pmdanamed (BZ 1223311)
- Fix issue with pmdagfs2 installation (BZ 1305939)
- Address testcase 370 failure on non x86_64 archs (BZ 1305940)
- Address endian issue with pmdalinux on some platforms (BZ 1298722)
2016-01-15 - Lukas Berk <lberk@redhat.com> 3.10.9-5
- Update patch to include testcase (BZ 1297822)
2016-01-14 - Lukas Berk <lberk@redhat.com> - 3.10.9-4
- Correct interrupts parsing on s390x platforms (BZ 1297822)
- Correct papi version we link against for 32 bit arches (BZ 1295694)
2016-01-07 - Lukas Berk <lberk@redhat.com> - 3.10.9-3
- Correct papi version we link against (BZ 1295694)
- Fix possible overflow with pmdaproc using local context options (BZ 1295801)
- Dropped pcp-compat package from upstream (BZ 1294390)
2015-12-17 - Lukas Berk <lberk@redhat.com> - 3.10.9-2
- Include post-release platform-defs patch
2015-12-16 - Lukas Berk <lberk@redhat.com> - 3.10.9-1
- Resolve local_sock() double free error (BZ 1258846).
- Resolve netfilter pmda uses outdated /proc API (BZ 1221653).
- Update to latest PCP sources (BZ 1248272).
- Fix pmatop attribute error (BZ 1195429).
- Fix pmwebd fails when monitoring systems with Vector (BZ 1238863).
2015-05-04 - Nathan Scott <nathans@redhat.com> - 3.10.3-3
- Fix postfix pmda failing to setgid to postfix user (BZ 1213724).
- Fix postfix pmda not reporting incoming mails (BZ 1213764).
- Consistent naming for tools related to LVM cache (BZ 1218007).

See Also

Package Description
perl-PCP-PMDA-3.10.9-9.el6.x86_64.rpm Performance Co-Pilot (PCP) Perl bindings and documentation
perl-PDF-Reuse-0.35-3.el6.noarch.rpm Reuse and mass produce PDF documents
perl-PPI-1.206-4.el6.noarch.rpm Parse, Analyze and Manipulate Perl
perl-PPI-HTML-1.07-7.el6.noarch.rpm Generate syntax-highlighted HTML for Perl using PPI
perl-Package-Constants-0.02-144.el6.x86_64.rpm List all constants declared in a package
perl-Package-Generator-0.103-2.el6.noarch.rpm Generate new packages quickly and easily
perl-PadWalker-1.9-1.el6.x86_64.rpm Play with other peoples' lexical variables
perl-Params-Check-0.26-144.el6.x86_64.rpm Generic input parsing/checking mechanism
perl-Params-Util-1.00-3.el6.x86_64.rpm Simple standalone param-checking functions
perl-Params-Validate-0.92-3.el6.x86_64.rpm Params-Validate Perl module
perl-Parse-CPAN-Meta-1.40-144.el6.x86_64.rpm Parse META.yml and other similar CPAN metadata files
perl-Parse-RecDescent-1.962.2-2.el6.noarch.rpm Parse-RecDescent Perl module
perl-Parse-Yapp-1.05-41.el6.noarch.rpm Perl extension for generating and using LALR parsers
perl-Perl-Critic-1.105-2.el6.noarch.rpm Critique Perl source code for best-practices
perl-Perl-MinimumVersion-1.20-3.el6.noarch.rpm Find a minimum required version of perl for Perl code
Advertisement
Advertisement