pam_passwdqc-1.0.5-8.el6.i686.rpm


Advertisement

Description

pam_passwdqc - Pluggable password quality-control module

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename pam_passwdqc-1.0.5-8.el6.i686.rpm
Package name pam_passwdqc
Package version 1.0.5
Package release 8.el6
Package architecture i686
Package type rpm
Category System Environment/Base
Homepage http://www.openwall.com/passwdqc/
License BSD and Copyright only
Maintainer -
Download size 34.90 KB
Installed size 61.07 KB
pam_passwdqc is a simple password strength checking module for
PAM-aware password changing programs, such as passwd(1).  In addition
to checking regular passwords, it offers support for passphrases and
can provide randomly generated passwords.  All features are optional
and can be (re-)configured without rebuilding.

Alternatives

Package Version Architecture Repository
pam_passwdqc-1.0.5-8.el6.x86_64.rpm 1.0.5 x86_64 CentOS
pam_passwdqc-1.0.5-8.el6.i686.rpm 1.0.5 i686 CentOS
pam_passwdqc-1.0.5-6.el6.lux.1.x86_64.rpm 1.0.5 x86_64 Lux
pam_passwdqc - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libcrypt.so.1 -
libcrypt.so.1(GLIBC_2.0) -
libpam.so.0 -
libpam.so.0(LIBPAM_1.0) -
rtld(GNU_HASH) -

Provides

Name Value
pam_passwdqc = 1.0.5-8.el6
pam_passwdqc(x86-32) = 1.0.5-8.el6
pam_passwdqc.so -

Download

Type URL
Mirror mirror.centos.org
Binary Package pam_passwdqc-1.0.5-8.el6.i686.rpm
Source Package pam_passwdqc-1.0.5-8.el6.src.rpm

Install Howto

Install pam_passwdqc rpm package:

# yum install pam_passwdqc

Files

Path
/lib/security/pam_passwdqc.so
/usr/share/doc/pam_passwdqc-1.0.5/LICENSE
/usr/share/doc/pam_passwdqc-1.0.5/README
/usr/share/man/man8/pam_passwdqc.8.gz

Changelog

2015-02-19 - Avesh Agarwal <avagarwa@redhat.com> - 1.0.5-8
Resolves: #889545 Bumping to tag it as fast track candidate.
2015-02-19 - Avesh Agarwal <avagarwa@redhat.com> - 1.0.5-7
Resolves: #889545
2010-04-20 - Avesh Agarwal <avagarwa@redhat.com> - 1.0.5-6
- Added explanation of new options, disable_firstupper_lastdigit_check,
oldpass_prompt_file, and newpass_prompt_file in the man pages
- Fixed output messages when disable_firstupper_lastdigit_check option
is used 
Resolves: #219201 pam_passwdqc should be more configurable
2010-01-13 - Avesh Agarwal <avagarwa@redhat.com> - 1.0.5-5
- Fixed following rpmlint errors on src rpm:
pam_passwdqc.src: W: summary-ended-with-dot Pluggable
password quality-control module.,
pam_passwdqc.src:11: E: buildprereq-use pam-devel
2009-09-29 - Avesh Agarwal <avagarwa@redhat.com> - 1.0.5-4
- Patch for new configurable options(rhbz# 219201): 
disable first upper and last digit check, passwords 
prompts can be read from a file
- Fixed an issue with spec file where "Release:" is not
specified with "(?dist)". Without this, it gives problem
when tagging across different fedora releases.
2009-07-25 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
2009-02-26 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
2008-06-05 - Tomas Mraz <tmraz@redhat.com> - 1.0.5-1
- upgrade to a latest upstream version
2008-02-20 - Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.4-5
- Autorebuild for GCC 4.3
2007-08-22 - Tomas Mraz <tmraz@redhat.com> - 1.0.4-4
- clarify license even more

See Also

Package Description
pam_pkcs11-0.6.2-17.el6.i686.rpm PKCS #11/NSS PAM login module
pam_pkcs11-0.6.2-17.el6.x86_64.rpm PKCS #11/NSS PAM login module
pam_ssh_agent_auth-0.9.3-123.el6_9.i686.rpm PAM module for authentication with ssh-agent
pam_ssh_agent_auth-0.9.3-123.el6_9.x86_64.rpm PAM module for authentication with ssh-agent
pango-1.28.1-11.el6.i686.rpm System for layout and rendering of internationalized text
pango-1.28.1-11.el6.x86_64.rpm System for layout and rendering of internationalized text
pango-devel-1.28.1-11.el6.i686.rpm Development files for pango
pango-devel-1.28.1-11.el6.x86_64.rpm Development files for pango
pangomm-2.26.0-1.el6.i686.rpm C++ interface for Pango
pangomm-2.26.0-1.el6.x86_64.rpm C++ interface for Pango
pangomm-devel-2.26.0-1.el6.i686.rpm Headers for developing programs that will use pangomm
pangomm-devel-2.26.0-1.el6.x86_64.rpm Headers for developing programs that will use pangomm
papi-5.1.1-12.el6.i686.rpm Performance Application Programming Interface
papi-5.1.1-12.el6.x86_64.rpm Performance Application Programming Interface
papi-devel-5.1.1-12.el6.i686.rpm Header files for the compiling programs with PAPI
Advertisement
Advertisement