libssh2-devel-1.4.2-2.el6_7.1.x86_64.rpm


Advertisement

Description

libssh2-devel - Development files for libssh2

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename libssh2-devel-1.4.2-2.el6_7.1.x86_64.rpm
Package name libssh2-devel
Package version 1.4.2
Package release 2.el6_7.1
Package architecture x86_64
Package type rpm
Category Development/Libraries
Homepage http://www.libssh2.org/
License BSD
Maintainer -
Download size 21.49 KB
Installed size 69.59 KB
The libssh2-devel package contains libraries and header files for
developing applications that use libssh2.

Alternatives

Package Version Architecture Repository
libssh2-devel-1.4.2-3.el6_10.1.x86_64.rpm 1.4.2 x86_64 CentOS Updates
libssh2-devel-1.4.2-3.el6_10.1.i686.rpm 1.4.2 i686 CentOS Updates
libssh2-devel-1.4.2-3.el6_10.1.i686.rpm 1.4.2 i686 CentOS Updates
libssh2-devel-1.4.2-2.el6_7.1.i686.rpm 1.4.2 i686 CentOS
libssh2-devel-1.4.2-2.el6_7.1.i686.rpm 1.4.2 i686 CentOS
libssh2-devel-0.18-10.el6.art.x86_64.rpm 0.18 x86_64 Atomic
libssh2-devel-0.18-10.el6.art.i686.rpm 0.18 i686 Atomic
libssh2-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libssh2 = 1.4.2-2.el6_7.1
libssh2.so.1()(64bit) -
pkgconfig -
pkgconfig(libcrypto) -
pkgconfig(libssl) -

Provides

Name Value
libssh2-devel = 1.4.2-2.el6_7.1
libssh2-devel(x86-64) = 1.4.2-2.el6_7.1
pkgconfig(libssh2) = 1.4.2

Download

Type URL
Mirror mirror.centos.org
Binary Package libssh2-devel-1.4.2-2.el6_7.1.x86_64.rpm
Source Package libssh2-1.4.2-2.el6_7.1.src.rpm

Install Howto

Install libssh2-devel rpm package:

# yum install libssh2-devel

Files

Path
/usr/include/libssh2.h
/usr/include/libssh2_publickey.h
/usr/include/libssh2_sftp.h
/usr/lib64/libssh2.so
/usr/lib64/pkgconfig/libssh2.pc
/usr/share/doc/libssh2-devel-1.4.2/COPYING

Changelog

2016-02-19 - Kamil Dudka <kdudka@redhat.com> - 1.4.2-2.el6_7.1
- use secrects of the appropriate length in Diffie-Hellman (CVE-2016-0787)
2013-05-31 - Kamil Dudka <kdudka@redhat.com> - 1.4.2-2
- fix basic functionality of libssh2 in FIPS mode (#968575)
2012-07-20 - Kamil Dudka <kdudka@redhat.com> - 1.4.2-1
- rebase to libssh2-1.4.2 (#745420, #749873, #804150, #806862)
2012-06-20 - Kamil Dudka <kdudka@redhat.com> - 1.2.2-11
- do not return LIBSSH2_ERROR_EAGAIN in blocking mode (#826511)
2012-03-19 - Kamil Dudka <kdudka@redhat.com> - 1.2.2-10
- transport_send: finish in-progress key exchange before sending data (#804145)
2012-03-14 - Kamil Dudka <kdudka@redhat.com> - 1.2.2-9
- avoid a crash of curl when downloading large files using SFTP (#801428)
2011-10-04 - Kamil Dudka <kdudka@redhat.com> - 1.2.2-8
- fix memory safety errors and memory leakage (#741919)
2010-07-21 - Ondrej Vasik <ovasik@redhat.com> - 1.2.2-7
- two other SELinux issues still caused build failure in mock
in the enforcing mode(#558911)
2010-06-21 - Kamil Dudka <kdudka@redhat.com> - 1.2.2-6
- avoid multilib conflict on libssh2-docs (#605082)
2010-01-26 - Kamil Dudka <kdudka@redhat.com> - 1.2.2-5
- avoid build failure in mock with SELinux in the enforcing mode (#558911)

See Also

Package Description
libssh2-docs-1.4.2-2.el6_7.1.x86_64.rpm Documentation for libssh2
libsss_idmap-1.13.3-60.el6.i686.rpm FreeIPA Idmap library
libsss_idmap-1.13.3-60.el6.x86_64.rpm FreeIPA Idmap library
libsss_idmap-devel-1.13.3-60.el6.i686.rpm FreeIPA Idmap library
libsss_idmap-devel-1.13.3-60.el6.x86_64.rpm FreeIPA Idmap library
libsss_nss_idmap-1.13.3-60.el6.i686.rpm Library for SID based lookups
libsss_nss_idmap-1.13.3-60.el6.x86_64.rpm Library for SID based lookups
libsss_nss_idmap-devel-1.13.3-60.el6.i686.rpm Library for SID based lookups
libsss_nss_idmap-devel-1.13.3-60.el6.x86_64.rpm Library for SID based lookups
libsss_simpleifp-1.13.3-60.el6.i686.rpm The SSSD D-Bus responder helper library
libsss_simpleifp-1.13.3-60.el6.x86_64.rpm The SSSD D-Bus responder helper library
libsss_simpleifp-devel-1.13.3-60.el6.i686.rpm The SSSD D-Bus responder helper library
libsss_simpleifp-devel-1.13.3-60.el6.x86_64.rpm The SSSD D-Bus responder helper library
libstdc++-4.4.7-23.el6.i686.rpm GNU Standard C++ Library
libstdc++-4.4.7-23.el6.x86_64.rpm GNU Standard C++ Library
Advertisement
Advertisement