libmlx4-1.0.6-7.el6.i686.rpm


Advertisement

Description

libmlx4 - Mellanox ConnectX InfiniBand HCA Userspace Driver

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename libmlx4-1.0.6-7.el6.i686.rpm
Package name libmlx4
Package version 1.0.6
Package release 7.el6
Package architecture i686
Package type rpm
Category System Environment/Libraries
Homepage https://www.openfabrics.org/
License GPLv2 or BSD
Maintainer -
Download size 30.61 KB
Installed size 50.45 KB
libmlx4 provides a device-specific userspace driver for Mellanox
ConnectX HCAs for use with the libibverbs library.

Alternatives

Package Version Architecture Repository
libmlx4-1.0.6-7.el6.x86_64.rpm 1.0.6 x86_64 CentOS
libmlx4-1.0.6-7.el6.i686.rpm 1.0.6 i686 CentOS
libmlx4 - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libibverbs.so.1 -
libibverbs.so.1(IBVERBS_1.0) -
libibverbs.so.1(IBVERBS_1.1) -
rdma >= 6.7_3.15-1.el6
rtld(GNU_HASH) -

Provides

Name Value
libibverbs-driver.i386 -
libmlx4 = 1.0.6-7.el6
libmlx4(x86-32) = 1.0.6-7.el6
libmlx4-devel = 1.0.6-7.el6
libmlx4-rdmav2.so -

Obsoletes

Name Value
libmlx4-rocee < 1.0.6

Download

Type URL
Mirror mirror.centos.org
Binary Package libmlx4-1.0.6-7.el6.i686.rpm
Source Package libmlx4-1.0.6-7.el6.src.rpm

Install Howto

Install libmlx4 rpm package:

# yum install libmlx4

Files

Path
/etc/libibverbs.d/mlx4.driver
/usr/lib/libmlx4-rdmav2.so
/usr/share/doc/libmlx4-1.0.6/AUTHORS
/usr/share/doc/libmlx4-1.0.6/COPYING
/usr/share/doc/libmlx4-1.0.6/README

Changelog

2015-03-11 - Doug Ledford <dledford@redhat.com> - 1.0.6-7
- Add compiler warnings patch
- Rebuild against latest libibverbs and valgrind-devel
- Move module init code to rdma package and require rdma package
- Resolves: bz1142161, bz1163527
2014-07-30 - Doug Ledford <dledford@redhat.com> - 1.0.6-6
- Fix obsoletes tag for sub packages
- Related: bz1053500
2014-07-24 - Doug Ledford <dledford@redhat.com> - 1.0.6-5
- Add IP based RoCE GID support
- Resolves: bz1053500
2014-06-18 - Doug Ledford <dledford@redhat.com> - 1.0.6-4
- Another minor fix for the dracut modules
- Related: bz1059094
2014-06-18 - Doug Ledford <dledford@redhat.com> - 1.0.6-3
- Actually use the right %source macro when installing the new
mlx4.conf file this time
- Related: bz1059094
2014-06-18 - Doug Ledford <dledford@redhat.com> - 1.0.6-2
- Add the modprobe.d/mlx4.conf for user set module options that we
don't replace on upgrade
- Rename the dracut module to just mlx4 instead of -libmlx4 (dracut
takes a dash between the number and the name literally)
- Add obsoletes tag to make us replace libmlx4-rocee
- Related: bz1059094
2014-06-16 - Doug Ledford <dledford@redhat.com> - 1.0.6-1.el6
- Update to latest upstream release
- Resolves: bz1059094
2013-08-14 - Michal Schmidt <mschmidt@redhat.com> 1.0.5-4.el6.1
- Fix dracut module for compatibility with RHEL6 version of dracut.
- Resolves: bz789121
2013-08-12 - Michal Schmidt <mschmidt@redhat.com> - 1.0.5-4
- Add dracut module
- Fix URL
2013-08-01 - Doug Ledford <dledford@redhat.com> - 1.0.5-3
- Reduce the dependencies of the setup script even further, it no longer
needs grep

See Also

Package Description
libmlx4-static-1.0.6-7.el6.x86_64.rpm Static version of the libmlx4 driver
libmlx5-1.0.2-1.el6.x86_64.rpm Mellanox Connect-IB InfiniBand HCA Userspace Driver
libmlx5-static-1.0.2-1.el6.i686.rpm Static version of the libmlx4 driver
libmlx5-static-1.0.2-1.el6.x86_64.rpm Static version of the libmlx4 driver
libmng-1.0.10-4.1.el6.i686.rpm Library for Multiple-image Network Graphics support
libmng-1.0.10-4.1.el6.x86_64.rpm Library for Multiple-image Network Graphics support
libmng-devel-1.0.10-4.1.el6.i686.rpm Development files for the Multiple-image Network Graphics library
libmng-devel-1.0.10-4.1.el6.x86_64.rpm Development files for the Multiple-image Network Graphics library
libmnl-1.0.2-3.el6.i686.rpm A minimalistic Netlink library
libmnl-1.0.2-3.el6.x86_64.rpm A minimalistic Netlink library
libmnl-devel-1.0.2-3.el6.i686.rpm Development files for libmnl
libmnl-devel-1.0.2-3.el6.x86_64.rpm Development files for libmnl
libmpcdec-1.2.6-6.1.el6.i686.rpm Musepack audio decoding library
libmpcdec-1.2.6-6.1.el6.x86_64.rpm Musepack audio decoding library
libmpcdec-devel-1.2.6-6.1.el6.i686.rpm Development files for the Musepack audio decoding library
Advertisement
Advertisement