libgovirt-devel-0.3.2-3.el6.x86_64.rpm


Advertisement

Description

libgovirt-devel - Libraries, includes, etc. to compile with the libgovirt library

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename libgovirt-devel-0.3.2-3.el6.x86_64.rpm
Package name libgovirt-devel
Package version 0.3.2
Package release 3.el6
Package architecture x86_64
Package type rpm
Category Development/Libraries
Homepage http://people.freedesktop.org/~teuf/govirt/
License LGPLv2+
Maintainer -
Download size 12.91 KB
Installed size 35.14 KB
libgovirt is a library that allows applications to use oVirt REST API
to list VMs managed by an oVirt instance, and to get the connection
parameters needed to make a SPICE/VNC connection to them.
Libraries, includes, etc. to compile with the libgovirt library

Alternatives

Package Version Architecture Repository
libgovirt-devel-0.3.2-3.el6.i686.rpm 0.3.2 i686 CentOS
libgovirt-devel-0.3.2-3.el6.i686.rpm 0.3.2 i686 CentOS
libgovirt-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
glib2-devel -
libgovirt(x86-64) = 0.3.2-3.el6
libgovirt.so.2()(64bit) -
pkgconfig -
pkgconfig(gio-2.0) -
pkgconfig(glib-2.0) -
pkgconfig(gobject-2.0) -
pkgconfig(rest-0.7) -

Provides

Name Value
libgovirt-devel = 0.3.2-3.el6
libgovirt-devel(x86-64) = 0.3.2-3.el6
pkgconfig(govirt-1.0) = 0.3.2

Download

Type URL
Mirror mirror.centos.org
Binary Package libgovirt-devel-0.3.2-3.el6.x86_64.rpm
Source Package libgovirt-0.3.2-3.el6.src.rpm

Install Howto

Install libgovirt-devel rpm package:

# yum install libgovirt-devel

Files

Path
/usr/include/govirt-1.0/
/usr/include/govirt-1.0/govirt/govirt.h
/usr/include/govirt-1.0/govirt/ovirt-api.h
/usr/include/govirt-1.0/govirt/ovirt-cdrom.h
/usr/include/govirt-1.0/govirt/ovirt-collection.h
/usr/include/govirt-1.0/govirt/ovirt-enum-types.h
/usr/include/govirt-1.0/govirt/ovirt-error.h
/usr/include/govirt-1.0/govirt/ovirt-options.h
/usr/include/govirt-1.0/govirt/ovirt-proxy.h
/usr/include/govirt-1.0/govirt/ovirt-resource.h
/usr/include/govirt-1.0/govirt/ovirt-rest-call-error.h
/usr/include/govirt-1.0/govirt/ovirt-storage-domain.h
/usr/include/govirt-1.0/govirt/ovirt-types.h
/usr/include/govirt-1.0/govirt/ovirt-vm-display.h
/usr/include/govirt-1.0/govirt/ovirt-vm-pool.h
/usr/include/govirt-1.0/govirt/ovirt-vm.h
/usr/lib64/libgovirt.so
/usr/lib64/pkgconfig/govirt-1.0.pc

Changelog

2016-07-26 - Christophe Fergeau <cfergeau@redhat.com> 0.3.2-3
- Fix bug when setting the CA used for https REST communication
Resolves: rhbz#1325762
- Fix parsing of state of storage domain nodes
Resolves: rhbz#1318672
- Silence one redundant warning happening during storage domain parsing
Related: rhbz#1201846
2015-12-17 - Christophe Fergeau <cfergeau@redhat.com> 0.3.2-2
- Silence unnecessary warning
Resolves: rhbz#1201846
- Access oVirt REST API through /ovirt-engine/api rather than /api
Resolves: rhbz#1277447
- Allow to cancel ovirt:// authentication dialog in virt-viewer
Resolves: rhbz#1201604
- Make sure 'cancelled' signal is disconnected when objects die
Related: rhbz#1201604
- Fix crash when VM has several ISO domains
Resolves: rhbz#1274355
- Don't print ticket value to stdout
Resolves: rhbz#1216118
- Add support for accessing VMs behind proxies
Resolves: rhbz#1292754
2015-01-20 - Christophe Fergeau <cfergeau@redhat.com> 0.3.2-1
- Update to libgovirt 0.3.2
Related: rhbz#981678
2014-10-10 - Christophe Fergeau <cfergeau@redhat.com> 0.3.1-3
- Add upstream patch allowing to remove CD images from an OvirtCdrom
Resolves: rhbz#1151171
2014-09-30 - Christophe Fergeau <cfergeau@redhat.com> 0.3.1-2
- Requires a new enough librest as we use symbols not available in older
librest
Related: rhbz#1116844
2014-09-08 - Christophe Fergeau <cfergeau@redhat.com> 0.3.1-1
- Rebase to libgovirt 0.3.1.
Resolves: rhbz#1116844
2014-07-07 - Marc-Andre Lureau <marcandre.lureau@redhat.com> - 0.3.0-1
- Rebase to libgovirt 0.3.0.
Resolves: rhbz#1116844
2014-01-24 - Daniel Mach <dmach@redhat.com> - 0.1.0-3
- Mass rebuild 2014-01-24
2013-12-27 - Daniel Mach <dmach@redhat.com> - 0.1.0-2
- Mass rebuild 2013-12-27
2013-06-11 - Christophe Fergeau <cfergeau@redhat.com> 0.1.0-1
- Update to upstream release 0.1.0

See Also

Package Description
libgpg-error-1.7-4.el6.i686.rpm Library for error values used by GnuPG components
libgpg-error-1.7-4.el6.x86_64.rpm Library for error values used by GnuPG components
libgpg-error-devel-1.7-4.el6.i686.rpm Development files for the libgpg-error package
libgpg-error-devel-1.7-4.el6.x86_64.rpm Development files for the libgpg-error package
libgphoto2-2.4.7-5.el6.i686.rpm Library for accessing digital cameras
libgphoto2-2.4.7-5.el6.x86_64.rpm Library for accessing digital cameras
libgphoto2-devel-2.4.7-5.el6.i686.rpm Headers and links to compile against the libgphoto2 library
libgphoto2-devel-2.4.7-5.el6.x86_64.rpm Headers and links to compile against the libgphoto2 library
libgpod-0.7.2-6.el6.i686.rpm Library to access the contents of an iPod
libgpod-0.7.2-6.el6.x86_64.rpm Library to access the contents of an iPod
libgpod-devel-0.7.2-6.el6.i686.rpm Development files for the libgpod library
libgpod-devel-0.7.2-6.el6.x86_64.rpm Development files for the libgpod library
libgpod-doc-0.7.2-6.el6.noarch.rpm API documentation for the libgpod library
libgsf-1.14.15-5.el6.i686.rpm GNOME Structured File library
libgsf-1.14.15-5.el6.x86_64.rpm GNOME Structured File library
Advertisement
Advertisement