keyutils-libs-1.4-5.el6.x86_64.rpm


Advertisement

Description

keyutils-libs - Key utilities library

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename keyutils-libs-1.4-5.el6.x86_64.rpm
Package name keyutils-libs
Package version 1.4
Package release 5.el6
Package architecture x86_64
Package type rpm
Category System Environment/Base
Homepage http://people.redhat.com/~dhowells/keyutils/
License GPLv2+ and LGPLv2+
Maintainer -
Download size 20.20 KB
Installed size 35.77 KB
This package provides a wrapper library for the key management facility system
calls.

Alternatives

Package Version Architecture Repository
keyutils-libs-1.4-5.el6.i686.rpm 1.4 i686 CentOS
keyutils-libs-1.4-5.el6.i686.rpm 1.4 i686 CentOS
keyutils-libs - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.2.5)(64bit) -
libdl.so.2()(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
keyutils-libs = 1.4-5.el6
keyutils-libs(x86-64) = 1.4-5.el6
libkeyutils.so.1()(64bit) -
libkeyutils.so.1(KEYUTILS_0.3)(64bit) -
libkeyutils.so.1(KEYUTILS_1.0)(64bit) -
libkeyutils.so.1(KEYUTILS_1.3)(64bit) -

Download

Type URL
Mirror mirror.centos.org
Binary Package keyutils-libs-1.4-5.el6.x86_64.rpm
Source Package keyutils-1.4-5.el6.src.rpm

Install Howto

Install keyutils-libs rpm package:

# yum install keyutils-libs

Files

Path
/lib64/libkeyutils.so.1
/lib64/libkeyutils.so.1.3
/usr/share/doc/keyutils-libs-1.4/LICENCE.LGPL

Changelog

2014-03-12 - David Howells  <dhowells@redhat.com> - 1.4-5
- Make keyctl show handle deeply nested keyrings [BZ 1075652].
- The key serial ID field displayed by keyctl show may be up to 10 digits [BZ 1075652].
- Make keyctl padd & co. handle binary data containing NUL chars [BZ 1075652].
- The input buffer for keyctl padd & co. should be 1MB-1 in size [BZ 1075652].
2012-02-03 - David Howells  <dhowells@redhat.com> - 1.4-4
- Allow /sbin/request-key to have multiple config files [BZ 772497].
2011-08-11 - David Howells  <dhowells@redhat.com> - 1.4-3
- Make the keyutils rpm depend on the same keyutils-libs rpm version [BZ 730002].
2011-08-09 - David Howells  <dhowells@redhat.com> - 1.4-2
- Pass -Wl,-z,relro to the linker as a security enhancement [BZ 727280].
2010-03-19 - David Howells  <dhowells@redhat.com> - 1.4-1
- Fix the library naming wrt the version.
- Move the package to version to 1.4.
2010-03-19 - David Howells  <dhowells@redhat.com> - 1.3-3
- Fix spelling mistakes in manpages.
- Add an index manpage for all the keyctl functions.
2010-03-11 - David Howells  <dhowells@redhat.com> - 1.3-2
- Fix rpmlint warnings.
2010-02-26 - David Howells <dhowells@redhat.com> - 1.3-1
- Fix compiler warnings in request-key.
- Expose the kernel function to get a key's security context.
- Expose the kernel function to set a processes keyring onto its parent.
- Move libkeyutils library version to 1.3.
2009-11-30 - Dennis Gregorovic <dgregor@redhat.com> - 1.2-6.1
- Rebuilt for RHEL 6
2009-07-24 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

See Also

Package Description
keyutils-libs-devel-1.4-5.el6.i686.rpm Development package for building Linux key management utilities
keyutils-libs-devel-1.4-5.el6.x86_64.rpm Development package for building Linux key management utilities
khmeros-base-fonts-5.0-9.el6.noarch.rpm Base KhmerOS font
khmeros-battambang-fonts-5.0-9.el6.noarch.rpm Battambang font
khmeros-bokor-fonts-5.0-9.el6.noarch.rpm Bokor font
khmeros-fonts-common-5.0-9.el6.noarch.rpm Common files of khmeros-fonts
khmeros-handwritten-fonts-5.0-9.el6.noarch.rpm Freehand and fasthand fonts
khmeros-metal-chrieng-fonts-5.0-9.el6.noarch.rpm Metal Chrieng font
khmeros-muol-fonts-5.0-9.el6.noarch.rpm Muol fonts - normal, light and Pali
khmeros-siemreap-fonts-5.0-9.el6.noarch.rpm Siemreap font
kiconedit-4.3.3-1.el6.x86_64.rpm An icon editor
kio_sysinfo-20090930-1.el6.x86_64.rpm KIO slave which shows basic system information
kipi-plugins-0.8.0-7.el6.x86_64.rpm Plugins to use with Kipi
kipi-plugins-libs-0.8.0-7.el6.i686.rpm Runtime libraries for kipi-plugins
kipi-plugins-libs-0.8.0-7.el6.x86_64.rpm Runtime libraries for kipi-plugins
Advertisement
Advertisement