febootstrap-3.21-4.el6.x86_64.rpm


Advertisement

Description

febootstrap - Bootstrapping tool for creating supermin appliances

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename febootstrap-3.21-4.el6.x86_64.rpm
Package name febootstrap
Package version 3.21
Package release 4.el6
Package architecture x86_64
Package type rpm
Category Development/Tools
Homepage http://people.redhat.com/~rjones/febootstrap/
License GPLv2+
Maintainer -
Download size 204.12 KB
Installed size 530.69 KB
febootstrap is a tool for building supermin appliances.  These are
tiny appliances (similar to virtual machines), usually around 100KB in
size, which get fully instantiated on-the-fly in a fraction of a
second when you need to boot one of them.
Note that febootstrap in RHEL 6.3+ builds febootstrap (version 2.11)
and febootstrap3 (version 3.21).  This is for backwards
compatibility with RHEL 6.0, 6.1 and 6.2.

Alternatives

Package Version Architecture Repository
febootstrap-2.7-1.el6.x86_64.rpm 2.7 x86_64 EPEL
febootstrap-2.7-1.el6.i686.rpm 2.7 i686 EPEL
febootstrap - - -

Requires

Name Value
/bin/bash -
fakechroot >= 2.9-20
fakeroot >= 1.11
febootstrap-supermin-helper = 3.21-4.el6
libc.so.6(GLIBC_2.7)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
rtld(GNU_HASH) -
yum >= 3.2
yum-utils -

Provides

Name Value
febootstrap = 3.21-4.el6
febootstrap(x86-64) = 3.21-4.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package febootstrap-3.21-4.el6.x86_64.rpm
Source Package febootstrap-3.21-4.el6.src.rpm

Install Howto

Install febootstrap rpm package:

# yum install febootstrap

Files

Path
/usr/bin/febootstrap
/usr/bin/febootstrap-install
/usr/bin/febootstrap-minimize
/usr/bin/febootstrap-run
/usr/bin/febootstrap-to-initramfs
/usr/bin/febootstrap-to-supermin
/usr/bin/febootstrap3
/usr/share/doc/febootstrap-3.21/COPYING
/usr/share/doc/febootstrap-3.21/README2
/usr/share/doc/febootstrap-3.21/README3
/usr/share/man/man8/febootstrap-install.8.gz
/usr/share/man/man8/febootstrap-minimize.8.gz
/usr/share/man/man8/febootstrap-run.8.gz
/usr/share/man/man8/febootstrap-to-initramfs.8.gz
/usr/share/man/man8/febootstrap-to-supermin.8.gz
/usr/share/man/man8/febootstrap.8.gz
/usr/share/man/man8/febootstrap3.8.gz

Changelog

2013-08-05 - Richard Jones <rjones@redhat.com> - 3.21-4
- Fix directory permissions to include setgid and sticky bits.
- Ignore ghost non-regular files.
- Fix segfault when -u/-g options missing argument.
related: rhbz#958184
2013-06-28 - Richard Jones <rjones@redhat.com> - 3.21-2
- Drop supplemental groups when using -g command line option
resolves: rhbz#902478
2013-05-17 - Richard Jones <rjones@redhat.com> - 3.21-1
- Rebase to febootstrap 3.21.
resolves: rhbz#958184
- Remove upstream patch.
2012-08-15 - Richard Jones <rjones@redhat.com> - 3.12-2
- Hotfix: helper: Fix -u and -g options when host uses LDAP or NIS
resolves: RHBZ#803962
2011-12-20 - Richard Jones <rjones@redhat.com> - 3.12-1
- Rebase to febootstrap 3.12.
resolves: RHBZ#719877
2011-08-27 - Richard Jones <rjones@redhat.com> - 3.9-1
- Rebase to febootstrap 3.9.
resolves: RHBZ#719877
- This package contains febootstrap (version 2.11) and febootstrap3.
2011-03-17 - Richard Jones <rjones@redhat.com> - 2.11-7
- Splitting the package broke RHEL 6.0 -> 6.1 upgrades.  Add an Obsoletes
header to fix this.
resolves: RHBZ#669839
2011-01-17 - Richard Jones <rjones@redhat.com> - 2.11-6
- Split package into febootstrap (for building) and febootstrap-supermin-helper
(for running).  Note that febootstrap depends on febootstrap-supermin-helper,
but you can install febootstrap-supermin-helper on its own (RHBZ#669839).
2011-01-14 - Richard Jones <rjones@redhat.com> - 2.11-5
- Clear executable stack flag on febootstrap-supermin-helper.
2010-12-11 - Richard W.M. Jones <rjones@redhat.com> - 2.11-3
- Backport patch to improve the stability of the checksum and reduce
the need to rebuild the appliance.
- Add BR + Requires on insmod.static.

See Also

Package Description
febootstrap-supermin-helper-3.21-4.el6.x86_64.rpm Runtime support for febootstrap
fence-agents-4.0.15-13.el6_9.2.x86_64.rpm Fence Agents for Red Hat Cluster
fence-sanlock-2.8-3.el6.x86_64.rpm Fence agent using sanlock and wdmd
fence-virt-0.2.3-24.el6.x86_64.rpm A pluggable fencing framework for virtual machines
fence-virtd-0.2.3-24.el6.x86_64.rpm Daemon which handles requests from fence-virt
fence-virtd-checkpoint-0.2.3-24.el6.x86_64.rpm Cluster+Libvirt backend for fence-virtd
fence-virtd-libvirt-0.2.3-24.el6.x86_64.rpm Libvirt backend for fence-virtd
fence-virtd-multicast-0.2.3-24.el6.x86_64.rpm Multicast listener for fence-virtd
fence-virtd-serial-0.2.3-24.el6.x86_64.rpm Serial VMChannel listener for fence-virtd
festival-1.96-18.el6.x86_64.rpm Speech synthesis and text-to-speech system
festival-devel-1.96-18.el6.i686.rpm Development files for the Festival speech synthesis system
festival-devel-1.96-18.el6.x86_64.rpm Development files for the Festival speech synthesis system
festival-docs-1.4.2-18.el6.noarch.rpm Documentation for the Festival speech synthesis system
festival-lib-1.96-18.el6.i686.rpm Library for the Festival speech synthesis system
festival-lib-1.96-18.el6.x86_64.rpm Library for the Festival speech synthesis system
Advertisement
Advertisement