expect-devel-5.44.1.15-5.el6_4.i686.rpm


Advertisement

Description

expect-devel - A program-script interaction and testing utility

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename expect-devel-5.44.1.15-5.el6_4.i686.rpm
Package name expect-devel
Package version 5.44.1.15
Package release 5.el6_4
Package architecture i686
Package type rpm
Category Development/Languages
Homepage http://expect.nist.gov/
License Public Domain
Maintainer -
Download size 30.84 KB
Installed size 26.78 KB
Expect is a tcl application for automating and testing
interactive applications such as telnet, ftp, passwd, fsck,
rlogin, tip, etc. Expect makes it easy for a script to
control another program and interact with it.
This package contains development files for the expect library.

Alternatives

Package Version Architecture Repository
expect-devel-5.44.1.15-5.el6_4.x86_64.rpm 5.44.1.15 x86_64 CentOS
expect-devel-5.44.1.15-5.el6_4.i686.rpm 5.44.1.15 i686 CentOS
expect-devel - - -

Requires

Name Value
expect = 5.44.1.15-5.el6_4

Provides

Name Value
expect-devel = 5.44.1.15-5.el6_4
expect-devel(x86-32) = 5.44.1.15-5.el6_4

Download

Type URL
Mirror mirror.centos.org
Binary Package expect-devel-5.44.1.15-5.el6_4.i686.rpm
Source Package expect-5.44.1.15-5.el6_4.src.rpm

Install Howto

Install expect-devel rpm package:

# yum install expect-devel

Files

Path
/usr/include/expect.h
/usr/include/expect_comm.h
/usr/include/expect_tcl.h
/usr/include/tcldbg.h
/usr/share/man/man3/libexpect.3.gz

Changelog

2013-10-31 - Vitezslav Crhonek <vcrhonek@redhat.com> - 5.44.1.15-5
- Fix bogus dates in the %changelog
- Fix memory leak when using -re option
Resolves: #1025202
2012-02-07 - Vitezslav Crhonek <vcrhonek@redhat.com> - 5.44.1.15-4
- Move libexpect link out of -devel subpackage
Resolves: #782859
2012-01-26 - Vitezslav Crhonek <vcrhonek@redhat.com> - 5.44.1.15-3
- Use full path to su in passmass
Resolves: #735962
- Fix segfault in characters matching
Resolves: #742911
- Fix minor man page formatting issue
Resolves: #674866
2010-06-08 - Vitezslav Crhonek <vcrhonek@redhat.com> - 5.44.1.15-2
- Fix wrong symlink
2010-03-18 - Vitezslav Crhonek <vcrhonek@redhat.com> - 5.44.1.15-1
- Update to 5.44.1.15 from upstream CVS
- Remove config.sub (no longer needed), remove unused patches (few are
upstream now, few are pointless with new version), comment patches
- Fix unbuffer to return exit code of ubuffered program
- Fix Tk initialization
2009-11-30 - Dennis Gregorovic <dgregor@redhat.com> - 5.43.0-19.1
- Rebuilt for RHEL 6
2009-08-10 - Ville Skyttä <ville.skytta@iki.fi> - 5.43.0-19
- Use bzipped upstream tarball.
2009-07-24 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.43.0-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
2009-02-24 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.43.0-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
2009-02-11 - Vitezslav Crhonek <vcrhonek@redhat.com> - 5:43.0-16
- Modify and rebuild for new Tcl

See Also

Package Description
expectk-5.44.1.15-5.el6_4.x86_64.rpm A program-script interaction and testing utility
fakechroot-2.9-24.5.el6_1.1.x86_64.rpm Gives a fake chroot environment
fakechroot-libs-2.9-24.5.el6_1.1.x86_64.rpm Gives a fake chroot environment (libraries)
fakeroot-1.12.2-22.2.el6.x86_64.rpm Gives a fake root environment
fakeroot-libs-1.12.2-22.2.el6.x86_64.rpm Gives a fake root environment (libraries)
farsight2-0.0.16-1.1.el6.i686.rpm Libraries for videoconferencing
farsight2-0.0.16-1.1.el6.x86_64.rpm Libraries for videoconferencing
farsight2-devel-0.0.16-1.1.el6.i686.rpm Development files for farsight2
farsight2-devel-0.0.16-1.1.el6.x86_64.rpm Development files for farsight2
farsight2-python-0.0.16-1.1.el6.x86_64.rpm Python binding for farsight2
fcoe-target-utils-2.0rc1.fb16-6.el6.noarch.rpm An administration shell for FCoE storage targets
fcoe-utils-1.0.28-6.el6.x86_64.rpm Fibre Channel over Ethernet utilities
febootstrap-3.21-4.el6.x86_64.rpm Bootstrapping tool for creating supermin appliances
febootstrap-supermin-helper-3.21-4.el6.x86_64.rpm Runtime support for febootstrap
fence-agents-4.0.15-13.el6_9.2.x86_64.rpm Fence Agents for Red Hat Cluster
Advertisement
Advertisement