eclipse-jdt-3.6.1-6.13.el6.x86_64.rpm


Advertisement

Description

eclipse-jdt - Eclipse Java Development Tools

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename eclipse-jdt-3.6.1-6.13.el6.x86_64.rpm
Package name eclipse-jdt
Package version 3.6.1
Package release 6.13.el6
Package architecture x86_64
Package type rpm
Category Text Editors/Integrated Development Environments (IDE)
Homepage http://www.eclipse.org/
License EPL
Maintainer -
Download size 23.36 MB
Installed size 25.59 MB
Eclipse Java Development Tools.  This package is required to use Eclipse for
developing software written in the Java programming language.

Alternatives

Package Version Architecture Repository
eclipse-jdt-3.6.1-6.13.el6.i686.rpm 3.6.1 i686 CentOS
eclipse-jdt - - -

Requires

Name Value
eclipse-cvs-client = 3.6.1-6.13.el6
eclipse-platform = 3.6.1-6.13.el6
jakarta-commons-httpclient -
java-devel -
java-javadoc -
junit >= 3.8.1-3jpp
junit4 -

Provides

Name Value
eclipse-jdt = 3.6.1-6.13.el6
eclipse-jdt(x86-64) = 3.6.1-6.13.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package eclipse-jdt-3.6.1-6.13.el6.x86_64.rpm
Source Package eclipse-3.6.1-6.13.el6.src.rpm

Install Howto

Install eclipse-jdt rpm package:

# yum install eclipse-jdt

Files

Path
/usr/bin/efj
/usr/lib64/eclipse/dropins/jdt/
/usr/lib64/eclipse/dropins/jdt/features/
/usr/lib64/eclipse/dropins/jdt/features/org.eclipse.jdt_3.6.1.r361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX/eclipse_update_120.jpg
/usr/lib64/eclipse/dropins/jdt/features/org.eclipse.jdt_3.6.1.r361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX/epl-v10.html
/usr/lib64/eclipse/dropins/jdt/features/org.eclipse.jdt_3.6.1.r361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX/feature.properties
/usr/lib64/eclipse/dropins/jdt/features/org.eclipse.jdt_3.6.1.r361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX/feature.xml
/usr/lib64/eclipse/dropins/jdt/features/org.eclipse.jdt_3.6.1.r361_v20100714-0800-7z8XFUSFLBmsgvVz0z-3vjz095IX/license.html
/usr/lib64/eclipse/dropins/jdt/plugins/junit4.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.ant.launching_1.0.0.v20100427.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.ant.ui_3.5.0.v20100427.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.apt.core_3.3.401.R36_v20100727-0110.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.apt.pluggable.core_1.0.301.R36_v20100727-0110.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.apt.ui_3.3.300.v20100513-0845.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.compiler.apt_1.0.300.v20100513-0845.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.compiler.tool_1.0.100.v_A68_R36x.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.core.manipulation_1.3.0.v20100520-0800.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.core_3.6.1.v_A68_R36x.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.debug.ui_3.5.0.v20100602-0830.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.doc.user_3.6.1.r361_v20100721-0800.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.junit.core_3.6.1.r361_v20100825-0800.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.junit.runtime_3.4.200.v20100526-0800.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.junit4.runtime_1.1.100.v20100526-0800.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.junit_3.6.1.r361_v20100825-0800.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.launching_3.5.100.v20100526.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.ui_3.6.1.r361_v20100825-0800.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt_3.6.1.r361_v20100714-0800.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.hamcrest.core_1.1.0.v20090501071000.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.debug_3.6.1.v20100715_r361/.api_description
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.debug_3.6.1.v20100715_r361/about.html
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.debug_3.6.1.v20100715_r361/jdi.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.debug_3.6.1.v20100715_r361/jdimodel.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.debug_3.6.1.v20100715_r361/plugin.properties
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.debug_3.6.1.v20100715_r361/plugin.xml
/usr/lib64/eclipse/dropins/jdt/plugins/org.eclipse.jdt.debug_3.6.1.v20100715_r361/META-INF/MANIFEST.MF
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit4/junit.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit4_4.8.1.v20100525/about.html
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit4_4.8.1.v20100525/plugin.properties
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit4_4.8.1.v20100525/META-INF/MANIFEST.MF
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_3.8.2.v3_8_2_v20100427-1100/about.html
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_3.8.2.v3_8_2_v20100427-1100/junit.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_3.8.2.v3_8_2_v20100427-1100/plugin.properties
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_3.8.2.v3_8_2_v20100427-1100/META-INF/MANIFEST.MF
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_3.8.2.v3_8_2_v20100427-1100/META-INF/eclipse.inf
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_3.8.2.v3_8_2_v20100427-1100/about_files/cpl-v10.html
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_4.8.1.v4_8_1_v20100427-1100/about.html
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_4.8.1.v4_8_1_v20100427-1100/junit.jar
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_4.8.1.v4_8_1_v20100427-1100/plugin.properties
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_4.8.1.v4_8_1_v20100427-1100/META-INF/MANIFEST.MF
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_4.8.1.v4_8_1_v20100427-1100/META-INF/eclipse.inf
/usr/lib64/eclipse/dropins/jdt/plugins/org.junit_4.8.1.v4_8_1_v20100427-1100/about_files/cpl-v10.html

Changelog

2011-01-19 - Andrew Overholt <overholt@redhat.com> 1:3.6.1-6.13
- Drop patch to remove ant-trax (needed by test runs).
2011-01-19 - Andrew Overholt <overholt@redhat.com> 1:3.6.1-6.12
- Add two upstream patches to allow for running SDK JUnit tests.
2011-01-12 - Andrew Overholt <overholt@redhat.com> 1:3.6.1-6.11
- Bring in line with Fedora.
- Remove some stuff that is now done in eclipse-build.
- Fix sources URL.
- Add PDE dependency on zip for pdebuild script.
- Use new eclipse-build targets.
- Increase minimum required memory in eclipse.ini.
2011-01-11 - Andrew Overholt <overholt@redhat.com> 1:3.6.1-6.10
- Put ant.launching into JDT's dropins directory.
2011-01-11 - Andrew Overholt <overholt@redhat.com> 1:3.6.1-6.9
- Use apache-tomcat-apis JARs.
- Version objectweb-asm BR/R.
2011-01-10 - Chris Aniszczyk <overholt@redhat.com> 1:3.6.1-6.8
- Fix JSP API symlinks.
2010-12-15 - Alexander Kurtakov <akurtako@redhat.com> 1:3.6.1-6.7
- Install o.e.jdt.junit.core in jdt (rhbz#663207).
2010-12-13 - Severin Gehwolf <sgehwolf@redhat.com> 1:3.6.1-6
- Add Eclipse help XSS vulnerability fix (RH Bz #661901).
2010-12-01 - Jeff Johnston <jjohnstn@redhat.com> 1:3.6.1-5
- Remove work around for openjdk bug#647737 as openjdk has
posted its own work around and will shortly be fixing problem 
correctly.
2010-11-10 - Jeff Johnston <jjohnstn@redhat.com> 1:3.6.1-4
- Work around for openjdk bug#647737.

See Also

Package Description
eclipse-linuxprofilingframework-0.6.1-1.el6.x86_64.rpm Eclipse Linux Tools Profiling Framework
eclipse-mylyn-3.4.2-9.el6.x86_64.rpm Mylyn is a task-focused UI for Eclipse
eclipse-mylyn-cdt-3.4.2-9.el6.x86_64.rpm Mylyn Bridge: C/C++ Development
eclipse-mylyn-java-3.4.2-9.el6.x86_64.rpm Mylyn Bridge: Java Development
eclipse-mylyn-pde-3.4.2-9.el6.x86_64.rpm Mylyn Bridge: Plug-in Development
eclipse-mylyn-trac-3.4.2-9.el6.x86_64.rpm Mylyn Trac Connector
eclipse-mylyn-webtasks-3.4.2-9.el6.x86_64.rpm Mylyn Connector: Web Templates
eclipse-mylyn-wikitext-3.4.2-9.el6.x86_64.rpm Mylyn WikiText
eclipse-nls-3.6.0.v20120721114722-2.el6.x86_64.rpm Babel language packs for the Eclipse platform and various plug-ins
eclipse-nls-ar-3.6.0.v20120721114722-2.el6.x86_64.rpm Eclipse/Babel language pack for Arabic
eclipse-nls-bg-3.6.0.v20120721114722-2.el6.x86_64.rpm Eclipse/Babel language pack for Bulgarian
eclipse-nls-ca-3.6.0.v20120721114722-2.el6.x86_64.rpm Eclipse/Babel language pack for Catalan
eclipse-nls-cs-3.6.0.v20120721114722-2.el6.x86_64.rpm Eclipse/Babel language pack for Czech
eclipse-nls-da-3.6.0.v20120721114722-2.el6.x86_64.rpm Eclipse/Babel language pack for Danish
eclipse-nls-de-3.6.0.v20120721114722-2.el6.x86_64.rpm Eclipse/Babel language pack for German
Advertisement
Advertisement