compat-readline5-devel-5.2-17.1.el6.x86_64.rpm


Advertisement

Description

compat-readline5-devel - Files needed to develop programs which use the readline library

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename compat-readline5-devel-5.2-17.1.el6.x86_64.rpm
Package name compat-readline5-devel
Package version 5.2
Package release 17.1.el6
Package architecture x86_64
Package type rpm
Category Development/Libraries
Homepage http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html
License GPLv2+
Maintainer -
Download size 26.77 KB
Installed size 61.41 KB
The Readline library provides a set of functions that allow users to
edit typed command lines. If you want to develop programs that will
use the readline library, you need to have the readline-devel package
installed. You also need to have the readline package installed.

Alternatives

Package Version Architecture Repository
compat-readline5-devel-5.2-17.1.el6.i686.rpm 5.2 i686 CentOS
compat-readline5-devel-5.2-17.1.el6.i686.rpm 5.2 i686 CentOS
compat-readline5-devel - - -

Requires

Name Value
compat-readline5 = 5.2-17.1.el6
libhistory.so.5()(64bit) -
libreadline.so.5()(64bit) -
ncurses-devel -

Provides

Name Value
compat-readline5-devel = 5.2-17.1.el6
compat-readline5-devel(x86-64) = 5.2-17.1.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package compat-readline5-devel-5.2-17.1.el6.x86_64.rpm
Source Package compat-readline5-5.2-17.1.el6.src.rpm

Install Howto

Install compat-readline5-devel rpm package:

# yum install compat-readline5-devel

Files

Path
/usr/include/readline5/
/usr/include/readline5/readline/chardefs.h
/usr/include/readline5/readline/history.h
/usr/include/readline5/readline/keymaps.h
/usr/include/readline5/readline/readline.h
/usr/include/readline5/readline/rlconf.h
/usr/include/readline5/readline/rlstdc.h
/usr/include/readline5/readline/rltypedefs.h
/usr/include/readline5/readline/tilde.h
/usr/lib64/readline5/libhistory.so
/usr/lib64/readline5/libreadline.so

Changelog

2009-11-30 - Dennis Gregorovic <dgregor@redhat.com> - 5.2-17.1
- Rebuilt for RHEL 6
2009-07-24 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2-17
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
2009-07-08 - Miroslav Lichvar <mlichvar@redhat.com> 5.2-16
- review fixes (#510022)
2009-07-07 - Miroslav Lichvar <mlichvar@redhat.com> 5.2-15
- make compat package
- include upstream patches 013, 014
2009-02-25 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
2008-03-23 - Jan Kratochvil <jan.kratochvil@redhat.com> - 5.2-13
- Fix the previous %changelog entry authorship.
2008-03-23 - Jan Kratochvil <jan.kratochvil@redhat.com> - 5.2-12
- Fix excessive prompts on CTRL-C abort while the prompt is being printed.
2008-02-19 - Fedora Release Engineering <rel-eng@fedoraproject.org> - 5.2-11
- Autorebuild for GCC 4.3
2008-01-18 - Miroslav Lichvar <mlichvar@redhat.com> 5.2-10
- move libreadline to /lib
2008-01-03 - Miroslav Lichvar <mlichvar@redhat.com> 5.2-9
- include upstream patches 008-011

See Also

Package Description
compat-readline5-static-5.2-17.1.el6.x86_64.rpm Static libraries for the readline library
compat-xcb-util-0.4.0-2.2.el6.i686.rpm Compatibility libraries atop libxcb
compat-xcb-util-0.4.0-2.2.el6.x86_64.rpm Compatibility libraries atop libxcb
compiz-0.8.2-24.el6.i686.rpm OpenGL window and compositing manager
compiz-0.8.2-24.el6.x86_64.rpm OpenGL window and compositing manager
compiz-devel-0.8.2-24.el6.i686.rpm Development packages for compiz
compiz-devel-0.8.2-24.el6.x86_64.rpm Development packages for compiz
compiz-gnome-0.8.2-24.el6.x86_64.rpm Compiz gnome integration bits
comps-extras-17.8-1.el6.noarch.rpm Images for components included in Fedora
conman-0.2.7-3.el6.x86_64.rpm ConMan - The Console Manager
control-center-2.28.1-41.el6.i686.rpm Utilities to configure the GNOME desktop
control-center-2.28.1-41.el6.x86_64.rpm Utilities to configure the GNOME desktop
control-center-devel-2.28.1-41.el6.i686.rpm Development files for the GNOME control-center
control-center-devel-2.28.1-41.el6.x86_64.rpm Development files for the GNOME control-center
control-center-extra-2.28.1-41.el6.x86_64.rpm Additional utilities to configure the GNOME desktop
Advertisement
Advertisement