brlapi-0.5.4-7.el6.i686.rpm


Advertisement

Description

brlapi - Appliation Programming Interface for BRLTTY

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename brlapi-0.5.4-7.el6.i686.rpm
Package name brlapi
Package version 0.5.4
Package release 7.el6
Package architecture i686
Package type rpm
Category Applications/System
Homepage http://mielke.cc/brltty/
License LGPLv2+
Maintainer -
Download size 102.70 KB
Installed size 335.78 KB
This package provides the run-time support for the Application
Programming Interface to BRLTTY.
Install this package if you have an application which directly accesses
a refreshable braille display.

Alternatives

Package Version Architecture Repository
brlapi-0.5.4-7.el6.i686.rpm 0.5.4 i686 CentOS
brlapi-0.5.4-7.el6.x86_64.rpm 0.5.4 x86_64 CentOS
brlapi - - -

Requires

Name Value
/sbin/ldconfig -
brltty = 4.1-7.el6
libX11.so.6 -
libXext.so.6 -
libXtst.so.6 -
libc.so.6(GLIBC_2.7) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
rtld(GNU_HASH) -

Provides

Name Value
brlapi = 0.5.4-7.el6
brlapi(x86-32) = 0.5.4-7.el6
libbrlapi.so.0.5 -
libbrlttybba.so -

Download

Type URL
Mirror mirror.centos.org
Binary Package brlapi-0.5.4-7.el6.i686.rpm
Source Package brltty-4.1-7.el6.src.rpm

Install Howto

Install brlapi rpm package:

# yum install brlapi

Files

Path
/bin/vstp
/bin/xbrlapi
/lib/libbrlapi.so.0.5
/lib/libbrlapi.so.0.5.4
/lib/brltty/libbrlttybba.so
/usr/share/doc/brlapi-0.5.4/README
/usr/share/doc/brlapi-0.5.4/Manual-BrlAPI/
/usr/share/doc/brlapi-0.5.4/Manual-BrlAPI/English/BrlAPI-1.html
/usr/share/doc/brlapi-0.5.4/Manual-BrlAPI/English/BrlAPI-2.html
/usr/share/doc/brlapi-0.5.4/Manual-BrlAPI/English/BrlAPI-3.html
/usr/share/doc/brlapi-0.5.4/Manual-BrlAPI/English/BrlAPI-4.html
/usr/share/doc/brlapi-0.5.4/Manual-BrlAPI/English/BrlAPI-5.html
/usr/share/doc/brlapi-0.5.4/Manual-BrlAPI/English/BrlAPI-6.html
/usr/share/doc/brlapi-0.5.4/Manual-BrlAPI/English/BrlAPI-7.html
/usr/share/doc/brlapi-0.5.4/Manual-BrlAPI/English/BrlAPI.html
/usr/share/doc/brlapi-0.5.4/Manual-BrlAPI/English/BrlAPI.sgml
/usr/share/doc/brlapi-0.5.4/Manual-BrlAPI/English/BrlAPI.txt
/usr/share/man/man1/vstp.1.gz
/usr/share/man/man1/xbrlapi.1.gz

Changelog

2012-07-27 - Jaroslav Škarvada <jskarvad@redhat.com> - 4.1-7
- Fixed build in case ocaml is preinstalled in build root
Resolves: rhbz#684526
- Fixed /usr/lib/libbrlapi.so symbolic link
Resolves: rhbz#809326
2010-02-18 - Jaroslav Škarvada <jskarvad@redhat.com> - 4.1-6
- fix rpmlint errors and warnings
2010-01-20 - Stepan Kasal <skasal@redhat.com> - 4.1-5
- requires(post): coreutils to work around an installator bug
- Resolves: #540437
2010-01-13 - Stepan Kasal <skasal@redhat.com> - 4.1-4
- limit building against speech-dispatcher to Fedora
- Resolves: rhbz#553795
2009-11-01 - Stepan Kasal <skasal@redhat.com> - 4.1-3
- build the TTY driver (it was disabled since it first appered in 3.7.2-1)
- build with speech-dispatcher, packed into a separate sub-package
2009-10-30 - Stepan Kasal <skasal@redhat.com> - 4.1-2
- move data-directory back to default: /etc/brltty
- move brltty to /bin and /lib, so that it can be used to repair the system
without /usr mounted (#276181)
- move vstp and libbrlttybba.so to brlapi
- brltty no longer requires brlapi
- brlapi now requires brltty from the same build
2009-10-28 - Stepan Kasal <skasal@redhat.com> - 4.1-1
- new upstream version
- use --disable-stripping instead of make variable override
- install the default brltty-pm.conf to docdir only (#526168)
- remove the duplicate copies of rhmkboot and rhmkroot from docdir
- patch configure so that the dirs in summary are not garbled:
brltty-autoconf-quote.patch
- move data-directory to ${datadir}/brltty
2009-10-20 - Stepan Kasal <skasal@redhat.com> - 4.0-2
- escape rpm macros in the rpm change log
- add requires to bind subpackages from one build together
2009-10-07 - Stepan Kasal <skasal@redhat.com> - 4.0-1
- new upstream version
- drop upstreamed patches; ./autogen not needed anymore
- pack the xbrlapi server; move its man page to brlapi package
- add man-page for brltty.conf (#526168)
2009-07-24 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.10-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

See Also

Package Description
brlapi-devel-0.5.4-7.el6.i686.rpm Headers, static archive, and documentation for BrlAPI
brlapi-devel-0.5.4-7.el6.x86_64.rpm Headers, static archive, and documentation for BrlAPI
brlapi-java-0.5.4-7.el6.x86_64.rpm Java binding for BrlAPI
brltty-4.1-7.el6.x86_64.rpm Braille display driver for Linux/Unix
brltty-at-spi-4.1-7.el6.x86_64.rpm AtSpi driver for BRLTTY
brltty-xw-4.1-7.el6.x86_64.rpm XWindow driver for BRLTTY
bsf-2.4.0-4.1.el6.noarch.rpm Bean Scripting Framework
bsf-javadoc-2.4.0-4.1.el6.noarch.rpm Javadoc for bsf
bsh-1.3.0-15.5.el6.noarch.rpm Lightweight Scripting for Java
bsh-demo-1.3.0-15.5.el6.noarch.rpm Demo for bsh
bsh-desktop-1.3.0-15.5.el6.noarch.rpm Desktop integration for bsh
bsh-javadoc-1.3.0-15.5.el6.noarch.rpm Javadoc for bsh
bsh-manual-1.3.0-15.5.el6.noarch.rpm Manual for bsh
btparser-0.17-2.el6.i686.rpm Parser and analyzer for backtraces produced by GDB
btparser-0.17-2.el6.x86_64.rpm Parser and analyzer for backtraces produced by GDB
Advertisement
Advertisement