boost-program-options-1.41.0-28.el6.x86_64.rpm


Advertisement

Description

boost-program-options - Runtime component of boost program_options library

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename boost-program-options-1.41.0-28.el6.x86_64.rpm
Package name boost-program-options
Package version 1.41.0
Package release 28.el6
Package architecture x86_64
Package type rpm
Category System Environment/Libraries
Homepage http://sodium.resophonic.com/boost-cmake/1.41.0.cmake0/
License Boost
Maintainer -
Download size 108.08 KB
Installed size 614.86 KB
Runtime support of boost program options library, which allows program
developers to obtain (name, value) pairs from the user, via
conventional methods such as command line and configuration file.

Alternatives

Package Version Architecture Repository
boost-program-options-1.55.0-25.el6.x86_64.rpm 1.55.0 x86_64 OKey
boost-program-options-1.44.0-1.el6.x86_64.rpm 1.44.0 x86_64 NauLinux Extras
boost-program-options-1.44.0-1.el6.i686.rpm 1.44.0 i686 NauLinux Extras
boost-program-options-1.41.0-28.el6.i686.rpm 1.41.0 i686 CentOS
boost-program-options-1.41.0-28.el6.i686.rpm 1.41.0 i686 CentOS
boost-program-options - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
librt.so.1()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
boost-program-options = 1.41.0-28.el6
boost-program-options(x86-64) = 1.41.0-28.el6
libboost_program_options-mt.so.5()(64bit) -
libboost_program_options.so.5()(64bit) -

Download

Type URL
Mirror mirror.centos.org
Binary Package boost-program-options-1.41.0-28.el6.x86_64.rpm
Source Package boost-1.41.0-28.el6.src.rpm

Install Howto

Install boost-program-options rpm package:

# yum install boost-program-options

Files

Path
/usr/lib64/libboost_program_options-mt.so.5
/usr/lib64/libboost_program_options.so.5
/usr/share/doc/boost-program-options-1.41.0/LICENSE_1_0.txt

Changelog

2015-12-23 - Jonathan Wakely <jwakely@redhat.com> 1.41.0-28
- Don't install .cmake files.
- Resolves: #1245805
2015-02-04 - Petr Machata <pmachata@redhat.com> - 1.41.0-27
- Fix the way MPI_VERSION is compared with (>=2 rather than ==2) so
that an arg-less boost::mpi::environment ctor is exposed for MPI
libraries with MPI_VERSION of 3.
(boost-1.41.0-mpi-NOARG_INIT.patch)
- Fix boost::interprocess::move (boost-1.41.0-interprocess-move.patch)
- Fix copy construction of boost::weak_ptr
(boost-1.41.0-weak_ptr-copy.patch)
- Undo the change of non-Requires: package references to not use
%{?_isa} again.
2015-01-08 - Petr Machata <pmachata@redhat.com> - 1.41.0-26
- Change Requires: and other package references to use %{?_isa}, so
that dependencies are arch-aware.
2014-08-21 - Michal Schmidt <mschmidt@redhat.com> - 1.41.0-25
- mpich obsoleted mpich2. Build against mpich and rename subpackages
accordingly. Obsolete mpich2 subpackages.
2014-06-23 - Petr Machata <pmachata@redhat.com> - 1.41.0-24
- Fix conformance problems in Boost.Numeric (uBLAS) and
Boost.CircularBuffer (boost-1.41.0-numeric-conformance.patch,
boost-1.41.0-circular_buffer-adl.patch)
2014-06-23 - Petr Machata <pmachata@redhat.com> - 1.41.0-23
- Fix conformance problems in Boost.Interprocess, Boost.Intrusive and
Boost.Graph
(boost-1.41.0-graph-conformance.patch,
boost-1.41.0-interprocess-conformance.patch,
boost-1.41.0-interprocess-conformance-maxval.patch,
boost-1.41.0-intrusive-conformance.patch)
2014-06-12 - Jonathan Wakely <jwakely@redhat.com> - 1.41.0-23
- Make Boost.Thread work with recent GCC and C++11.
(boost-1.41.0-thread-rvalue-fixes.patch)
2014-06-12 - Jonathan Wakely <jwakely@redhat.com> - 1.41.0-22
- Fix shared_ptr to work with recent GCC and C++11.
(boost-1.41.0-shared_ptr-deleted-copy.patch)
- Resolves: #1108268
2014-05-30 - Petr Machata <pmachata@redhat.com> - 1.41.0-21
- Fix building of Python module for Boost-MPI and ship it
(boost-1.41.0-mpi-python.patch, __init__.py)
2014-04-29 - Petr Machata <pmachata@redhat.com> - 1.41.0-20
- Add an upstream patch for BOOST_ENABLE_THREADS

See Also

Package Description
boost-python-1.41.0-28.el6.i686.rpm Runtime component of boost python library
boost-python-1.41.0-28.el6.x86_64.rpm Runtime component of boost python library
boost-regex-1.41.0-28.el6.i686.rpm Runtime component of boost regular expression library
boost-regex-1.41.0-28.el6.x86_64.rpm Runtime component of boost regular expression library
boost-serialization-1.41.0-28.el6.i686.rpm Runtime component of boost serialization library
boost-serialization-1.41.0-28.el6.x86_64.rpm Runtime component of boost serialization library
boost-signals-1.41.0-28.el6.i686.rpm Runtime component of boost signals and slots library
boost-signals-1.41.0-28.el6.x86_64.rpm Runtime component of boost signals and slots library
boost-static-1.41.0-28.el6.x86_64.rpm The Boost C++ static development libraries
boost-system-1.41.0-28.el6.i686.rpm Runtime component of boost system support library
boost-system-1.41.0-28.el6.x86_64.rpm Runtime component of boost system support library
boost-test-1.41.0-28.el6.i686.rpm Runtime component of boost test library
boost-test-1.41.0-28.el6.x86_64.rpm Runtime component of boost test library
boost-thread-1.41.0-28.el6.i686.rpm Runtime component of boost thread library
boost-thread-1.41.0-28.el6.x86_64.rpm Runtime component of boost thread library
Advertisement
Advertisement