avahi-glib-devel-0.6.25-17.el6.x86_64.rpm


Advertisement

Description

avahi-glib-devel - Libraries and header files for avahi glib development

Property Value
Distribution CentOS 6
Repository CentOS x86_64
Package filename avahi-glib-devel-0.6.25-17.el6.x86_64.rpm
Package name avahi-glib-devel
Package version 0.6.25
Package release 17.el6
Package architecture x86_64
Package type rpm
Category Development/Libraries
Homepage http://avahi.org
License LGPLv2
Maintainer -
Download size 18.21 KB
Installed size 3.30 KB
The avahi-devel package contains the header files and libraries
necessary for developing programs using avahi with glib.

Alternatives

Package Version Architecture Repository
avahi-glib-devel-0.6.25-17.el6.i686.rpm 0.6.25 i686 CentOS
avahi-glib-devel-0.6.25-17.el6.i686.rpm 0.6.25 i686 CentOS
avahi-glib-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
avahi-devel = 0.6.25-17.el6
avahi-glib = 0.6.25-17.el6
glib2-devel -
libavahi-glib.so.1()(64bit) -
pkgconfig(glib-2.0) -

Provides

Name Value
avahi-glib-devel = 0.6.25-17.el6
avahi-glib-devel(x86-64) = 0.6.25-17.el6
pkgconfig(avahi-glib) = 0.6.25

Download

Type URL
Mirror mirror.centos.org
Binary Package avahi-glib-devel-0.6.25-17.el6.x86_64.rpm
Source Package avahi-0.6.25-17.el6.src.rpm

Install Howto

Install avahi-glib-devel rpm package:

# yum install avahi-glib-devel

Files

Path
/usr/include/avahi-glib/glib-malloc.h
/usr/include/avahi-glib/glib-watch.h
/usr/lib64/libavahi-glib.so
/usr/lib64/pkgconfig/avahi-glib.pc

Changelog

2016-10-31 - Michal Sekletar <msekleta@redhat.com> - 0.6.25-17
- produce better error message when client reaches maximum number of dbus objects (#1292862)
- don't print backtrace if avahi-discover can't connect to avahi-daemon (#1110349)
- introduce new subpackage with python bindings (#753905)
- avahi-daemon initscript improvements (#584766)
- avahi-dnsconfd initscript improvements (#584761)
2016-07-15 - Michal Sekletar <msekleta@redhat.com> - 0.6.25-16
- silently discard invalid DNS response packets (#1332631)
2014-08-28 - Michal Sekletar <msekleta@redhat.com> - 0.6.25-15
- Document newly introduced options in manpage (#1074028)
2014-08-12 - Michal Sekletar <msekleta@redhat.com> - 0.6.25-14
- Make internal limits configurable (#1074028)
2014-06-12 - Michal Sekletar <msekleta@redhat.com> - 0.6.25-13
- Don't consider queries with non-empty additional data sections as invalid (#885849, #768708)
2012-09-24 - Lennart Poettering <lpoetter@redhat.com> - 0.6.25-12
- Drop hard deps on the main Avahi package from library packages
- Resolves: #599435
2011-04-04 - Lennart Poettering <lpoetter@redhat.com> - 0.6.25-11
- Fix for CVE-2011-1002
- Resolves: #684886
- Actually apply the patch
2011-04-04 - Lennart Poettering <lpoetter@redhat.com> - 0.6.25-10
- Fix for CVE-2011-1002
- Resolves: #684886
2011-02-08 - Christopher Aillon <caillon@redhat.com> - 0.6.25-9
- Don't stomp on rpm's default CFLAGS when building
2010-06-30 - Soren Sandmann <ssp@redhat.com> - 0.6.25-8
- Fix typo in the spec file: ldconfign->ldconfig
It breaks the build roots.
- Related: #607296

See Also

Package Description
avahi-gobject-0.6.25-17.el6.i686.rpm GObject wrapper library for Avahi
avahi-gobject-0.6.25-17.el6.x86_64.rpm GObject wrapper library for Avahi
avahi-gobject-devel-0.6.25-17.el6.i686.rpm Libraries and header files for Avahi GObject development
avahi-gobject-devel-0.6.25-17.el6.x86_64.rpm Libraries and header files for Avahi GObject development
avahi-libs-0.6.25-17.el6.i686.rpm Libraries for avahi run-time use
avahi-libs-0.6.25-17.el6.x86_64.rpm Libraries for avahi run-time use
avahi-qt3-0.6.25-17.el6.i686.rpm Qt3 libraries for avahi
avahi-qt3-0.6.25-17.el6.x86_64.rpm Qt3 libraries for avahi
avahi-qt3-devel-0.6.25-17.el6.i686.rpm Libraries and header files for avahi Qt3 development
avahi-qt3-devel-0.6.25-17.el6.x86_64.rpm Libraries and header files for avahi Qt3 development
avahi-qt4-0.6.25-17.el6.i686.rpm Qt4 libraries for avahi
avahi-qt4-0.6.25-17.el6.x86_64.rpm Qt4 libraries for avahi
avahi-qt4-devel-0.6.25-17.el6.i686.rpm Libraries and header files for avahi Qt4 development
avahi-qt4-devel-0.6.25-17.el6.x86_64.rpm Libraries and header files for avahi Qt4 development
avahi-tools-0.6.25-17.el6.x86_64.rpm Command line tools for mDNS browsing and publishing
Advertisement
Advertisement