nss-3.28.4-1.el6_9.i686.rpm


Advertisement

Description

nss - Network Security Services

Distribution: CentOS 6
Repository: CentOS Updates x86_64
Package name: nss
Package version: 3.28.4
Package release: 1.el6_9
Package architecture: i686
Package type: rpm
Installed size: 2.44 MB
Download size: 883.21 KB
Official Mirror: mirror.centos.org
Network Security Services (NSS) is a set of libraries designed to support cross-platform development of security-enabled client and server applications. Applications built with NSS can support SSL v2 and v3, TLS, PKCS #5, PKCS #7, PKCS #11, PKCS #12, S/MIME, X.509 v3 certificates, and other security standards.

Provides

  • config(nss) = 3.28.4-1.el6_9
  • libnss3.so
  • libnss3.so(NSS_3.10)
  • libnss3.so(NSS_3.10.2)
  • libnss3.so(NSS_3.11)
  • libnss3.so(NSS_3.11.1)
  • libnss3.so(NSS_3.11.2)
  • libnss3.so(NSS_3.11.7)
  • libnss3.so(NSS_3.11.9)
  • libnss3.so(NSS_3.12)
  • libnss3.so(NSS_3.12.1)
  • libnss3.so(NSS_3.12.10)
  • libnss3.so(NSS_3.12.3)
  • libnss3.so(NSS_3.12.4)
  • libnss3.so(NSS_3.12.5)
  • libnss3.so(NSS_3.12.6)
  • libnss3.so(NSS_3.12.7)
  • libnss3.so(NSS_3.12.9)
  • libnss3.so(NSS_3.13)
  • libnss3.so(NSS_3.13.2)
  • libnss3.so(NSS_3.14)
  • libnss3.so(NSS_3.14.1)
  • libnss3.so(NSS_3.14.3)
  • libnss3.so(NSS_3.15)
  • libnss3.so(NSS_3.15.4)
  • libnss3.so(NSS_3.16.1)
  • libnss3.so(NSS_3.16.2)
  • libnss3.so(NSS_3.18)
  • libnss3.so(NSS_3.19)
  • libnss3.so(NSS_3.19.1)
  • libnss3.so(NSS_3.2)
  • libnss3.so(NSS_3.2.1)
  • libnss3.so(NSS_3.21)
  • libnss3.so(NSS_3.22)
  • libnss3.so(NSS_3.3)
  • libnss3.so(NSS_3.3.1)
  • libnss3.so(NSS_3.4)
  • libnss3.so(NSS_3.5)
  • libnss3.so(NSS_3.6)
  • libnss3.so(NSS_3.7)
  • libnss3.so(NSS_3.7.1)
  • libnss3.so(NSS_3.8)
  • libnss3.so(NSS_3.9)
  • libnss3.so(NSS_3.9.2)
  • libnss3.so(NSS_3.9.3)
  • libnssckbi.so
  • libnssckbi.so(NSS_3.1)
  • libnsspem.so
  • libnsspem.so(NSS_3.1)
  • libsmime3.so
  • libsmime3.so(NSS_3.10)
  • libsmime3.so(NSS_3.12.10)
  • libsmime3.so(NSS_3.12.2)
  • libsmime3.so(NSS_3.13)
  • libsmime3.so(NSS_3.15)
  • libsmime3.so(NSS_3.16)
  • libsmime3.so(NSS_3.18)
  • libsmime3.so(NSS_3.2)
  • libsmime3.so(NSS_3.2.1)
  • libsmime3.so(NSS_3.3)
  • libsmime3.so(NSS_3.4)
  • libsmime3.so(NSS_3.4.1)
  • libsmime3.so(NSS_3.6)
  • libsmime3.so(NSS_3.7)
  • libsmime3.so(NSS_3.7.2)
  • libsmime3.so(NSS_3.8)
  • libsmime3.so(NSS_3.9)
  • libsmime3.so(NSS_3.9.3)
  • libssl3.so
  • libssl3.so(NSS_3.11.4)
  • libssl3.so(NSS_3.11.8)
  • libssl3.so(NSS_3.12.10)
  • libssl3.so(NSS_3.12.6)
  • libssl3.so(NSS_3.13)
  • libssl3.so(NSS_3.13.2)
  • libssl3.so(NSS_3.14)
  • libssl3.so(NSS_3.15)
  • libssl3.so(NSS_3.15.4)
  • libssl3.so(NSS_3.2)
  • libssl3.so(NSS_3.2.1)
  • libssl3.so(NSS_3.20)
  • libssl3.so(NSS_3.21)
  • libssl3.so(NSS_3.22)
  • libssl3.so(NSS_3.23)
  • libssl3.so(NSS_3.24)
  • libssl3.so(NSS_3.27)
  • libssl3.so(NSS_3.28)
  • libssl3.so(NSS_3.4)
  • libssl3.so(NSS_3.7.4)
  • nss = 3.28.4-1.el6_9
  • nss(x86-32) = 3.28.4-1.el6_9

Conflicts

  • curl < 7.19.7-26.el6

    Download

    Install Howto

    Install the nss rpm package:

    # yum install nss

    Files

    • /etc/pki/nss-legacy/nss-rhel6.config
    • /etc/pki/nssdb/cert8.db
    • /etc/pki/nssdb/key3.db
    • /etc/pki/nssdb/secmod.db
    • /usr/lib/libnss3.so
    • /usr/lib/libnssckbi.so
    • /usr/lib/libnsspem.so
    • /usr/lib/libsmime3.so
    • /usr/lib/libssl3.so
    • /usr/lib/nss/libnssckbi.so

    Changelog

    2017-04-07 - Daiki Ueno <dueno@redhat.com> - 3.28.4-1 - Rebase to 3.28.4

    2017-03-24 - Daiki Ueno <dueno@redhat.com> - 3.28.3-3 - Fix crash with tstclnt -W - Adjust gtests to run with our old softoken and downstream patches

    2017-03-15 - Daiki Ueno <dueno@redhat.com> - 3.28.3-2 - Avoid cipher suite ordering change, spotted by Hubert Kario

    2017-02-28 - Daiki Ueno <dueno@redhat.com> - 3.28.3-1 - Rebase to 3.28.3 - Remove upstreamed moz-1282627-rh-1294606.patch, moz-1312141-rh-1387811.patch, moz-1315936.patch, and moz-1318561.patch - Remove no longer necessary nss-duplicate-ciphers.patch - Disable X25519 and exclude tests using it - Catch failed ASN1 decoding of RSA keys, by Kamil Dudka (#1427481)

    2017-01-09 - Daiki Ueno <dueno@redhat.com> - 3.27.1-13 - Update expired PayPalEE.cert

    2016-12-13 - Daiki Ueno <dueno@redhat.com> - 3.27.1-12 - Disable unsupported test cases in ssl_gtests

    2016-12-06 - Daiki Ueno <dueno@redhat.com> - 3.27.1-11 - Adjust the sslstress.txt filename so that it matches with the disableSSL2tests patch ported from RHEL 7 - Exclude SHA384 and CHACHA20_POLY1305 ciphersuites from stress tests - Don't add gtests and ssl_gtests to nss_tests, unless gtests are enabled

    2016-12-02 - Daiki Ueno <dueno@redhat.com> - 3.27.1-10 - Add patch to fix SSL CA name leaks, taken from NSS 3.27.2 release - Add patch to fix bash syntax error in tests/ssl.sh - Add patch to remove duplicate ciphersuites entries in sslinfo.c - Add patch to abort selfserv/strsclnt/tstclnt on non-parsable version range - Build with support for SSLKEYLOGFILE

    2016-11-16 - Daiki Ueno <dueno@redhat.com> - 3.27.1-9 - Update fix_multiple_open patch to fix regression in openldap client - Remove pk11_genobj_leak patch, which caused crash with Firefox - Add comment in the policy file to preserve the last empty line - Disable SHA384 ciphersuites when CKM_TLS12_KEY_AND_MAC_DERIVE is not provided by softoken; this superseds check_hash_impl patch

    2016-11-11 - Daiki Ueno <dueno@redhat.com> - 3.27.1-8 - Fix problem in check_hash_impl patch

    Advertisement
    Advertisement