vim-X11-7.4.629-5.el6_10.2.i686.rpm


Advertisement

Description

vim-X11 - The VIM version of the vi editor for the X Window System

Property Value
Distribution CentOS 6
Repository CentOS Updates i386
Package filename vim-X11-7.4.629-5.el6_10.2.i686.rpm
Package name vim-X11
Package version 7.4.629
Package release 5.el6_10.2
Package architecture i686
Package type rpm
Category Applications/Editors
Homepage http://www.vim.org/
License Vim
Maintainer -
Download size 1.07 MB
Installed size 2.36 MB
VIM (VIsual editor iMproved) is an updated and improved version of the
vi editor.  Vi was the first real screen-based editor for UNIX, and is
still very popular.  VIM improves on vi by adding new features:
multiple windows, multi-level undo, block highlighting and
more. VIM-X11 is a version of the VIM editor which will run within the
X Window System.  If you install this package, you can run VIM as an X
application with a full GUI interface and mouse support.
Install the vim-X11 package if you'd like to try out a version of vi
with graphics and mouse capabilities.  You'll also need to install the
vim-common package.

Alternatives

Package Version Architecture Repository
vim-X11-7.4.629-5.el6_10.2.x86_64.rpm 7.4.629 x86_64 CentOS Updates
vim-X11-7.4.629-5.el6_8.1.x86_64.rpm 7.4.629 x86_64 CentOS
vim-X11-7.4.629-5.el6_8.1.i686.rpm 7.4.629 i686 CentOS
vim-X11-7.4.430-1.gf.el6.x86_64.rpm 7.4.430 x86_64 Ghettoforge Testing
vim-X11-7.4.430-1.gf.el6.i686.rpm 7.4.430 i686 Ghettoforge Testing
vim-X11-7.4.211-1.gf.el6.x86_64.rpm 7.4.211 x86_64 Ghettoforge Plus
vim-X11-7.4.211-1.gf.el6.i686.rpm 7.4.211 i686 Ghettoforge Plus
vim-X11 - - -

Requires

Name Value
gtk2 >= 2.6
hicolor-icon-theme -
libICE.so.6 -
libSM.so.6 -
libX11.so.6 -
libXt.so.6 -
libacl.so.1 -
libacl.so.1(ACL_1.0) -
libattr >= 2.4
libc.so.6(GLIBC_2.11) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgdk-x11-2.0.so.0 -
libgdk_pixbuf-2.0.so.0 -
libglib-2.0.so.0 -
libgobject-2.0.so.0 -
libgpm.so.2 -
libgtk-x11-2.0.so.0 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libpango-1.0.so.0 -
libperl.so -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
libselinux.so.1 -
libtinfo.so.5 -
perl(:MODULE_COMPAT_5.10.1) -
rtld(GNU_HASH) -
vim-common = 7.4.629-5.el6_10.2

Provides

Name Value
gvim = 7.4.629-5.el6_10.2
mimehandler(application/x-shellscript) -
mimehandler(text/english) -
mimehandler(text/plain) -
mimehandler(text/x-c) -
mimehandler(text/x-c++) -
mimehandler(text/x-c++hdr) -
mimehandler(text/x-c++src) -
mimehandler(text/x-chdr) -
mimehandler(text/x-csrc) -
mimehandler(text/x-java) -
mimehandler(text/x-makefile) -
mimehandler(text/x-moc) -
mimehandler(text/x-pascal) -
mimehandler(text/x-tcl) -
mimehandler(text/x-tex) -
vim-X11 = 7.4.629-5.el6_10.2
vim-X11(x86-32) = 7.4.629-5.el6_10.2

Download

Type URL
Mirror mirror.centos.org
Binary Package vim-X11-7.4.629-5.el6_10.2.i686.rpm
Source Package vim-7.4.629-5.el6_10.2.src.rpm

Install Howto

Install vim-X11 rpm package:

# yum install vim-X11

Files

Path
/usr/bin/evim
/usr/bin/gex
/usr/bin/gview
/usr/bin/gvim
/usr/bin/gvimdiff
/usr/bin/gvimtutor
/usr/bin/vimx
/usr/share/applications/gvim.desktop
/usr/share/icons/hicolor/16x16/apps/gvim.png
/usr/share/icons/hicolor/32x32/apps/gvim.png
/usr/share/icons/hicolor/48x48/apps/gvim.png
/usr/share/icons/hicolor/64x64/apps/gvim.png
/usr/share/man/man1/evim.1.gz

Changelog

2019-06-26 - Zdenek Dohnal <zdohnal@redhat.com> - 2:7.4.629-5.2
- 1724045 - fix CVE-2019-12735 the :source! command allows arbitrary command execution via the modeline
- fix spec warnings about expanding macros
2016-12-12 - Karsten Hopp <karsten@redhat.com> 7.4.629-5.1
- add fix for CVE-2016-1248
2015-03-31 - Karsten Hopp <karsten@redhat.com> 7.4.629-5
- update sshd_config and cpp syntax files
2015-02-12 - Karsten Hopp <karsten@redhat.com> 7.4.629-3
- some minor spec file fixes required by the rebase
2015-02-11 - Karsten Hopp <karsten@redhat.com> 7.4.629-2
- fix syntax highlighting for some ssh_config sshd_config keywords
2015-02-11 - Karsten Hopp <karsten@redhat.com> 7.4.629-1
- patchlevel 629
2015-02-06 - Karsten Hopp <karsten@redhat.com> 7.4.622-1
- patchlevel 622
2015-02-05 - Karsten Hopp <karsten@redhat.com> 7.4.621-1
- patchlevel 621
2015-02-04 - Karsten Hopp <karsten@redhat.com> 7.4.618-1
- patchlevel 618
2015-02-03 - Karsten Hopp <karsten@redhat.com> 7.4.615-1
- patchlevel 615

See Also

Package Description
vim-common-7.4.629-5.el6_10.2.i686.rpm The common files needed by any version of the VIM editor
vim-enhanced-7.4.629-5.el6_10.2.i686.rpm A version of the VIM editor which includes recent enhancements
vim-filesystem-7.4.629-5.el6_10.2.i686.rpm VIM filesystem layout
vim-minimal-7.4.629-5.el6_10.2.i686.rpm A minimal version of the VIM editor
virt-p2v-0.9.1-2.20130730.1.el6.centos.noarch.rpm Virt P2V ISO image
xmlrpc3-client-3.0-4.17.el6_9.noarch.rpm XML-RPC client implementation
xmlrpc3-client-devel-3.0-4.17.el6_9.noarch.rpm Source for XML-RPC client implementation
xmlrpc3-common-3.0-4.17.el6_9.noarch.rpm Common classes for XML-RPC client and server implementations
xmlrpc3-common-devel-3.0-4.17.el6_9.noarch.rpm Source for common classes of XML-RPC
xmlrpc3-javadoc-3.0-4.17.el6_9.noarch.rpm Javadoc for xmlrpc3
xmlrpc3-server-3.0-4.17.el6_9.noarch.rpm XML-RPC server implementation
xmlrpc3-server-devel-3.0-4.17.el6_9.noarch.rpm Source for XML-RPC server implementation
ypserv-2.19-32.el6_10.i686.rpm The NIS (Network Information Service) server
yum-3.2.29-81.el6.centos.0.1.noarch.rpm RPM package installer/updater/manager
yum-NetworkManager-dispatcher-1.1.30-42.el6_10.noarch.rpm NetworkManager script which tells yum to check it's cache on network change
Advertisement
Advertisement