rh-ruby24-rubygem-psych-2.2.2-92.el6.x86_64.rpm


Advertisement

Description

rh-ruby24-rubygem-psych - A libyaml wrapper for Ruby

Property Value
Distribution CentOS 6
Repository CentOS SCLo RH x86_64
Package filename rh-ruby24-rubygem-psych-2.2.2-92.el6.x86_64.rpm
Package name rh-ruby24-rubygem-psych
Package version 2.2.2
Package release 92.el6
Package architecture x86_64
Package type rpm
Category Development/Libraries
Homepage http://ruby-lang.org/
License MIT
Maintainer -
Download size 86.23 KB
Installed size 118.18 KB
Psych is a YAML parser and emitter. Psych leverages
libyaml[http://pyyaml.org/wiki/LibYAML] for its YAML parsing and emitting
capabilities. In addition to wrapping libyaml, Psych also knows how to
serialize and de-serialize most Ruby objects to and from the YAML format.

Alternatives

Package Version Architecture Repository
rh-ruby24-rubygem-psych-2.2.2-92.el6.x86_64.rpm 2.2.2 x86_64 CentOS SCLo RH Testing
rh-ruby24-rubygem-psych-2.2.2-91.sc1.el6.x86_64.rpm 2.2.2 x86_64 CentOS SCLo RH Testing
rh-ruby24-rubygem-psych-2.2.2-91.sc1.el6.x86_64.rpm 2.2.2 x86_64 CentOS SCLo RH
rh-ruby24-rubygem-psych-2.2.2-90.el6.x86_64.rpm 2.2.2 x86_64 CentOS SCLo RH Testing
rh-ruby24-rubygem-psych-2.2.2-90.el6.x86_64.rpm 2.2.2 x86_64 CentOS SCLo RH
rh-ruby24-rubygem-psych-2.2.2-75.el6.x86_64.rpm 2.2.2 x86_64 CentOS SCLo RH Testing
rh-ruby24-rubygem-psych-2.2.2-75.el6.x86_64.rpm 2.2.2 x86_64 CentOS SCLo RH
rh-ruby24-rubygem-psych - - -

Requires

Name Value
libc.so.6(GLIBC_2.2.5)(64bit) -
libcrypt.so.1()(64bit) -
libdl.so.2()(64bit) -
libm.so.6()(64bit) -
libpthread.so.0()(64bit) -
librt.so.1()(64bit) -
libruby.so.2.4()(64bit) -
libyaml-0.so.2()(64bit) -
rh-ruby24-ruby(release) -
rh-ruby24-ruby(rubygems) >= 2.6.14.4
rtld(GNU_HASH) -

Provides

Name Value
psych.so()(64bit) -
rh-ruby24-rubygem(psych) = 2.2.2-92.el6
rh-ruby24-rubygem-psych = 2.2.2-92.el6
rh-ruby24-rubygem-psych(x86-64) = 2.2.2-92.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package rh-ruby24-rubygem-psych-2.2.2-92.el6.x86_64.rpm
Source Package rh-ruby24-ruby-2.4.6-92.el6.src.rpm

Install Howto

  1. Install CentOS SCLo RH repository:
    yum install centos-release-scl-rh
  2. Install rh-ruby24-rubygem-psych rpm package:
    # yum install rh-ruby24-rubygem-psych

Files

Path
/opt/rh/rh-ruby24/root/usr/lib64/gems/ruby/psych-2.2.2/psych.so
/opt/rh/rh-ruby24/root/usr/lib64/ruby/psych.so
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/class_loader.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/coder.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/core_ext.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/deprecated.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/exception.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/handler.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/nodes.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/omap.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/parser.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/scalar_scanner.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/set.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/stream.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/streaming.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/syntax_error.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/tree_builder.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/versions.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/visitors.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/y.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/handlers/document_stream.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/handlers/recorder.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/json/ruby_events.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/json/stream.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/json/tree_builder.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/json/yaml_events.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/nodes/alias.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/nodes/document.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/nodes/mapping.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/nodes/node.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/nodes/scalar.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/nodes/sequence.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/nodes/stream.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/visitors/depth_first.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/visitors/emitter.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/visitors/json_tree.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/visitors/to_ruby.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/visitors/visitor.rb
/opt/rh/rh-ruby24/root/usr/share/gems/gems/psych-2.2.2/lib/psych/visitors/yaml_tree.rb
/opt/rh/rh-ruby24/root/usr/share/gems/specifications/psych-2.2.2.gemspec
/opt/rh/rh-ruby24/root/usr/share/ruby/psych
/opt/rh/rh-ruby24/root/usr/share/ruby/psych.rb

Changelog

2019-04-11 - Jun Aruga <jaruga@redhat.com> - 2.4.6-92
- Upgrade to Ruby 2.4.6.
- Delete directory using symlink when decompressing tar
Resolves: CVE-2019-8320
- Fix escape sequence injection vulnerability in verbose.
Resolves: CVE-2019-8321
- Fix escape sequence injection vulnerability in gem owner.
Resolves: CVE-2019-8322
- Fix escape sequence injection vulnerability in API response handling.
Resolves: CVE-2019-8323
- Prohibit arbitrary code execution when installing a malicious gem.
Resolves: CVE-2019-8324
- Fix escape sequence injection vulnerability in errors.
Resolves: CVE-2019-8325
2018-11-05 - Pavel Valena <pvalena@redhat.com> - 2.4.5-91
- Upgrade to Ruby 2.4.5.
Resolves: CVE-2018-16395
Resolves: rhbz#1563077
Removed Patch10: ruby-2.5.0-Disable-Tokyo-TZ-tests.patch; subsumed
- Properly harden package using -fstack-protector-strong.
- Fix: return default path with nonexistent home dir(rhbz#1602879)
2018-03-12 - Pavel Valena <pvalena@redhat.com> - 2.4.3-90
- Command injection in lib/resolv.rb:lazy_initialize() allows arbitrary code
execution(CVE-2017-17790).
* ruby-2.5.0-Fixed-command-Injection.patch
Related: rhbz#1549651
2018-02-12 - Pavel Valena <pvalena@redhat.com> - 2.4.3-89
- Upgrade to Ruby 2.4.3.
Resolves: rhbz#1549651
Resolves: CVE-2017-17405
* Remove Patch10: ruby-2.4.3-CVE-2017-0903-Fix-unsafe-object-deserialization
-vulnerability.patch
subsumed
2017-10-30 - Vít Ondruch <vondruch@redhat.com> - 2.4.2-86
- Upgrade to Ruby 2.4.2.
* Remove Patch10: ruby-2.4.0-vm_insnhelper.c-block-argument-at-tailcall.patch;
subsumed
Resolves: rhbz#1506785
- Fix unsafe object deserialization in RubyGems (CVE-2017-0903).
* ruby-2.4.3-CVE-2017-0903-Fix-unsafe-object-deserialization
-vulnerability.patch
Resolves: CVE-2017-0903
2017-01-17 - Vít Ondruch <vondruch@redhat.com> - 2.4.0-75
- Apply patch fixing rubygem-mongo build failures.
2017-01-09 - Vít Ondruch <vondruch@redhat.com> - 2.4.0-73
- Reshuffle the %license macro to avoid %postun scriptlet issues.
Resolves: rhbz#1411233
2017-01-09 - Vít Ondruch <vondruch@redhat.com> - 2.4.0-72
- Add rubygem-io-console dependency for rubygem-rdoc.
2017-01-02 - Vít Ondruch <vondruch@redhat.com> - 2.4.0-71
- ruby-libs should not own links to unbundled gems.
2017-01-02 - Vít Ondruch <vondruch@redhat.com> - 2.4.0-70
- Upgrade to Ruby 2.4.0.
- Workaround "an invalid stdio handle" error on PPC (rhbz#1361037).
- Add gemspec_add_dep and gemspec_remove_dep macros.
- Move gemified xmlrpc into subpackage.
- Move gemified openssl into subpackage.
- Make symlinks for json gem.
- Tk is removed from stdlib.
- Harden package.
- Extend 'gem_' macros for pre-release version support.

See Also

Package Description
rh-ruby24-rubygem-rake-12.0.0-75.el6.noarch.rpm Ruby based make-like utility
rh-ruby24-rubygem-rake-12.0.0-90.el6.noarch.rpm Ruby based make-like utility
rh-ruby24-rubygem-rake-12.0.0-91.sc1.el6.noarch.rpm Ruby based make-like utility
rh-ruby24-rubygem-rake-12.0.0-92.el6.noarch.rpm Ruby based make-like utility
rh-ruby24-rubygem-rdoc-5.0.0-75.el6.noarch.rpm A tool to generate HTML and command-line documentation for Ruby projects
rh-ruby24-rubygem-rdoc-5.0.0-90.el6.noarch.rpm A tool to generate HTML and command-line documentation for Ruby projects
rh-ruby24-rubygem-rdoc-5.0.0-91.sc1.el6.noarch.rpm A tool to generate HTML and command-line documentation for Ruby projects
rh-ruby24-rubygem-rdoc-5.0.0-92.el6.noarch.rpm A tool to generate HTML and command-line documentation for Ruby projects
rh-ruby24-rubygem-test-unit-3.2.3-75.el6.noarch.rpm An xUnit family unit testing framework for Ruby
rh-ruby24-rubygem-test-unit-3.2.3-90.el6.noarch.rpm An xUnit family unit testing framework for Ruby
rh-ruby24-rubygem-test-unit-3.2.3-91.sc1.el6.noarch.rpm An xUnit family unit testing framework for Ruby
rh-ruby24-rubygem-test-unit-3.2.3-92.el6.noarch.rpm An xUnit family unit testing framework for Ruby
rh-ruby24-rubygem-xmlrpc-0.2.1-75.el6.noarch.rpm XMLRPC is a lightweight protocol that enables remote procedure calls over HTTP
rh-ruby24-rubygem-xmlrpc-0.2.1-90.el6.noarch.rpm XMLRPC is a lightweight protocol that enables remote procedure calls over HTTP
rh-ruby24-rubygem-xmlrpc-0.2.1-91.sc1.el6.noarch.rpm XMLRPC is a lightweight protocol that enables remote procedure calls over HTTP
Advertisement
Advertisement