rh-ruby23-ruby-2.3.8-70.el6.x86_64.rpm


Advertisement

Description

rh-ruby23-ruby - An interpreter of object-oriented scripting language

Property Value
Distribution CentOS 6
Repository CentOS SCLo RH x86_64
Package filename rh-ruby23-ruby-2.3.8-70.el6.x86_64.rpm
Package name rh-ruby23-ruby
Package version 2.3.8
Package release 70.el6
Package architecture x86_64
Package type rpm
Category Development/Languages
Homepage http://ruby-lang.org/
License (Ruby or BSD) and Public Domain and MIT and CC0 and zlib and UCD
Maintainer -
Download size 73.30 KB
Installed size 67.24 KB
Ruby is the interpreted scripting language for quick and easy
object-oriented programming.  It has many features to process text
files and to do system management tasks (as in Perl).  It is simple,
straight-forward, and extensible.

Alternatives

Package Version Architecture Repository
rh-ruby23-ruby-2.3.8-70.el6.x86_64.rpm 2.3.8 x86_64 CentOS SCLo RH Testing
rh-ruby23-ruby-2.3.8-69.sc1.el6.x86_64.rpm 2.3.8 x86_64 CentOS SCLo RH Testing
rh-ruby23-ruby-2.3.8-69.sc1.el6.x86_64.rpm 2.3.8 x86_64 CentOS SCLo RH
rh-ruby23-ruby-2.3.6-67.el6.x86_64.rpm 2.3.6 x86_64 CentOS SCLo RH Testing
rh-ruby23-ruby-2.3.6-67.el6.x86_64.rpm 2.3.6 x86_64 CentOS SCLo RH
rh-ruby23-ruby-2.3.1-64.el6.x86_64.rpm 2.3.1 x86_64 CentOS SCLo RH Testing
rh-ruby23-ruby-2.3.1-64.el6.x86_64.rpm 2.3.1 x86_64 CentOS SCLo RH
rh-ruby23-ruby - - -

Requires

Name Value
libc.so.6(GLIBC_2.2.5)(64bit) -
libcrypt.so.1()(64bit) -
libdl.so.2()(64bit) -
libm.so.6()(64bit) -
libpthread.so.0()(64bit) -
librt.so.1()(64bit) -
libruby.so.2.3()(64bit) -
rh-ruby23-ruby(rubygems) >= 2.5.2.3
rh-ruby23-ruby-libs(x86-64) = 2.3.8-70.el6
rh-ruby23-rubygem(bigdecimal) >= 1.2.8
rh-ruby23-rubygem(did_you_mean) >= 1.0.0
rtld(GNU_HASH) -

Provides

Name Value
rh-ruby23-ruby = 2.3.8-70.el6
rh-ruby23-ruby(x86-64) = 2.3.8-70.el6
ruby(runtime_executable) = 2.3.8

Download

Type URL
Mirror mirror.centos.org
Binary Package rh-ruby23-ruby-2.3.8-70.el6.x86_64.rpm
Source Package rh-ruby23-ruby-2.3.8-70.el6.src.rpm

Install Howto

  1. Install CentOS SCLo RH repository:
    yum install centos-release-scl-rh
  2. Install rh-ruby23-ruby rpm package:
    # yum install rh-ruby23-ruby

Files

Path
/opt/rh/rh-ruby23/root/usr/bin/erb
/opt/rh/rh-ruby23/root/usr/bin/ruby
/opt/rh/rh-ruby23/root/usr/share/doc/rh-ruby23-ruby-2.3.8/BSDL
/opt/rh/rh-ruby23/root/usr/share/doc/rh-ruby23-ruby-2.3.8/COPYING
/opt/rh/rh-ruby23/root/usr/share/doc/rh-ruby23-ruby-2.3.8/COPYING.ja
/opt/rh/rh-ruby23/root/usr/share/doc/rh-ruby23-ruby-2.3.8/GPL
/opt/rh/rh-ruby23/root/usr/share/doc/rh-ruby23-ruby-2.3.8/LEGAL
/opt/rh/rh-ruby23/root/usr/share/man/man1/erb.1.gz
/opt/rh/rh-ruby23/root/usr/share/man/man1/ruby.1.gz

Changelog

2019-04-12 - Jun Aruga <jaruga@redhat.com> - 2.3.8-70
- Refresh expired certificates.
- Prohibit arbitrary code execution when installing a malicious gem.
Resolves: CVE-2019-8324
2018-11-22 - Pavel Valena <pvalena@redhat.com> - 2.3.8-69
- Rebuild with correct remote branch
Related: rhbz#1650591
2018-11-05 - Pavel Valena <pvalena@redhat.com> - 2.3.8-68
- Upgrade to Ruby 2.3.8.
Resolves: CVE-2018-16395
Resolves: CVE-2018-16396
Resolves: rhbz#1563078
Removed Patch11: ruby-2.5.0-Disable-Tokyo-TZ-tests.patch; subsumed
- Properly harden package using -fstack-protector-strong.
- Fix: return default path with nonexistent home dir(rhbz#1602880)
2018-03-12 - Pavel Valena <pvalena@redhat.com> - 2.3.6-67
- Command injection in lib/resolv.rb:lazy_initialize() allows arbitrary code
execution(CVE-2017-17790).
* ruby-2.5.0-Fixed-command-Injection.patch
Related: rhbz#1549649
2018-02-13 - Pavel Valena <pvalena@redhat.com> - 2.3.6-66
- Upgrade to Ruby 2.3.6.
Resolves: rhbz#1549649
Resolves: CVE-2017-17405
2016-10-26 - Pavel Valena <pvalena@redhat.com> - 2.3.1-64
- Fix: do not fail in operating_system.rb when X_SCLS is empty
Resolves: rhbz#1387139
2016-10-17 - Pavel Valena <pvalena@redhat.com> - 2.3.1-63
- Support in no_proxy for domain names with whitespaces and leading dots
Resolves: rhbz#1384810
2016-08-12 - Pavel Valena <pvalena@redhat.com> - 2.3.1-62
- Fix support for dependent^2 SCLs
- Update to Ruby 2.3.1
* Remove Patch8:
ruby-2.3.0-undef-BUILTIN_CHOOSE_EXPR_CONSTANT_P.patch; subsumed
* Remove Patch10:
ruby-2.3.1-remove-tests-depending-on-europe-moscow.patch; subsumed
also removed "UTC=TZ " tests prefix
2016-07-25 - Pavel Valena <pvalena@redhat.com> - 2.3.0-61
- Add %{scl}-runtime to Requires in libs subpackage
2016-07-19 - Pavel Valena <pvalena@redhat.com> - 2.3.0-60
- Fix and enhance systemtap tests
- Remove tests depending on Europe/Moscow to avoid failures due to tzdata change

See Also

Package Description
rh-ruby23-ruby-devel-2.3.1-64.el6.x86_64.rpm A Ruby development environment
rh-ruby23-ruby-devel-2.3.6-67.el6.x86_64.rpm A Ruby development environment
rh-ruby23-ruby-devel-2.3.8-69.sc1.el6.x86_64.rpm A Ruby development environment
rh-ruby23-ruby-devel-2.3.8-70.el6.x86_64.rpm A Ruby development environment
rh-ruby23-ruby-doc-2.3.1-64.el6.noarch.rpm Documentation for ruby
rh-ruby23-ruby-doc-2.3.6-67.el6.noarch.rpm Documentation for ruby
rh-ruby23-ruby-doc-2.3.8-69.sc1.el6.noarch.rpm Documentation for ruby
rh-ruby23-ruby-doc-2.3.8-70.el6.noarch.rpm Documentation for ruby
rh-ruby23-ruby-irb-2.3.1-64.el6.noarch.rpm The Interactive Ruby
rh-ruby23-ruby-irb-2.3.6-67.el6.noarch.rpm The Interactive Ruby
rh-ruby23-ruby-irb-2.3.8-69.sc1.el6.noarch.rpm The Interactive Ruby
rh-ruby23-ruby-irb-2.3.8-70.el6.noarch.rpm The Interactive Ruby
rh-ruby23-ruby-libs-2.3.1-64.el6.x86_64.rpm Libraries necessary to run Ruby
rh-ruby23-ruby-libs-2.3.6-67.el6.x86_64.rpm Libraries necessary to run Ruby
rh-ruby23-ruby-libs-2.3.8-69.sc1.el6.x86_64.rpm Libraries necessary to run Ruby
Advertisement
Advertisement