xulrunner-17.0.10-1.el6.centos.i686.rpm


Advertisement

Description

xulrunner - XUL Runtime for Gecko Applications

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename xulrunner-17.0.10-1.el6.centos.i686.rpm
Package name xulrunner
Package version 17.0.10
Package release 1.el6.centos
Package architecture i686
Package type rpm
Category Applications/Internet
Homepage http://developer.mozilla.org/En/XULRunner
License MPLv1.1 or GPLv2+ or LGPLv2+
Maintainer -
Download size 14.13 MB
Installed size 35.99 MB
XULRunner is a Mozilla runtime package that can be used to bootstrap XUL+XPCOM
applications that are as rich as Firefox and Thunderbird. It provides mechanisms
for installing, upgrading, and uninstalling these applications. XULRunner also
provides libxul, a solution which allows the embedding of Mozilla technologies
in other projects and products.

Alternatives

Package Version Architecture Repository
xulrunner-17.0.10-1.el6.centos.x86_64.rpm 17.0.10 x86_64 CentOS
xulrunner-17.0.10-1.el6.centos.i686.rpm 17.0.10 i686 CentOS
xulrunner - - -

Requires

Name Value
/sbin/ldconfig -
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libX11.so.6 -
libXext.so.6 -
libXrender.so.1 -
libXt.so.6 -
libasound.so.2 -
libatk-1.0.so.0 -
libc.so.6(GLIBC_2.7) -
libcairo.so.2 -
libdbus-1.so.3 -
libdbus-glib-1.so.2 -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
liberation-fonts-common -
liberation-sans-fonts -
libfontconfig.so.1 -
libfreetype.so.6 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.4) -
libgcc_s.so.1(GLIBC_2.0) -
libgconf-2.so.4 -
libgdk-x11-2.0.so.0 -
libgdk_pixbuf-2.0.so.0 -
libgio-2.0.so.0 -
libglib-2.0.so.0 -
libgmodule-2.0.so.0 -
libgnomevfs-2.so.0 -
libgobject-2.0.so.0 -
libgthread-2.0.so.0 -
libgtk-x11-2.0.so.0 -
libhunspell-1.2.so.0 -
libjpeg.so.62 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libnspr4.so -
libnss3.so -
libnssutil3.so -
libpango-1.0.so.0 -
libpangocairo-1.0.so.0 -
libpangoft2-1.0.so.0 -
libplc4.so -
libplds4.so -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.2) -
libpthread.so.0(GLIBC_2.2.3) -
libpthread.so.0(GLIBC_2.3.2) -
libpthread.so.0(GLIBC_2.3.3) -
librt.so.1 -
librt.so.1(GLIBC_2.2) -
libsmime3.so -
libssl3.so -
libstartup-notification-1.so.0 -
libstdc++.so.6 -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.9) -
libz.so.1 -
mozilla-filesystem -
nspr >= 4.9.2
nss >= 3.14.0

Provides

Name Value
gecko-libs = 17.0.10
gecko-libs(x86-32) = 17.0.10
libdbusservice.so -
libdbusservice.so(EXPORTED) -
libmozalloc.so -
libmozgnome.so -
libmozgnome.so(EXPORTED) -
libmozsqlite3.so -
libnkgnomevfs.so -
libnkgnomevfs.so(EXPORTED) -
libxpcom.so -
libxul.so -
xulrunner = 17.0.10-1.el6.centos
xulrunner(x86-32) = 17.0.10-1.el6.centos

Conflicts

Name Value
firefox < 3.6

Download

Type URL
Mirror mirror.centos.org
Binary Package xulrunner-17.0.10-1.el6.centos.i686.rpm
Source Package xulrunner-17.0.10-1.el6.centos.src.rpm

Install Howto

Install xulrunner rpm package:

# yum install xulrunner

Files

Path
/etc/ld.so.conf.d/xulrunner-32.conf
/usr/bin/xulrunner
/usr/lib/xulrunner/LICENSE
/usr/lib/xulrunner/README.xulrunner
/usr/lib/xulrunner/chrome.manifest
/usr/lib/xulrunner/dependentlibs.list
/usr/lib/xulrunner/dictionaries
/usr/lib/xulrunner/libmozalloc.so
/usr/lib/xulrunner/libmozsqlite3.so
/usr/lib/xulrunner/libxpcom.so
/usr/lib/xulrunner/libxul.so
/usr/lib/xulrunner/mozilla-xremote-client
/usr/lib/xulrunner/omni.ja
/usr/lib/xulrunner/platform.ini
/usr/lib/xulrunner/plugin-container
/usr/lib/xulrunner/run-mozilla.sh
/usr/lib/xulrunner/xulrunner
/usr/lib/xulrunner/xulrunner-stub
/usr/lib/xulrunner/chrome/
/usr/lib/xulrunner/chrome/icons/
/usr/lib/xulrunner/chrome/icons/default/default16.png
/usr/lib/xulrunner/chrome/icons/default/default32.png
/usr/lib/xulrunner/chrome/icons/default/default48.png
/usr/lib/xulrunner/components/binary.manifest
/usr/lib/xulrunner/components/compreg.dat
/usr/lib/xulrunner/components/libdbusservice.so
/usr/lib/xulrunner/components/libmozgnome.so
/usr/lib/xulrunner/components/libnkgnomevfs.so
/usr/lib/xulrunner/components/xpti.dat
/usr/lib/xulrunner/defaults/
/usr/lib/xulrunner/defaults/pref/all-redhat.js
/usr/lib/xulrunner/plugins/

Changelog

2013-10-29 - Johnny Hughes <johnny@centos.org> - 17.0.10-1
- Roll in CentOS Branding
2013-10-23 - Martin Stransky <stransky@redhat.com> - 17.0.10-1
- Update to 17.0.10 ESR
2013-10-11 - Martin Stransky <stransky@redhat.com> - 17.0.9-2
- Added patch for rhbz#983488 - Resizing window changes window
size to 0 with third party window manager.
2013-09-12 - Jan Horak <jhorak@redhat.com> - 17.0.9-1
- Update to 17.0.9 ESR
2013-09-04 - Jan Horak <jhorak@redhat.com> - 17.0.8-5
- Fixed mozbz#633001 - Cannot open ipv6 address with self-signed certificate
2013-09-03 - Martin Stransky <stransky@redhat.com> - 17.0.8-4
- Fixed rhbz#818636 - Firefox allows install of addons,
disregarding xpinstall.enabled flag set as false.
2013-08-06 - Martin Stransky <stransky@redhat.com> - 17.0.8-3
- Update to 17.0.8 ESR Build 2
2013-08-01 - Martin Stransky <stransky@redhat.com> - 17.0.8-2
- Added fix for rhbz#990921 - firefox does not build with 
required nss/nspr
2013-07-31 - Martin Stransky <stransky@redhat.com> - 17.0.8-1
- Update to 17.0.8 ESR
2013-06-19 - Jan Horak <jhorak@redhat.com> - 17.0.7-1
- Update to 17.0.7 ESR

See Also

Package Description
xulrunner-devel-17.0.10-1.el6.centos.i686.rpm Development files for Gecko
xvattr-1.3-18.el6.i686.rpm Utility for getting and setting Xv attributes
xz-4.999.9-0.5.beta.20091007git.el6.i686.rpm LZMA compression utilities
xz-devel-4.999.9-0.5.beta.20091007git.el6.i686.rpm Devel libraries & headers for liblzma
xz-libs-4.999.9-0.5.beta.20091007git.el6.i686.rpm Libraries for decoding LZMA compression
xz-lzma-compat-4.999.9-0.5.beta.20091007git.el6.i686.rpm Older LZMA format compatibility binaries
yajl-1.0.7-3.el6.i686.rpm Yet Another JSON Library (YAJL)
yajl-devel-1.0.7-3.el6.i686.rpm Libraries, includes, etc to develop with YAJL
yap-5.1.3-2.1.el6.i686.rpm High-performance Prolog Compiler
yap-devel-5.1.3-2.1.el6.i686.rpm C-Interface development files for Yap
yap-docs-5.1.3-2.1.el6.i686.rpm Documentation for Yap
yelp-2.28.1-17.el6_3.i686.rpm Help browser for the GNOME desktop
yp-tools-2.9-12.el6.i686.rpm NIS (or YP) client programs
ypbind-1.20.4-33.el6.i686.rpm The NIS daemon which binds NIS clients to an NIS domain
ypserv-2.19-31.el6.i686.rpm The NIS (Network Information Service) server
Advertisement
Advertisement