ruby-static-1.8.7.374-5.el6.i686.rpm


Advertisement

Description

ruby-static - Static libraries for Ruby development environment

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename ruby-static-1.8.7.374-5.el6.i686.rpm
Package name ruby-static
Package version 1.8.7.374
Package release 5.el6
Package architecture i686
Package type rpm
Category Development/Languages
Homepage http://www.ruby-lang.org/
License Ruby or GPLv2
Maintainer -
Download size 472.58 KB
Installed size 1.39 MB
Static libraries for for building a extension library for the
Ruby or an application embedded Ruby.

Alternatives

Package Version Architecture Repository
ruby-static-1.8.7.374-5.el6.x86_64.rpm 1.8.7.374 x86_64 CentOS
ruby-static - - -

Requires

Name Value
ruby-devel = 1.8.7.374-5.el6

Provides

Name Value
ruby-static = 1.8.7.374-5.el6
ruby-static(x86-32) = 1.8.7.374-5.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package ruby-static-1.8.7.374-5.el6.i686.rpm
Source Package ruby-1.8.7.374-5.el6.src.rpm

Install Howto

Install ruby-static rpm package:

# yum install ruby-static

Files

Path
/usr/lib/libruby-static.a

Changelog

2016-09-21 - Vít Ondruch <vondruch@redhat.com> - 1.8.7.374-5
- Prevent Resolv::DNS from returning truncated dns replies.
Resolves: rhbz#1331086
2015-02-16 - Vít Ondruch <vondruch@redhat.com> - 1.8.7.374-4
- Fix broken DNS Resolv when resolv.conf has option ndots > 1.
Resolves: rhbz#1132704
2014-11-16 - Vít Ondruch <vondruch@redhat.com> - 1.8.7.374-3
- Fix REXML billion laughs attack via parameter entity expansion
(CVE-2014-8080).
Resolves: rhbz#1163994
- REXML incomplete fix for CVE-2014-8080 (CVE-2014-8090).
Resolves: rhbz#1163994
2014-08-12 - Vít Ondruch <vondruch@redhat.com> - 1.8.7.374-2
- Replace hardcoded MD5 by sha256 to prevent SSL server failure in FIPS mode.
* ruby-1.8.7-p374-Replace-md5-by-sha256-to-fix-SSL-server-FIPS-compatibility.patch
- Resolves: rhbz#802946
2014-05-09 - Vít Ondruch <vondruch@redhat.com> - 1.8.7.374-1
- Update to Ruby 1.8.7-p374.
* Remove Patch41: ruby-ppc64-segv-fix.patch; subsumed
* Remove Patch45: ruby-1.8.7-CVE-2011-0188.patch; subsumed
* Remove Patch46: ruby-1.8.7-FIPS.patch; subsumed
* Remove Patch47: ruby-1.8.7-p352-mkconfig.rb-fix-for-continued-lines.patch; subsumed
* Remove Patch48: ruby-1.8.7-p352-CVE-2011-4815.patch; subsumed
* Remove Patch49: ruby-1.8.7-p358-marshal-load-segv-fix.patch; subsumed
* Remove Patch50: ruby-2.0.0-entity-expansion-DoS-vulnerability-in-REXML.patch; subsumed
* Remove Patch51: ruby-2.0.0-add-missing-rexml-require.patch; subsumed
* Remove Patch52: ruby-1.8.7-p371-CVE-2012-4481.patch; subsumed
* Remove Patch53: ruby-1.8.7-p374-CVE-2013-4073-fix-hostname-verification.patch; subsumed
Resolves: rhbz#830098
- Enable ECC support, provided by OpenSSL, in Ruby
* ruby-1.9.3-p482-Fix-build-against-OpenSSL-with-enabled-ECC-curves.patch
Resolves: rhbz#1033864
- Exclude test that fails when issuing a certificate with RSA signature and
DSS1 digest for earlier OpenSSL versions when used in conjunction with
OpenSSL 1.0.1.
* ruby-1.9.3-p172-Exclude-failing-tests-written-for-earlier-OpenSSL.patch
Resolves: rhbz#1034351
- Rename Tracer.fire to SystemTap.fire to avoid conflict with Ruby's tracer.
Resolves: rhbz#784766
2013-11-22 - Vít Ondruch <vondruch@redhat.com> - 1.8.7.352-13
- Workaround build issues against OpenSSL with enabled ECC curves.
- Make DRb compatible with OpenSSL 1.0.1.
* ruby-1.9.3-p222-generate-1024-bits-RSA-key-instead-of-512-bits.patch
- Fix CVE-2013-4164 Heap Overflow in Floating Point Parsing
* ruby-1.9.3-p484-CVE-2013-4164-ignore-too-long-fraction-part-which-does-not-affect-the-result.patch
- Resolves: rhbz#1033502
2013-07-08 - Vít Ondruch <vondruch@redhat.com> - 1.8.7.352-12
- Fix regression introduced by CVE-2013-4073
https://bugs.ruby-lang.org/issues/8575
* ruby-2.0.0-p255-Fix-SSL-client-connection-crash-for-SAN-marked-critical.patch
- Related: rhbz#979301
2013-06-28 - Vít Ondruch <vondruch@redhat.com> - 1.8.7.352-11
- hostname check bypassing vulnerability in SSL client.
* ruby-1.8.7-p374-CVE-2013-4073-fix-hostname-verification.patch
- Resolves: rhbz#979301
2013-03-01 - Vít Ondruch <vondruch@redhat.com> - 1.8.7.352-10
- $SAFE escaping vulnerability about Exception#to_s / NameError#to_s
* ruby-1.8.7-p371-CVE-2012-4481.patch
- Related: rhbz#915380
2013-02-28 - Vít Ondruch <vondruch@redhat.com> - 1.8.7.352-9
- Fix regression introduced by fix for entity expansion DOS vulnerability
in REXML (https://bugs.ruby-lang.org/issues/7961)
* ruby-2.0.0-add-missing-rexml-require.patch
- Related: rhbz#915380

See Also

Package Description
ruby-tcltk-1.8.7.374-5.el6.i686.rpm Tcl/Tk interface for scripting language Ruby
rubygem-flexmock-0.8.6-1.1.el6.noarch.rpm Mock object library for ruby
rubygem-flexmock-doc-0.8.6-1.1.el6.noarch.rpm Documentation for rubygem-flexmock
rubygem-rake-0.8.7-2.1.el6.noarch.rpm Ruby based make-like utility
rubygems-1.3.7-5.el6.noarch.rpm The Ruby standard for packaging ruby libraries
rubygems-devel-1.3.7-5.el6.noarch.rpm Macros and development tools for packaging RubyGems
rusers-0.17-61.el6.i686.rpm Displays the users logged into machines on the local network
rusers-server-0.17-61.el6.i686.rpm Server for the rusers protocol
rwho-0.17-34.el6.i686.rpm Displays who is logged in to local network machines
saab-fonts-0.91-4.el6.noarch.rpm Free Punjabi Unicode OpenType Font
sabayon-2.29.92-3.el6.i686.rpm Tool to maintain user profiles in a GNOME desktop
sabayon-apply-2.29.92-3.el6.i686.rpm The parts of sabayon needed on the client systems
sac-1.3-5.1.el6.i686.rpm Java standard interface for CSS parser
sac-javadoc-1.3-5.1.el6.noarch.rpm Javadoc for sac
samba-3.6.23-51.el6.i686.rpm Server and Client software to interoperate with Windows machines
Advertisement
Advertisement