ruby-flexmock-0.8.6-1.1.el6.noarch.rpm


Advertisement

Description

ruby-flexmock - Non-Gem support package for flexmock

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename ruby-flexmock-0.8.6-1.1.el6.noarch.rpm
Package name ruby-flexmock
Package version 0.8.6
Package release 1.1.el6
Package architecture noarch
Package type rpm
Category Development/Languages
Homepage http://flexmock.rubyforge.org
License Copyright only
Maintainer -
Download size 10.00 KB
Installed size unknown
This package provides non-Gem support for flexmock.

Alternatives

Package Version Architecture Repository
ruby-flexmock-0.8.6-1.1.el6.noarch.rpm 0.8.6 noarch CentOS
ruby-flexmock - - -

Requires

Name Value
rubygem-flexmock = 0.8.6-1.1.el6

Provides

Name Value
ruby(flexmock) = 0.8.6-1.1.el6
ruby-flexmock = 0.8.6-1.1.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package ruby-flexmock-0.8.6-1.1.el6.noarch.rpm
Source Package rubygem-flexmock-0.8.6-1.1.el6.src.rpm

Install Howto

Install ruby-flexmock rpm package:

# yum install ruby-flexmock

Files

Path
/usr/lib/ruby/site_ruby/1.8/flexmock.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/argument_matchers.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/argument_types.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/base.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/composite.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/core.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/core_class_methods.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/default_framework_adapter.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/deprecated_methods.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/errors.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/expectation.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/expectation_director.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/mock_container.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/noop.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/ordering.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/partial_mock.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/rails.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/recorder.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/rspec.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/test_unit.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/test_unit_integration.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/undefined.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/validators.rb
/usr/lib/ruby/site_ruby/1.8/flexmock/rails/view_mocking.rb

Changelog

2009-11-30 - Dennis Gregorovic <dgregor@redhat.com> - 0.8.6-1.1
- Rebuilt for RHEL 6
2009-07-30 - Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.8.6-1
- Switch to gem, repackage
2009-07-26 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
2009-02-25 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
2007-11-08 - Paul Nasrat <pauln@truemesh.com> - 0.7.1-3
- Fix repoid
2007-11-07 - Paul Nasrat <pauln@truemesh.com> - 0.7.1-2
- Spec cleanups in response to review
- Fix license
- strip out shebangs
2007-09-09 - Paul Nasrat <pauln@truemesh.com> - 0.7.1-1
- Initial vesion

See Also

Package Description
ruby-irb-1.8.7.374-5.el6.i686.rpm The Interactive Ruby
ruby-libs-1.8.7.374-5.el6.i686.rpm Libraries necessary to run Ruby
ruby-qpid-0.7.946106-2.el6.i686.rpm Ruby language client for AMQP
ruby-qpid-qmf-0.14-14.el6_3.i686.rpm The QPID Management Framework bindings for ruby
ruby-rdoc-1.8.7.374-5.el6.i686.rpm A tool to generate documentation from Ruby source files
ruby-ri-1.8.7.374-5.el6.i686.rpm Ruby interactive reference
ruby-saslwrapper-0.14-1.el6.i686.rpm Ruby bindings for saslwrapper
ruby-static-1.8.7.374-5.el6.i686.rpm Static libraries for Ruby development environment
ruby-tcltk-1.8.7.374-5.el6.i686.rpm Tcl/Tk interface for scripting language Ruby
rubygem-flexmock-0.8.6-1.1.el6.noarch.rpm Mock object library for ruby
rubygem-flexmock-doc-0.8.6-1.1.el6.noarch.rpm Documentation for rubygem-flexmock
rubygem-rake-0.8.7-2.1.el6.noarch.rpm Ruby based make-like utility
rubygems-1.3.7-5.el6.noarch.rpm The Ruby standard for packaging ruby libraries
rubygems-devel-1.3.7-5.el6.noarch.rpm Macros and development tools for packaging RubyGems
rusers-0.17-61.el6.i686.rpm Displays the users logged into machines on the local network
Advertisement
Advertisement