python-volume_key-0.3.1-5.el6.i686.rpm


Advertisement

Description

python-volume_key - Python bindings for libvolume_key

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename python-volume_key-0.3.1-5.el6.i686.rpm
Package name python-volume_key
Package version 0.3.1
Package release 5.el6
Package architecture i686
Package type rpm
Category System Environment/Libraries
Homepage https://fedorahosted.org/volume_key/
License GPLv2
Maintainer -
Download size 26.86 KB
Installed size 73.03 KB
This package provides Python bindings for libvolume_key, a library for
manipulating storage volume encryption keys and storing them separately from
volumes.
The main goal of the software is to allow restoring access to an encrypted
hard drive if the primary user forgets the passphrase.  The encryption key
back up can also be useful for extracting data after a hardware or software
failure that corrupts the header of the encrypted volume, or to access the
company data after an employee leaves abruptly.
volume_key currently supports only the LUKS volume encryption format.  Support
for other formats is possible, some formats are planned for future releases.

Alternatives

Package Version Architecture Repository
python-volume_key-0.3.1-5.el6.x86_64.rpm 0.3.1 x86_64 CentOS
python-volume_key - - -

Requires

Name Value
libblkid.so.1 -
libc.so.6(GLIBC_2.4) -
libcryptsetup.so.1 -
libdl.so.2 -
libglib-2.0.so.0 -
libgpgme.so.11 -
libnspr4.so -
libnss3.so -
libnss3.so(NSS_3.2) -
libnssutil3.so -
libplc4.so -
libplds4.so -
libpthread.so.0 -
libpython2.6.so.1.0 -
libsmime3.so -
libsmime3.so(NSS_3.4) -
libssl3.so -
libvolume_key.so.1 -
python(abi) = 2.6
rtld(GNU_HASH) -
volume_key-libs = 0.3.1-5.el6

Provides

Name Value
_volume_key.so -
python-volume_key = 0.3.1-5.el6
python-volume_key(x86-32) = 0.3.1-5.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package python-volume_key-0.3.1-5.el6.i686.rpm
Source Package volume_key-0.3.1-5.el6.src.rpm

Install Howto

Install python-volume_key rpm package:

# yum install python-volume_key

Files

Path
/usr/lib/python2.6/site-packages/_volume_key.so
/usr/lib/python2.6/site-packages/volume_key.py
/usr/lib/python2.6/site-packages/volume_key.pyc
/usr/lib/python2.6/site-packages/volume_key.pyo

Changelog

2011-01-20 - Miloslav Trmač <mitr@redhat.com> - 0.3.1-5
- Rebuild for fastrack
Related: #636541 #638732 #641111 #643897
2011-01-14 - Miloslav Trmač <mitr@redhat.com> - 0.3.1-4
- Clarify documentation about which block device to use as an argument
Resolves: #636541
- Report readable error messages instead of random characters in some cases
Resolves: #638732
- Make passphrase prompts interruptable, report incorrect passphrases
Resolves: #641111
- Ask for passphrases only after checking for easily detectable problems
Resolves: #643897
2010-04-28 - Miloslav Trmač <mitr@redhat.com> - 0.3.1-3
- Update translations
Resolves: #585836
2010-02-05 - Miloslav Trmač <mitr@redhat.com> - 0.3.1-2
- Fix a crash when an empty passphrase is provided
Resolves: #558410
2009-12-11 - Miloslav Trmač <mitr@redhat.com> - 0.3.1-1
- Update to volume_key-0.3.1.
2009-09-30 - Miloslav Trmač <mitr@redhat.com> - 0.3-1
- Update to volume_key-0.3.
- Drop bundled libcryptsetup.
2009-08-08 - Miloslav Trmač <mitr@redhat.com> - 0.2-3
- Handle changed "TYPE=crypto_LUKS" from libblkid
- Preserve file timestamps during installation
2009-07-26 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
2009-06-30 - Miloslav Trmač <mitr@redhat.com> - 0.2-1
- Initial build.

See Also

Package Description
python-weberror-0.10.2-2.el6.noarch.rpm Web Error handling and exception catching middleware
python-webflash-0.1-0.2.a9.el6.noarch.rpm Portable flash messages for WSGI apps
python-webhelpers-0.6.4-4.el6.noarch.rpm Helper library for aiding the writing of web templates in Python
python-webob-0.9.6.1-3.el6.noarch.rpm WSGI request and response object
python-webtest-1.2-2.el6.noarch.rpm Helper to test WSGI applications
python-wsgiproxy-0.2-1.el6.noarch.rpm HTTP proxying tools for WSGI apps
python-zope-filesystem-1-5.el6.i686.rpm Python-Zope Libraries Base Filesystem
python-zope-interface-3.5.2-2.1.el6.i686.rpm Zope 3 Interface Infrastructure
python-zope-sqlalchemy-0.4-3.el6.noarch.rpm Minimal Zope/SQLAlchemy transaction integration
pytz-2010h-2.el6.noarch.rpm World Timezone Definitions for Python
pywbem-0.7.0-4.el6.noarch.rpm Python WBEM Client and Provider Interface
pywebkitgtk-1.1.6-4.el6.i686.rpm Python Bindings for WebKit-gtk
pyxdg-0.18-1.el6.noarch.rpm Python library to access freedesktop.org standards
pyxf86config-0.3.37-7.1.el6.i686.rpm Python wrappers for libxf86config
qca-ossl-2.0.0-0.8.beta3.1.el6.i686.rpm OpenSSL plugin for the Qt Cryptographic Architecture v2
Advertisement
Advertisement