postgresql-libs-8.4.20-8.el6_9.i686.rpm


Advertisement

Description

postgresql-libs - The shared libraries required for any PostgreSQL clients

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename postgresql-libs-8.4.20-8.el6_9.i686.rpm
Package name postgresql-libs
Package version 8.4.20
Package release 8.el6_9
Package architecture i686
Package type rpm
Category Applications/Databases
Homepage http://www.postgresql.org/
License PostgreSQL
Maintainer -
Download size 205.63 KB
Installed size 614.07 KB
The postgresql-libs package provides the essential shared libraries for any
PostgreSQL client program or interface. You will need to install this package
to use any other PostgreSQL package or any clients that need to connect to a
PostgreSQL server.

Alternatives

Package Version Architecture Repository
postgresql-libs-8.4.20-8.el6_9.x86_64.rpm 8.4.20 x86_64 CentOS
postgresql-libs-8.4.20-8.el6_9.i686.rpm 8.4.20 i686 CentOS
postgresql-libs - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4) -
libcrypt.so.1 -
libcrypto.so.10 -
libcrypto.so.10(libcrypto.so.10) -
libgssapi_krb5.so.2 -
libgssapi_krb5.so.2(gssapi_krb5_2_MIT) -
libldap_r-2.4.so.2 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
libssl.so.10 -
libssl.so.10(libssl.so.10) -
rtld(GNU_HASH) -

Provides

Name Value
libecpg.so.6 -
libecpg_compat.so.3 -
libpgtypes.so.3 -
libpq.so = 8.4.20-8.el6_9
libpq.so.5 -
postgresql-libs = 8.4.20-8.el6_9
postgresql-libs(x86-32) = 8.4.20-8.el6_9

Download

Type URL
Mirror mirror.centos.org
Binary Package postgresql-libs-8.4.20-8.el6_9.i686.rpm
Source Package postgresql-8.4.20-8.el6_9.src.rpm

Install Howto

Install postgresql-libs rpm package:

# yum install postgresql-libs

Files

Path
/usr/lib/libecpg.so.6
/usr/lib/libecpg.so.6.1
/usr/lib/libecpg_compat.so.3
/usr/lib/libecpg_compat.so.3.1
/usr/lib/libpgtypes.so.3
/usr/lib/libpgtypes.so.3.1
/usr/lib/libpq.so.5
/usr/lib/libpq.so.5.2
/usr/share/doc/postgresql-libs-8.4.20/COPYRIGHT
/usr/share/locale/cs/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/de/LC_MESSAGES/ecpglib6-8.4.mo
/usr/share/locale/de/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/es/LC_MESSAGES/ecpglib6-8.4.mo
/usr/share/locale/es/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/fr/LC_MESSAGES/ecpglib6-8.4.mo
/usr/share/locale/fr/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/it/LC_MESSAGES/ecpglib6-8.4.mo
/usr/share/locale/it/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/ja/LC_MESSAGES/ecpglib6-8.4.mo
/usr/share/locale/ja/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/ko/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/pl/LC_MESSAGES/ecpglib6-8.4.mo
/usr/share/locale/pl/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/pt_BR/LC_MESSAGES/ecpglib6-8.4.mo
/usr/share/locale/pt_BR/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/ru/LC_MESSAGES/ecpglib6-8.4.mo
/usr/share/locale/ru/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/sv/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/ta/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/tr/LC_MESSAGES/ecpglib6-8.4.mo
/usr/share/locale/tr/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/zh_CN/LC_MESSAGES/ecpglib6-8.4.mo
/usr/share/locale/zh_CN/LC_MESSAGES/libpq5-8.4.mo
/usr/share/locale/zh_TW/LC_MESSAGES/libpq5-8.4.mo

Changelog

2017-08-29 - Petr Kubat <pkubat@redhat.com> - 8.4.20-8
- backport fix for CVE-2017-7546 (rhbz#1484677)
2016-09-08 - Pavel Raiskup <praiskup@redhat.com> - 8.4.20-7
- backport PGSTARTTIMEOUT variable from latest RHSCL while reasonably
changing wait timeout to 2 seconds by default
2016-02-24 - Pavel Raiskup <praiskup@redhat.com> - 8.4.20-6
- allow TLS > 1.0 (rhbz#1287053)
2016-02-16 - Pavel Raiskup <praiskup@redhat.com> - 8.4.20-5
- fix for CVE-2016-0773 (rhbz#1308598)
- fix tests for new libxml2 (rhbz#1303972)
2015-10-21 - Pavel Raiskup <praiskup@redhat.com> - 8.4.20-4
- fix for CVE-2015-5288 (rhbz#1273446)
2015-05-27 - Pavel Raiskup <praiskup@redhat.com> - 8.4.20-3
- CVE-2015-3165, CVE-2015-3166, CVE-2015-3167
2015-03-10 - Pavel Raiskup <praiskup@redhat.com> - 8.4.20-2
- fix for CVE-2015-0241 CVE-2015-0243 CVE-2015-0244 CVE-2014-8161
(rhbz#1198651 & rhbz#1198652)
2014-02-18 - Pavel Raiskup <praiskup@redhat.com> - 8.4.20-1
- Update to PostgreSQL 8.4.20 (#1065843) for fixes described at
http://www.postgresql.org/docs/8.4/static/release-8-4-19.html
http://www.postgresql.org/docs/8.4/static/release-8-4-20.html
2013-10-11 - Pavel Raiskup <praiskup@redhat.com> - 8.4.18-1
- Update to PostgreSQL 8.4.18, for various fixes described at
http://www.postgresql.org/docs/8.4/static/release-8-4-14.html
http://www.postgresql.org/docs/8.4/static/release-8-4-15.html
http://www.postgresql.org/docs/8.4/static/release-8-4-16.html
http://www.postgresql.org/docs/8.4/static/release-8-4-17.html
http://www.postgresql.org/docs/8.4/static/release-8-4-18.html
including fixes for CVE-2013-0255, CVE-2013-1900 (#1017837)
2012-08-27 - Tom Lane <tgl@redhat.com> 8.4.13-1
- Update to PostgreSQL 8.4.13, for various fixes described at
http://www.postgresql.org/docs/8.4/static/release-8-4-13.html
including the fixes for CVE-2012-3488, CVE-2012-3489
Resolves: #852021

See Also

Package Description
postgresql-odbc-08.04.0200-1.el6.i686.rpm PostgreSQL ODBC driver
postgresql-plperl-8.4.20-8.el6_9.i686.rpm The Perl procedural language for PostgreSQL
postgresql-plpython-8.4.20-8.el6_9.i686.rpm The Python procedural language for PostgreSQL
postgresql-pltcl-8.4.20-8.el6_9.i686.rpm The Tcl procedural language for PostgreSQL
postgresql-server-8.4.20-8.el6_9.i686.rpm The programs needed to create and run a PostgreSQL server
postgresql-test-8.4.20-8.el6_9.i686.rpm The test suite distributed with PostgreSQL
pothana2000-fonts-1.3.2-3.el6.noarch.rpm Unicode compliant OpenType font for Telugu
powertop-2.3-4.el6.i686.rpm Power consumption monitor
ppl-0.10.2-11.el6.i686.rpm The Parma Polyhedra Library: a library of numerical abstractions
ppl-devel-0.10.2-11.el6.i686.rpm Development tools for the Parma Polyhedra Library C and C++ interfaces
ppl-docs-0.10.2-11.el6.i686.rpm Documentation for the Parma Polyhedra Library
ppl-gprolog-0.10.2-11.el6.i686.rpm The GNU Prolog interface of the Parma Polyhedra Library
ppl-gprolog-static-0.10.2-11.el6.i686.rpm The static archive for the GNU Prolog interface of the Parma Polyhedra Library
ppl-java-0.10.2-11.el6.i686.rpm The Java interface of the Parma Polyhedra Library
ppl-java-javadoc-0.10.2-11.el6.i686.rpm Javadocs for ppl-java
Advertisement
Advertisement