poppler-0.12.4-12.el6_9.i686.rpm


Advertisement

Description

poppler - PDF rendering library

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename poppler-0.12.4-12.el6_9.i686.rpm
Package name poppler
Package version 0.12.4
Package release 12.el6_9
Package architecture i686
Package type rpm
Category Development/Libraries
Homepage http://poppler.freedesktop.org/
License GPLv2
Maintainer -
Download size 554.66 KB
Installed size 1.63 MB
Poppler, a PDF rendering library, is a fork of the xpdf PDF
viewer developed by Derek Noonburg of Glyph and Cog, LLC.

Alternatives

Package Version Architecture Repository
poppler-0.12.4-12.el6_9.i686.rpm 0.12.4 i686 CentOS
poppler-0.12.4-12.el6_9.x86_64.rpm 0.12.4 x86_64 CentOS
poppler - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4) -
libfontconfig.so.1 -
libfreetype.so.6 -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libjpeg.so.62 -
libjpeg.so.62(LIBJPEG_6.2) -
liblcms.so.1 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libopenjpeg.so.2 -
libpng12.so.0 -
libpng12.so.0(PNG12_0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
poppler-data >= 0.4.0
rtld(GNU_HASH) -

Provides

Name Value
libpoppler.so.5 -
poppler = 0.12.4-12.el6_9
poppler(x86-32) = 0.12.4-12.el6_9

Download

Type URL
Mirror mirror.centos.org
Binary Package poppler-0.12.4-12.el6_9.i686.rpm
Source Package poppler-0.12.4-12.el6_9.src.rpm

Install Howto

Install poppler rpm package:

# yum install poppler

Files

Path
/usr/lib/libpoppler.so.5
/usr/lib/libpoppler.so.5.0.0
/usr/share/doc/poppler-0.12.4/COPYING
/usr/share/doc/poppler-0.12.4/README

Changelog

2017-08-10 - Caolán McNamara <caolanm@redhat.com> - 0.12.4-12
- Resolves: rhbz#1479815 CVE-2017-9776
2016-09-29 - Marek Kasik <mkasik@redhat.com> - 0.12.4-11
- Don't crash on streams without Length
- Resolves: #1302365
2016-03-11 - Marek Kasik <mkasik@redhat.com> - 0.12.4-10
- Use better default pixel size for printing of 0 width lines
- Resolves: #1316163
2015-12-09 - Martin Hatina <mhatina@redhat.com> - 0.12.4-9
- Identification of fonts directly from streams and files
- Resolves: #1208719
2015-12-01 - Martin Hatina <mhatina@redhat.com> - 0.12.4-8
- Embed type1 fonts to PostScript files correctly
- Resolves: #1232210
2015-11-30 - Martin Hatina <mhatina@redhat.com> - 0.12.4-7
- Fix lines disappearing when selecting paragraph
- Resolves: #614824
2015-11-26 - Martin Hatina <mhatina@redhat.com> - 0.12.4-6
- Silence illegal entry in bfrange block in ToUnicode CMap
- Resolves: #710816
2015-06-02 - Marek Kasik <mkasik@redhat.com> - 0.12.4-5
- Fix captions of push button fields.
- Resolves: #1191907
2010-10-06 - Marek Kasik <mkasik@redhat.com> - 0.12.4-4
- Add poppler-0.12.4-CVE-2010-3702.patch
(Properly initialize parser)
- Add poppler-0.12.4-CVE-2010-3703.patch
(Properly initialize stack)
- Add poppler-0.12.4-CVE-2010-3704.patch
(Fix crash in broken pdf (code < 0))
- Resolves: #639860
2010-05-05 - Marek Kasik <mkasik@redhat.com> - 0.12.4-3
- Don't detect overlaping cells as table
- Resolves: #588723

See Also

Package Description
poppler-data-0.4.0-1.el6.noarch.rpm Encoding files
poppler-devel-0.12.4-12.el6_9.i686.rpm Libraries and headers for poppler
poppler-glib-0.12.4-12.el6_9.i686.rpm Glib wrapper for poppler
poppler-glib-devel-0.12.4-12.el6_9.i686.rpm Development files for glib wrapper
poppler-qt-0.12.4-12.el6_9.i686.rpm Qt3 wrapper for poppler
poppler-qt-devel-0.12.4-12.el6_9.i686.rpm Development files for Qt3 wrapper
poppler-qt4-0.12.4-12.el6_9.i686.rpm Qt4 wrapper for poppler
poppler-qt4-devel-0.12.4-12.el6_9.i686.rpm Development files for Qt4 wrapper
poppler-utils-0.12.4-12.el6_9.i686.rpm Command line utilities for converting PDF files
popt-1.13-7.el6.i686.rpm C library for parsing command line parameters
popt-devel-1.13-7.el6.i686.rpm Development files for the popt library
popt-static-1.13-7.el6.i686.rpm Static library for parsing command line parameters
portreserve-0.0.4-11.el6.i686.rpm TCP port reservation utility
postfix-2.6.6-8.el6.i686.rpm Postfix Mail Transport Agent
postfix-perl-scripts-2.6.6-8.el6.i686.rpm Postfix utilities written in perl
Advertisement
Advertisement