php-zts-5.3.3-49.el6.i686.rpm


Advertisement

Description

php-zts - Thread-safe PHP interpreter for use with the Apache HTTP Server

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename php-zts-5.3.3-49.el6.i686.rpm
Package name php-zts
Package version 5.3.3
Package release 49.el6
Package architecture i686
Package type rpm
Category Development/Languages
Homepage http://www.php.net/
License PHP
Maintainer -
Download size 1.18 MB
Installed size 3.48 MB
The php-zts package contains a module for use with the Apache HTTP
Server which can operate under a threaded server processing model.

Alternatives

Package Version Architecture Repository
php-zts-5.3.3-49.el6.x86_64.rpm 5.3.3 x86_64 CentOS
php-zts - - -

Requires

Name Value
httpd-mmn = 20051115
libbz2.so.1 -
libc.so.6(GLIBC_2.8) -
libcom_err.so.2 -
libcrypt.so.1 -
libcrypto.so.10 -
libcrypto.so.10(OPENSSL_1.0.1) -
libcrypto.so.10(libcrypto.so.10) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgmp.so.3 -
libgssapi_krb5.so.2 -
libk5crypto.so.3 -
libkrb5.so.3 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libnsl.so.1 -
libpcre.so.0 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
libssl.so.10 -
libssl.so.10(libssl.so.10) -
libxml2.so.2 -
libxml2.so.2(LIBXML2_2.4.30) -
libxml2.so.2(LIBXML2_2.5.2) -
libxml2.so.2(LIBXML2_2.6.0) -
libxml2.so.2(LIBXML2_2.6.11) -
libxml2.so.2(LIBXML2_2.6.5) -
libz.so.1 -
php-common(x86-32) = 5.3.3-49.el6
rtld(GNU_HASH) -

Provides

Name Value
libphp5.so -
php-zts = 5.3.3-49.el6
php-zts(x86-32) = 5.3.3-49.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package php-zts-5.3.3-49.el6.i686.rpm
Source Package php-5.3.3-49.el6.src.rpm

Install Howto

Install php-zts rpm package:

# yum install php-zts

Files

Path
/usr/lib/httpd/modules/libphp5-zts.so

Changelog

2016-11-07 - Remi Collet <rcollet@redhat.com> - 5.3.3-49
- fix php-soap fails to connect to HTTPS web service sporadically
as stream_socket_enable_crypto() uses NONBLOCK #1283153
2016-07-25 - Remi Collet <rcollet@redhat.com> - 5.3.3-48
- don't set environmental variable based on user supplied Proxy
request header CVE-2016-5385
2015-12-09 - Remi Collet <rcollet@redhat.com> - 5.3.3-47
- fix wrong warning in openssl_encrypt() for missing IV
when IV is not required #1260315
- fix segfault's when you try and allocate an SplFixedArray
with size >= 9999 #1071344
- segfault in php_pgsql_meta_data CVE-2015-4644  #1234434
- add options to enable TLS in curl #1255920
- fix segfault in gc_collect_cycles #1122681
2015-07-03 - Remi Collet <rcollet@redhat.com> - 5.3.3-46
- fix gzfile accept paths with NUL character #1213407
- fix patch for CVE-2015-4024
2015-06-10 - Remi Collet <rcollet@redhat.com> - 5.3.3-45
- fix more functions accept paths with NUL character #1213407
2015-06-08 - Remi Collet <rcollet@redhat.com> - 5.3.3-44
- soap: missing fix for #1222538 and #1204868
2015-06-05 - Remi Collet <rcollet@redhat.com> - 5.3.3-43
- core: fix multipart/form-data request can use excessive
amount of CPU usage CVE-2015-4024
- fix various functions accept paths with NUL character
CVE-2015-4026, #1213407
- ftp: fix integer overflow leading to heap overflow when
reading FTP file listing CVE-2015-4022
- phar: fix buffer over-read in metadata parsing CVE-2015-2783
- phar: invalid pointer free() in phar_tar_process_metadata()
CVE-2015-3307
- phar: fix buffer overflow in phar_set_inode() CVE-2015-3329
- phar: fix memory corruption in phar_parse_tarfile caused by
empty entry file name CVE-2015-4021
- soap: more fix type confusion through unserialize #1222538
2015-04-13 - Remi Collet <rcollet@redhat.com> - 5.3.3-42
- soap: more fix type confusion through unserialize #1204868
2015-04-09 - Remi Collet <rcollet@redhat.com> - 5.3.3-41
- core: fix double in zend_ts_hash_graceful_destroy CVE-2014-9425
- core: fix use-after-free in unserialize CVE-2015-2787
- exif: fix free on unitialized pointer CVE-2015-0232
- gd: fix buffer read overflow in gd_gif.c CVE-2014-9709
- date: fix use after free vulnerability in unserialize CVE-2015-0273
- enchant: fix heap buffer overflow in enchant_broker_request_dict
CVE-2014-9705
- phar: use after free in phar_object.c CVE-2015-2301
- soap: fix type confusion through unserialize
2014-10-23 - Jan Kaluza <jkaluza@redhat.com> - 5.3.3-40
- fileinfo: fix out-of-bounds read in elf note headers. CVE-2014-3710

See Also

Package Description
pidgin-2.7.9-28.el6.i686.rpm A Gtk+ based multiprotocol instant messaging client
pidgin-devel-2.7.9-28.el6.i686.rpm Development headers and libraries for pidgin
pidgin-docs-2.7.9-28.el6.i686.rpm API docs for pidgin and libpurple
pidgin-perl-2.7.9-28.el6.i686.rpm Perl scripting support for Pidgin
pilot-link-0.12.4-6.el6.i686.rpm File transfer utilities between Linux and PalmPilots
pilot-link-devel-0.12.4-6.el6.i686.rpm PalmPilot development header files
pilot-link-perl-0.12.4-6.el6.i686.rpm PalmPilot utilies written in perl
pinentry-0.7.6-8.el6.i686.rpm Collection of simple PIN or passphrase entry dialogs
pinentry-gtk-0.7.6-8.el6.i686.rpm Passphrase/PIN entry dialog based on GTK+
pinentry-qt-0.7.6-8.el6.i686.rpm Passphrase/PIN entry dialog based on Qt3
pinentry-qt4-0.7.6-8.el6.i686.rpm Passphrase/PIN entry dialog based on Qt4
pinfo-0.6.9-12.el6.i686.rpm An info file viewer
piranha-0.8.6-7.el6.i686.rpm Cluster administation tools
pixman-0.32.8-1.el6.i686.rpm Pixel manipulation library
pixman-devel-0.32.8-1.el6.i686.rpm Pixel manipulation library development package
Advertisement
Advertisement