perl-Params-Validate-0.92-3.el6.i686.rpm


Advertisement

Description

perl-Params-Validate - Params-Validate Perl module

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename perl-Params-Validate-0.92-3.el6.i686.rpm
Package name perl-Params-Validate
Package version 0.92
Package release 3.el6
Package architecture i686
Package type rpm
Category Development/Libraries
Homepage http://search.cpan.org/dist/Params-Validate/
License GPL+ or Artistic
Maintainer -
Download size 74.86 KB
Installed size 179.47 KB
The Params::Validate module allows you to validate method or function
call parameters to an arbitrary level of specificity. At the simplest
level, it is capable of validating the required parameters were given
and that no unspecified additional parameters were passed in. It is
also capable of determining that a parameter is of a specific type,
that it is an object of a certain class hierarchy, that it possesses
certain methods, or applying validation callbacks to arguments.

Alternatives

Package Version Architecture Repository
perl-Params-Validate-1.13-1.of.el6.i686.rpm 1.13 i686 Open Fusion
perl-Params-Validate-1.13-1.of.el6.x86_64.rpm 1.13 x86_64 Open Fusion
perl-Params-Validate-1.00-1.of.el6.i686.rpm 1.00 i686 Open Fusion
perl-Params-Validate-1.00-1.of.el6.x86_64.rpm 1.00 x86_64 Open Fusion
perl-Params-Validate-0.95-1.of.el6.i686.rpm 0.95 i686 Open Fusion
perl-Params-Validate-0.95-1.of.el6.x86_64.rpm 0.95 x86_64 Open Fusion
perl-Params-Validate-0.92-3.el6.x86_64.rpm 0.92 x86_64 CentOS
perl-Params-Validate - - -

Requires

Name Value
libc.so.6(GLIBC_2.1.3) -
perl(:MODULE_COMPAT_5.10.1) -
perl(Attribute::Handlers) -
perl(Exporter) -
perl(Scalar::Util) -
perl(XSLoader) -
perl(attributes) -
perl(strict) -
perl(vars) -
perl(warnings) -
rtld(GNU_HASH) -

Provides

Name Value
Validate.so -
perl(Attribute::Params::Validate) = 1.7
perl(Params::Validate) = 0.92
perl(Params::Validate) -
perl-Params-Validate = 0.92-3.el6
perl-Params-Validate(x86-32) = 0.92-3.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package perl-Params-Validate-0.92-3.el6.i686.rpm
Source Package perl-Params-Validate-0.92-3.el6.src.rpm

Install Howto

Install perl-Params-Validate rpm package:

# yum install perl-Params-Validate

Files

Path
/usr/lib/perl5/Attribute/
/usr/lib/perl5/Attribute/Params/Validate.pm
/usr/lib/perl5/Params/Validate.pm
/usr/lib/perl5/Params/ValidatePP.pm
/usr/lib/perl5/Params/ValidateXS.pm
/usr/lib/perl5/auto/Params/
/usr/lib/perl5/auto/Params/Validate/Validate.bs
/usr/lib/perl5/auto/Params/Validate/Validate.so
/usr/share/doc/perl-Params-Validate-0.92/Changes
/usr/share/doc/perl-Params-Validate-0.92/LICENSE
/usr/share/doc/perl-Params-Validate-0.92/README
/usr/share/doc/perl-Params-Validate-0.92/TODO
/usr/share/man/man3/Attribute::Params::Validate.3pm.gz
/usr/share/man/man3/Params::Validate.3pm.gz
/usr/share/man/man3/Params::ValidatePP.3pm.gz
/usr/share/man/man3/Params::ValidateXS.3pm.gz

Changelog

2010-01-15 - Marcela Mašláňová <mmaslano@redhat.com> - 0.92-3
- switch off Kwalitee tests, which we don't provide
- Resolves: rhbz#553449
2009-12-07 - Stepan Kasal <skasal@redhat.com> - 0.92-2
- rebuild against perl 5.10.1
2009-11-23 - Ralf Corsépius <corsepiu@fedoraproject.org> - 0.92-1
- Upstream update.
- Switch to Build.PL.
- Disable IS_MAINTAINER test.
2009-07-26 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
2009-02-26 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.91-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
2008-06-10 - Ralf Corsépius <rc040203@freenet.de> - 0.91-1
- Upstream update.
- Conditionally activate IS_MAINTAINER tests.
2008-02-27 - Tom "spot" Callaway <tcallawa@redhat.com> - 0.89-4
- Rebuild for perl 5.10 (again)
2008-02-10 - Ralf Corsépius <rc040203@freenet.de> - 0.89-3
- Rebuild for gcc43.
2008-01-15 - Tom "spot" Callaway <tcallawa@redhat.com> - 0.89-2
- rebuild for new perl
2007-11-13 - Ralf Corsépius <rc040203@freenet.de> - 0.89-1
- Upstream update.

See Also

Package Description
perl-Parse-CPAN-Meta-1.40-144.el6.i686.rpm Parse META.yml and other similar CPAN metadata files
perl-Parse-RecDescent-1.962.2-2.el6.noarch.rpm Parse-RecDescent Perl module
perl-Parse-Yapp-1.05-41.el6.noarch.rpm Perl extension for generating and using LALR parsers
perl-Perl-Critic-1.105-2.el6.noarch.rpm Critique Perl source code for best-practices
perl-Perl-MinimumVersion-1.20-3.el6.noarch.rpm Find a minimum required version of perl for Perl code
perl-Perlilog-0.3-4.el6.noarch.rpm Verilog environment and IP core handling in Perl
perl-Pod-Coverage-0.20-4.el6.noarch.rpm Checks if the documentation of a module is comprehensive
perl-Pod-Escapes-1.04-144.el6.i686.rpm Perl module for resolving POD escape sequences
perl-Pod-POM-0.25-2.el6.noarch.rpm Object-oriented interface to Perl POD documents
perl-Pod-Simple-3.13-144.el6.i686.rpm Framework for parsing POD documentation
perl-Pod-Spell-1.01-6.1.el6.noarch.rpm A formatter for spellchecking Pod
perl-Probe-Perl-0.01-4.el6.noarch.rpm Information about the currently running perl
perl-Readonly-1.03-11.el6.noarch.rpm Facility for creating read-only scalars, arrays, hashes
perl-Readonly-XS-1.05-3.el6.i686.rpm Companion module for Readonly
perl-SGMLSpm-1.03ii-21.el6.noarch.rpm Perl library for parsing the output of nsgmls
Advertisement
Advertisement