perl-PCP-PMDA-3.10.9-9.el6.i686.rpm


Advertisement

Description

perl-PCP-PMDA - Performance Co-Pilot (PCP) Perl bindings and documentation

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename perl-PCP-PMDA-3.10.9-9.el6.i686.rpm
Package name perl-PCP-PMDA
Package version 3.10.9
Package release 9.el6
Package architecture i686
Package type rpm
Category Development/Libraries
Homepage http://www.pcp.io
License GPLv2+
Maintainer -
Download size 51.75 KB
Installed size 117.73 KB
The PCP::PMDA Perl module contains the language bindings for
building Performance Metric Domain Agents (PMDAs) using Perl.
Each PMDA exports performance data for one specific domain, for
example the operating system kernel, Cisco routers, a database,
an application, etc.

Alternatives

Package Version Architecture Repository
perl-PCP-PMDA-3.10.9-9.el6.x86_64.rpm 3.10.9 x86_64 CentOS
perl-PCP-PMDA - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libpcp.so.3 -
libpcp.so.3(PCP_3.0) -
libpcp_pmda.so.3 -
libpcp_pmda.so.3(PCP_PMDA_3.0) -
pcp-libs = 3.10.9-9.el6
perl -
perl(DynaLoader) -
perl(Exporter) -
perl(strict) -
perl(vars) -
perl(warnings) -
rtld(GNU_HASH) -

Provides

Name Value
PMDA.so -
perl(PCP::PMDA) = 1.15
perl-PCP-PMDA = 3.10.9-9.el6
perl-PCP-PMDA(x86-32) = 3.10.9-9.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package perl-PCP-PMDA-3.10.9-9.el6.i686.rpm
Source Package pcp-3.10.9-9.el6.src.rpm

Install Howto

Install perl-PCP-PMDA rpm package:

# yum install perl-PCP-PMDA

Files

Path
/usr/lib/perl5/vendor_perl/PCP/PMDA.pm
/usr/lib/perl5/vendor_perl/auto/PCP/PMDA/PMDA.so
/usr/share/man/man3/PCP::PMDA.3pm.gz

Changelog

2017-01-23 - Nathan Scott <nathans@redhat.com> 3.10.9-9
- Added pcp-iostat precision reporting capability (BZ 1297498)
- Fixed a pcp-iostat argument checking stack trace (BZ 1414257)
2016-11-02 - Frank Ch. Eigler <fche@redhat.com> 3.10.9-8
- Fix pmwebd css content-type (BZ 1324964)
2016-10-27 - Nathan Scott <nathans@redhat.com> 3.10.9-7
- Fix pmlogconf probing of base XFS metrics (BZ 1358972)
- Resolve SIGFPE in pcp-atop with missing metrics (BZ 1373590)
- Support pcp-iostat uninterpolated PCP archive replay (BZ 1293661)
- Resolve several reporting issues in PostgreSQL PMDA (BZ 1304619)
2016-02-10 - Lukas Berk <lberk@redhat.com> 3.10.9-6
- Update pmdanamed testcaes (BZ 1303005)
- Fix possible fd leak in pmdanamed (BZ 1223311)
- Fix issue with pmdagfs2 installation (BZ 1305939)
- Address testcase 370 failure on non x86_64 archs (BZ 1305940)
- Address endian issue with pmdalinux on some platforms (BZ 1298722)
2016-01-15 - Lukas Berk <lberk@redhat.com> 3.10.9-5
- Update patch to include testcase (BZ 1297822)
2016-01-14 - Lukas Berk <lberk@redhat.com> - 3.10.9-4
- Correct interrupts parsing on s390x platforms (BZ 1297822)
- Correct papi version we link against for 32 bit arches (BZ 1295694)
2016-01-07 - Lukas Berk <lberk@redhat.com> - 3.10.9-3
- Correct papi version we link against (BZ 1295694)
- Fix possible overflow with pmdaproc using local context options (BZ 1295801)
- Dropped pcp-compat package from upstream (BZ 1294390)
2015-12-17 - Lukas Berk <lberk@redhat.com> - 3.10.9-2
- Include post-release platform-defs patch
2015-12-16 - Lukas Berk <lberk@redhat.com> - 3.10.9-1
- Resolve local_sock() double free error (BZ 1258846).
- Resolve netfilter pmda uses outdated /proc API (BZ 1221653).
- Update to latest PCP sources (BZ 1248272).
- Fix pmatop attribute error (BZ 1195429).
- Fix pmwebd fails when monitoring systems with Vector (BZ 1238863).
2015-05-04 - Nathan Scott <nathans@redhat.com> - 3.10.3-3
- Fix postfix pmda failing to setgid to postfix user (BZ 1213724).
- Fix postfix pmda not reporting incoming mails (BZ 1213764).
- Consistent naming for tools related to LVM cache (BZ 1218007).

See Also

Package Description
perl-PDF-Reuse-0.35-3.el6.noarch.rpm Reuse and mass produce PDF documents
perl-PPI-1.206-4.el6.noarch.rpm Parse, Analyze and Manipulate Perl
perl-PPI-HTML-1.07-7.el6.noarch.rpm Generate syntax-highlighted HTML for Perl using PPI
perl-Package-Constants-0.02-144.el6.i686.rpm List all constants declared in a package
perl-Package-Generator-0.103-2.el6.noarch.rpm Generate new packages quickly and easily
perl-PadWalker-1.9-1.el6.i686.rpm Play with other peoples' lexical variables
perl-Params-Check-0.26-144.el6.i686.rpm Generic input parsing/checking mechanism
perl-Params-Util-1.00-3.el6.i686.rpm Simple standalone param-checking functions
perl-Params-Validate-0.92-3.el6.i686.rpm Params-Validate Perl module
perl-Parse-CPAN-Meta-1.40-144.el6.i686.rpm Parse META.yml and other similar CPAN metadata files
perl-Parse-RecDescent-1.962.2-2.el6.noarch.rpm Parse-RecDescent Perl module
perl-Parse-Yapp-1.05-41.el6.noarch.rpm Perl extension for generating and using LALR parsers
perl-Perl-Critic-1.105-2.el6.noarch.rpm Critique Perl source code for best-practices
perl-Perl-MinimumVersion-1.20-3.el6.noarch.rpm Find a minimum required version of perl for Perl code
perl-Perlilog-0.3-4.el6.noarch.rpm Verilog environment and IP core handling in Perl
Advertisement
Advertisement