libselinux-python-2.0.94-7.el6.i686.rpm


Advertisement

Description

libselinux-python - SELinux python bindings for libselinux

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename libselinux-python-2.0.94-7.el6.i686.rpm
Package name libselinux-python
Package version 2.0.94
Package release 7.el6
Package architecture i686
Package type rpm
Category Development/Libraries
Homepage http://www.selinuxproject.org
License Public Domain
Maintainer -
Download size 200.14 KB
Installed size 631.23 KB
The libselinux-python package contains the python bindings for developing
SELinux applications.

Alternatives

Package Version Architecture Repository
libselinux-python-2.0.94-7.el6.x86_64.rpm 2.0.94 x86_64 CentOS
libselinux-python - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libselinux = 2.0.94-7.el6
libselinux.so.1 -
python(abi) = 2.6
rtld(GNU_HASH) -

Provides

Name Value
_selinux.so -
audit2why.so -
libselinux-python = 2.0.94-7.el6
libselinux-python(x86-32) = 2.0.94-7.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package libselinux-python-2.0.94-7.el6.i686.rpm
Source Package libselinux-2.0.94-7.el6.src.rpm

Install Howto

Install libselinux-python rpm package:

# yum install libselinux-python

Files

Path
/usr/lib/python2.6/site-packages/selinux/__init__.py
/usr/lib/python2.6/site-packages/selinux/__init__.pyc
/usr/lib/python2.6/site-packages/selinux/__init__.pyo
/usr/lib/python2.6/site-packages/selinux/_selinux.so
/usr/lib/python2.6/site-packages/selinux/audit2why.so

Changelog

2016-03-07 - Petr Lautrbach <plautrba@redhat.com> 2.0.94-7
- label_file: fix memory leak in init() (#1309730)
2015-12-16 - Petr Lautrbach <plautrba@redhat.com> - 2.0.94-6
- matchpathcon: add -P <policy_root_path> (#680950)
2014-06-30 - Miroslav Grepl <mgrepl@redhat.com> - 2.0.94-5.8
- avc_has_perm will now return yes if the machine is in permissive mode
Resolves:#753675
- nscd permission support for netgroup
- Fix matchpathcon verify handling to fail on non-existing objects
2014-06-10 - Miroslav Grepl <mgrepl@redhat.com> - 2.0.94-5.7
- Fix selinuxdefcon to print end of line at the end of output.
Resolves:#913115
- Fix security_get_initial_context desc in security_compute_av.3
Resolves:#1011109
- Apply fix for selinux.8 man page from pschiffe@redhat.com.
Resolves:#1011145
2014-05-12 - Dan Walsh <dwalsh@redhat.com> - 2.0.94-5.6
- Back port handling of is_selinux_enabled form rhel7. We need is_selinux_enabled() to report disabled in a docker container so that SELinux aware applications do not attempt to do SELinux activities.
Resolves: #1096816
2013-05-07 - Miroslav Grepl <mgrepl@redhat.com> - 2.0.94-5.5
Fix patch that Handles substitutions for /
Resolves:#953947
2013-04-25 - Miroslav Grepl <mgrepl@redhat.com> - 2.0.94-5.4
- Handle substitutions for /
Resolves:#953947
2012-02-03 - Dan Walsh <dwalsh@redhat.com> - 2.0.94-5.3
- avc_netlink_recieve should continue to poll if it receinves an EINTR rather 
Resolves: #717147
2011-10-24 - Dan Walsh <dwalsh@redhat.com> - 2.0.94-5.2
- Apply libselinux patch to handle large groups.
Resolves: #748471
2011-05-25 - Dan Walsh <dwalsh@redhat.com> - 2.0.94-5.1
- Cleanup selinux_mnt on disabled machines
Resolves: #706049
- Make restorecon python binding use realpath
Resolves: #698583

See Also

Package Description
libselinux-ruby-2.0.94-7.el6.i686.rpm SELinux ruby bindings for libselinux
libselinux-static-2.0.94-7.el6.i686.rpm Static libraries used to build SELinux
libselinux-utils-2.0.94-7.el6.i686.rpm SELinux libselinux utilies
libsemanage-2.0.43-5.1.el6.i686.rpm SELinux binary policy manipulation library
libsemanage-devel-2.0.43-5.1.el6.i686.rpm Header files and libraries used to build policy manipulation tools
libsemanage-python-2.0.43-5.1.el6.i686.rpm semanage python bindings for libsemanage
libsemanage-static-2.0.43-5.1.el6.i686.rpm Static library used to build policy manipulation tools
libsepol-2.0.41-4.el6.i686.rpm SELinux binary policy manipulation library
libsepol-devel-2.0.41-4.el6.i686.rpm Header files and libraries used to build policy manipulation tools
libsepol-static-2.0.41-4.el6.i686.rpm static libraries used to build policy manipulation tools
libsexy-0.1.11-13.el6.i686.rpm Funky fresh graphical widgets for GTK+ 2
libsexy-devel-0.1.11-13.el6.i686.rpm Development files for libsexy
libshout-2.2.2-5.1.el6.i686.rpm Icecast source streaming library
libshout-devel-2.2.2-5.1.el6.i686.rpm static libraries and header files for libshout development
libsigc++20-2.2.4.2-1.el6.i686.rpm Typesafe signal framework for C++
Advertisement
Advertisement