libgnat-4.4.7-23.el6.i686.rpm


Advertisement

Description

libgnat - GNU Ada 95 runtime shared libraries

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename libgnat-4.4.7-23.el6.i686.rpm
Package name libgnat
Package version 4.4.7
Package release 23.el6
Package architecture i686
Package type rpm
Category System Environment/Libraries
Homepage http://gcc.gnu.org
License GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions
Maintainer -
Download size 907.55 KB
Installed size 3.07 MB
GNAT is a GNU Ada 95 front-end to GCC. This package includes shared libraries,
which are required to run programs compiled with the GNAT.

Alternatives

Package Version Architecture Repository
libgnat-4.4.7-23.el6.x86_64.rpm 4.4.7 x86_64 CentOS
libgnat-4.4.7-23.el6.i686.rpm 4.4.7 i686 CentOS
libgnat - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.1.3) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_4.2.0) -
libm.so.6 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libpthread.so.0(GLIBC_2.3.2) -
rtld(GNU_HASH) -

Provides

Name Value
libgnarl-4.4.so -
libgnat = 4.4.7-23.el6
libgnat = 4.4.4-15.el6
libgnat(x86-32) = 4.4.7-23.el6
libgnat-4.4.so -

Download

Type URL
Mirror mirror.centos.org
Binary Package libgnat-4.4.7-23.el6.i686.rpm
Source Package gcc-4.4.7-23.el6.src.rpm

Install Howto

Install libgnat rpm package:

# yum install libgnat

Files

Path
/usr/lib/libgnarl-4.4.so
/usr/lib/libgnat-4.4.so

Changelog

2018-04-12 - Jeff Law <law@redhat.com> 4.4.7-23
- Avoid emitting CFI magic for thunks when -fno-dwarf2-cfi-asm
2018-03-24 - Jeff Law <law@redhat.com> 4.4.7-22
- Spectre mitigations patch for s390x (#1553817)
2018-01-31 - Jeff Law <law@redhat.com> 4.4.7-21
- Fix indirect_jump/tablejump patterns for retpolines (#1535656)
2018-01-23 - Jeff Law <law@redhat.com> 4.4.7-20
- Retpoline support (#1535656)
2017-12-07 - Marek Polacek <polacek@redhat.com> 4.4.7-19
- fix distribute_notes (#1402484)
- always use _Unwind_GetIPInfo in unwind-c.c (#1104812)
2016-10-18 - Jakub Jelinek <jakub@redhat.com> 4.4.7-18
- fix up std::rethrow_exception (PR libstdc++/62258, #1380760)
- fix fortran ICE in resolve_ordinary_assign (PR fortran/43362, #1356346)
2015-12-15 - Jakub Jelinek <jakub@redhat.com> 4.4.7-17
- change libgomp default spincount if OMP_WAIT_POLICY is not specified
(#1229852, PR libgomp/43706)
- remove -Wl,-z,nodlopen from Ada libraries, which no longer contain
trampolines (#1241495)
- guard __gcov_flush body in libgcov.a with a mutex (#1251488,
PR gcov/49484, PR gcov-profile/52627)
- add missing s390.exp hunk from -mhotpatch= support (#1233260)
2015-06-01 - Jakub Jelinek <jakub@redhat.com> 4.4.7-16
- update -mhotpatch= support for s390{,x} (#1148120, PR target/66215)
2015-03-26 - Jakub Jelinek <jakub@redhat.com> 4.4.7-15
- update -mhotpatch= support for s390{,x} (#1148120)
2015-02-27 - Jakub Jelinek <jakub@redhat.com> 4.4.7-14
- add -mhotpatch= support for s390{,x} (#1148120)

See Also

Package Description
libgnat-devel-4.4.7-23.el6.i686.rpm GNU Ada 95 libraries
libgnome-2.28.0-11.el6.i686.rpm GNOME base library
libgnome-devel-2.28.0-11.el6.i686.rpm Libraries and headers for libgnome
libgnomecanvas-2.26.0-4.el6.i686.rpm GnomeCanvas widget
libgnomecanvas-devel-2.26.0-4.el6.i686.rpm Libraries and headers for libgnomecanvas
libgnomecanvasmm26-2.26.0-3.el6.i686.rpm C++ interface for Gnome libs (a GUI library for X)
libgnomecanvasmm26-devel-2.26.0-3.el6.i686.rpm Headers for developing programs that will use libgnomecanvasmm
libgnomecups-0.2.3-9.el6.i686.rpm GNOME library for CUPS integration
libgnomecups-devel-0.2.3-9.el6.i686.rpm GNOME library for CUPS integration
libgnomekbd-2.28.2-2.el6.i686.rpm A keyboard configuration library
libgnomekbd-capplet-2.28.2-2.el6.i686.rpm A configuration applet to select libgnomekbd plugins
libgnomekbd-devel-2.28.2-2.el6.i686.rpm Development files for libgnomekbd
libgnomemm26-2.28.0-2.el6.i686.rpm C++ interface for Gnome libs (a GUI library for X)
libgnomemm26-devel-2.28.0-2.el6.i686.rpm Headers for developing programs that will use Gnome--
libgnomeprint22-2.18.6-4.el6.i686.rpm Printing library for GNOME
Advertisement
Advertisement