ipa-server-trust-ad-3.0.0-51.el6.centos.i686.rpm


Advertisement

Description

ipa-server-trust-ad - Virtual package to install packages required for Active Directory trusts

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename ipa-server-trust-ad-3.0.0-51.el6.centos.i686.rpm
Package name ipa-server-trust-ad
Package version 3.0.0
Package release 51.el6.centos
Package architecture i686
Package type rpm
Category System Environment/Base
Homepage http://www.freeipa.org/
License GPLv3+
Maintainer -
Download size 136.79 KB
Installed size 253.23 KB
Cross-realm trusts with Active Directory in IPA require working Samba 4 installation.
This package is provided for convenience to install all required dependencies at once.

Alternatives

Package Version Architecture Repository
ipa-server-trust-ad-3.0.0-51.el6.centos.x86_64.rpm 3.0.0 x86_64 CentOS
ipa-server-trust-ad - - -

Requires

Name Value
/usr/bin/python -
/usr/sbin/update-alternatives -
ipa-server = 3.0.0-51.el6.centos
libc.so.6(GLIBC_2.8) -
libcom_err.so.2 -
libcrypto.so.10 -
libcrypto.so.10(libcrypto.so.10) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgcc_s.so.1(GCC_3.3.1) -
libk5crypto.so.3 -
libk5crypto.so.3(k5crypto_3_MIT) -
libkrb5.so.3 -
libkrb5.so.3(krb5_3_MIT) -
liblber-2.4.so.2 -
libldap_r-2.4.so.2 -
libndr.so.0 -
libndr.so.0(NDR_0.0.1) -
libsamba-passdb.so.0 -
libsamba-passdb.so.0(SAMBA_PASSDB_0.2.0) -
libsamba-util.so.0 -
libsamba-util.so.0(SAMBA_UTIL_0.0.1) -
libsmbconf.so.0 -
libsmbconf.so.0(SMBCONF_0) -
libsmbldap.so.0 -
libsmbldap.so.0(SMBLDAP_0) -
libsss_idmap -
libsss_idmap.so.0 -
libsss_idmap.so.0(SSS_IDMAP_0.4) -
libtalloc.so.2 -
libtalloc.so.2(TALLOC_2.0.2) -
libtevent.so.0 -
libwbclient.so.0(WBCLIENT_0.9) -
m2crypto -
python -
python(abi) = 2.6
python-sss -
rtld(GNU_HASH) -
samba4 >= 4.0.0-31
samba4-python -
samba4-winbind -

Provides

Name Value
ipa-server-trust-ad = 3.0.0-51.el6.centos
ipa-server-trust-ad(x86-32) = 3.0.0-51.el6.centos
ipasam.so -
libipa_extdom_extop.so -
libipa_sidgen.so -
libipa_sidgen_task.so -

Download

Type URL
Mirror mirror.centos.org
Binary Package ipa-server-trust-ad-3.0.0-51.el6.centos.i686.rpm
Source Package ipa-3.0.0-51.el6.centos.src.rpm

Install Howto

Install ipa-server-trust-ad rpm package:

# yum install ipa-server-trust-ad

Files

Path
/usr/lib/dirsrv/plugins/libipa_extdom_extop.so
/usr/lib/dirsrv/plugins/libipa_sidgen.so
/usr/lib/dirsrv/plugins/libipa_sidgen_task.so
/usr/lib/krb5/plugins/libkrb5/winbind_krb5_locator.so
/usr/lib/python2.6/site-packages/ipaserver/dcerpc.py
/usr/lib/python2.6/site-packages/ipaserver/dcerpc.pyc
/usr/lib/python2.6/site-packages/ipaserver/dcerpc.pyo
/usr/lib/python2.6/site-packages/ipaserver/install/adtrustinstance.py
/usr/lib/python2.6/site-packages/ipaserver/install/adtrustinstance.pyc
/usr/lib/python2.6/site-packages/ipaserver/install/adtrustinstance.pyo
/usr/lib/samba/pdb/ipasam.so
/usr/sbin/ipa-adtrust-install
/usr/share/ipa/smb.conf.empty
/usr/share/man/man1/ipa-adtrust-install.1.gz

Changelog

2017-03-21 - Johnny Hughes <johnny@centos.org> - 3.0.0-51.el6
- Roll in CentOS Branding
2016-11-07 - Jan Cholasta <jcholast@redhat.com> - 3.0.0-51.el6
- Resolves: #1321138 Missing dependency package "python-sss-murmur" in
ipa-server-3.0.0-50.el6.x86_64
- SPEC: Require python2 version of sssd bindings
- Resolves: #1367026 Document and test procedure for running IdM Server in TLS
1.2+ environment
- Require 389-ds-base with TLS 1.0 disable switch
2016-08-30 - Jan Cholasta <jcholast@redhat.com> - 3.0.0-50.el6.3
- Resolves: #1322059 IPA Replica-Install from RHEL6 to RHEL7 Fails
- Modififed NSSConnection not to shutdown existing database.
- Do not erroneously reinit NSS in Dogtag interface
- Make sure replication works after DM password is changed
2016-08-22 - Jan Cholasta <jcholast@redhat.com> - 3.0.0-50.el6.2
- Resolves: #1351593 CVE-2016-5404 ipa: Insufficient privileges check in
certificate revocation
- cert-revoke: fix permission check bypass (CVE-2016-5404)
2016-04-12 - Alexander Bokovoy <abokovoy@redhat.com> - 3.0.0-50.el6.1
- Update IPA code to support Samba 4.2
- Related: #1322689
2016-01-07 - Jan Cholasta <mbasti@redhat.com> - 3.0.0-50.el6
- Resolves: #1225868 display browser config options that apply to the browser -
Chrome
- Remove ico files from Makefile
- Resolves: #1232843 ipa-client-install errors out if client and server time
are not in sync or unreachable
- Skip time sync during client install when using --no-ntp
- Resolves: #1288495 Add userCertificate index used in Smart Card
authentication
- add DS index for userCertificate attribute
- Resolves: #1293588 JavaScript error in ssbrowser.html - TypeError: Cannot
read property 'mozilla' of undefined
- webui: fix browser detection in browserconfig.html and ssbrowser.html
- Resolves: #1296124 Adjust Firefox configuration to new extension signing
policy
- webui: use manual Firefox configuration for Firefox >= 40
- Remove binary patching from patch 0140
2015-12-22 - Martin Basti <mbasti@redhat.com> - 3.0.0-49.el6
- Resolves: #1127211 ipa-server-install --uninstall produces avc
- sysrestore: copy files instead of moving them to avoind SELinux issues
- Use 'mv -Z' in specfile to restore SELinux context
- Resolves: #1222999 ipa aci plugin is not parsing aci's correctly.
- ACI plugin: correctly parse bind rules enclosed in parentheses
- Resolves: #1225868 display browser config options that apply to the browser -
Chrome
- webui: add Kerberos configuration instructions for Chrome
- Remove ico files from Makefile
- WebUI: fix ipa_error.css
- Resolves: #1232468 The Domain option is not correctly set in idmapd.conf when
ipa-client-automount is executed.
- Simplify adding options in ipachangeconf
- ipachangeconf: Add ability to preserve section case
- ipa-client-automount: Leverage IPAChangeConf to configure the domain for
idmapd
- Resolves: #1232899 ipa-client-install does not respect --realm option
- Allow user to force Kerberos realm during installation.
- Resolves: #1276358 Remove /usr/share/ipa/updates/50-lockout-policy.update
file from IPA 3.0 releases
- Remove 50-lockout-policy.update file
2015-11-12 - Jan Cholasta <jcholast@redhat.com> - 3.0.0-48.el6
- Resolves: #1263703 ipa-server-install with externally signed CA fails with
NSS error (SEC_ERROR_BUSY)
- Free NSS objects in --external-ca scenario
- Resolves: #1263262 Unable to resolve group memberships for AD users when
using sssd-1.12.2-58.el7_1.6.x86_64 client in combination with
ipa-server-3.0.0-42.el6.x86_64 with AD Trust
- Do not lookup up the domain too early if only the SID is known
- Do not store SID string in a local buffer
- Allow ID-to-SID mappings in the extdom plugin
2015-05-13 - Petr Vobornik <pvoborni@redhat.com> - 3.0.0-47.el6
- Resolves: #1220788 - Some IPA schema files are not RFC 4512 compliant

See Also

Package Description
ipmitool-1.8.15-2.el6.i686.rpm Utility for IPMI control
iproute-2.6.32-57.el6.i686.rpm Advanced IP routing and network device configuration tools
iproute-devel-2.6.32-57.el6.i686.rpm iproute development files
iproute-doc-2.6.32-57.el6.i686.rpm ip and tc documentation with examples
ipset-6.11-4.el6.i686.rpm Manage Linux IP sets
ipset-devel-6.11-4.el6.i686.rpm Development files for ipset
iptables-1.4.7-19.el6.i686.rpm Tools for managing Linux kernel packet filtering capabilities
iptables-devel-1.4.7-19.el6.i686.rpm Development package for iptables
iptables-ipv6-1.4.7-19.el6.i686.rpm IPv6 support for iptables
iptraf-3.0.1-14.el6.i686.rpm A console-based network monitoring utility
iptstate-2.2.2-4.el6.i686.rpm A top-like display of IP Tables state table entries
iputils-20071127-24.el6.i686.rpm Network monitoring tools including ping
ipvsadm-1.26-4.el6.i686.rpm Utility to administer the Linux Virtual Server
ipw2100-firmware-1.3-11.el6.noarch.rpm Firmware for IntelĀ® PRO/Wireless 2100 network adaptors
ipw2200-firmware-3.1-4.el6.noarch.rpm Firmware for IntelĀ® PRO/Wireless 2200 network adaptors
Advertisement
Advertisement