ibacm-devel-1.0.9-1.el6.i686.rpm


Advertisement

Description

ibacm-devel - Headers file needed when building apps to talk directly to ib_acm

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename ibacm-devel-1.0.9-1.el6.i686.rpm
Package name ibacm-devel
Package version 1.0.9
Package release 1.el6
Package architecture i686
Package type rpm
Category System Environment/Daemons
Homepage https://www.openfabrics.org/
License GPLv2 or BSD
Maintainer -
Download size 6.52 KB
Installed size 3.78 KB
Most applications do not need to know how to talk directly to the ib_acm
daemon, but it does have a socket that it listens on, and it has a
specific protocol for incoming/outgoing data.  So if you wish to build
the ability to communicate directly with ib_acm into your own application,
the protocol used to communicate with it, and the data structures
involved, are in this header file.  Please note that this is an unsupported
method of using this daemon.  The only supported means of using this is
via librdmacm.  As such, even though this header file is provided, no
further documentation is available.  One must read the source if they
wish to make use of this header file.

Alternatives

Package Version Architecture Repository
ibacm-devel-1.0.9-1.el6.x86_64.rpm 1.0.9 x86_64 CentOS
ibacm-devel-1.0.9-1.el6.i686.rpm 1.0.9 i686 CentOS
ibacm-devel - - -

Requires

Name Value
ibacm = 1.0.9-1.el6

Provides

Name Value
ibacm-devel = 1.0.9-1.el6
ibacm-devel(x86-32) = 1.0.9-1.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package ibacm-devel-1.0.9-1.el6.i686.rpm
Source Package ibacm-1.0.9-1.el6.src.rpm

Install Howto

Install ibacm-devel rpm package:

# yum install ibacm-devel

Files

Path
/usr/include/infiniband/acm.h

Changelog

2015-03-11 - Doug Ledford <dledford@redhat.com> - 1.0.9-1
- Update to official 1.0.9 release
- Related: bz1119108
2014-06-16 - Doug Ledford <dledford@redhat.com> - 1.0.9-0.git3cbbe4e
- Update to head of git repo to pick up dynamic addressing changes
- Resolves: bz1056662
2012-10-15 - Doug Ledford <dledford@redhat.com> - 1.0.8-0.git7a3adb7
- Update to latest upstream via git repo
- Resolves: bz866222, bz866223
2012-04-05 - Doug Ledford <dledford@redhat.com> - 1.0.5-3
- Until the next upstream release, the pid file is in a wonky location.
Make the init script know about that location so we can stop properly.
- Resolves: bz808599
2012-04-05 - Doug Ledford <dledford@redhat.com> - 1.0.5-2
- Don't install the address file or config file, the config file isn't
strictly needed and defaults will be used if it isn't installed, but
with the address file we specifically need to build one based upon
the machine where the program is installed, a default file is not only
not helpful, but it messes up the daemon.
- Related: bz700285
2012-02-28 - Doug Ledford <dledford@redhat.com> - 1.0.5-1
- Ininital version for rhel6
- Related: bz700285

See Also

Package Description
ibsim-0.5-7.el6.i686.rpm InfiniBand fabric simulator for management
ibus-1.3.4-10.el6.i686.rpm Intelligent Input Bus for Linux OS
ibus-anthy-1.2.1-3.el6.i686.rpm The Anthy engine for IBus input platform
ibus-chewing-1.3.5.20100714-4.el6.i686.rpm The Chewing engine for IBus input platform
ibus-devel-1.3.4-10.el6.i686.rpm Development tools for ibus
ibus-devel-docs-1.3.4-10.el6.i686.rpm Developer documents for ibus
ibus-gtk-1.3.4-10.el6.i686.rpm IBus im module for gtk2
ibus-hangul-1.3.0.20100329-6.el6.i686.rpm The Hangul engine for IBus input platform
ibus-libs-1.3.4-10.el6.i686.rpm IBus libraries
ibus-m17n-1.3.0-2.el6.i686.rpm The M17N engine for IBus platform
ibus-pinyin-1.3.8-1.el6.i686.rpm The Chinese Pinyin and Bopomofo engines for IBus input platform
ibus-pinyin-open-phrase-1.3.8-1.el6.i686.rpm The open phrase database for ibus Pinyin and Bopomofo
ibus-qt-1.3.0-2.el6.i686.rpm Qt IBus library and Qt input method plugin
ibus-qt-devel-1.3.0-2.el6.i686.rpm Development tools for ibus qt
ibus-qt-docs-1.3.0-2.el6.i686.rpm Development documents for ibus qt
Advertisement
Advertisement