glibc-static-2.12-1.212.el6.i686.rpm


Advertisement

Description

glibc-static - C library static libraries for -static linking

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename glibc-static-2.12-1.212.el6.i686.rpm
Package name glibc-static
Package version 2.12
Package release 1.212.el6
Package architecture i686
Package type rpm
Category Development/Libraries
Homepage http://sources.redhat.com/glibc/
License LGPLv2+ and LGPLv2+ with exceptions and GPLv2+
Maintainer -
Download size 1.15 MB
Installed size 4.42 MB
The glibc-static package contains the C library static libraries
for -static linking.  You don't need these, unless you link statically,
which is highly discouraged.

Alternatives

Package Version Architecture Repository
glibc-static-2.12-1.212.el6_10.3.x86_64.rpm 2.12 x86_64 CentOS Updates
glibc-static-2.12-1.212.el6_10.3.i686.rpm 2.12 i686 CentOS Updates
glibc-static-2.12-1.212.el6_10.3.i686.rpm 2.12 i686 CentOS Updates
glibc-static-2.12-1.212.el6.x86_64.rpm 2.12 x86_64 CentOS
glibc-static-2.12-1.212.el6.i686.rpm 2.12 i686 CentOS
glibc-static - - -

Requires

Name Value
glibc-devel = 2.12-1.212.el6

Provides

Name Value
glibc-static = 2.12-1.212.el6
glibc-static(x86-32) = 2.12-1.212.el6

Download

Type URL
Mirror mirror.centos.org
Binary Package glibc-static-2.12-1.212.el6.i686.rpm
Source Package glibc-2.12-1.212.el6.src.rpm

Install Howto

Install glibc-static rpm package:

# yum install glibc-static

Files

Path
/usr/lib/libBrokenLocale.a
/usr/lib/libanl.a
/usr/lib/libc.a
/usr/lib/libc_stubs.a
/usr/lib/libcrypt.a
/usr/lib/libdl.a
/usr/lib/libm.a
/usr/lib/libnsl.a
/usr/lib/libpthread.a
/usr/lib/libresolv.a
/usr/lib/librt.a
/usr/lib/libutil.a

Changelog

2017-11-17 - Patsy Franklin <pfrankli@redhat.com> - 2.12-1.212
- CVE-2017-15670: glob: Fix one-byte overflow with GLOB_TILDE (#1504810)
- CVE-2017-15804: glob: Fix buffer overflow in GLOB_TILDE unescaping (#1504810)
2017-06-19 - Florian Weimer <fweimer@redhat.com> - 2.12-1.211
- Avoid large allocas in the dynamic linker (#1452717)
2017-03-29 - Carlos O'Donell <carlos@redhat.com> - 2.12-1.210
- Fix thread cancellation issues for setmntent() and others (#1437147).
2017-01-25 - Florian Weimer <fweimer@redhat.com> - 2.12-1.209
- Fix AF_INET6 getaddrinfo with nscd (#1416496)
2016-10-18 - Carlos O'Donell <carlos@redhat.com> - 2.12-1.208
- Update tests for struct sockaddr_storage changes (#1338673)
2016-10-17 - Martin Sebor <msebor@redhat.com> - 2.12-1.207
- Use FL_CLOEXEC in internal calls to fopen (#1012343).
2016-10-17 - Carlos O'Donell <carlos@redhat.com> - 2.12-1.206
- Fix CVE-2015-8779 glibc: Unbounded stack allocation in catopen function
(#1358015).
2016-10-17 - DJ Delorie <dj@redhat.com> - 2.12-1.205
- Make padding in struct sockaddr_storage explicit (#1338673)
2016-10-13 - Carlos O'Donell <carlos@redhat.com> - 2.12-1.204
- Fix detection of Intel FMA hardware (#1384281).
2016-10-11 - Carlos O'Donell <carlos@redhat.com> - 2.12-1.203
- Add support for el_GR@euro, ur_IN, and wal_ET locales (#1101858).

See Also

Package Description
glibc-utils-2.12-1.212.el6.i686.rpm Development utilities from GNU C library
glibmm24-2.22.1-1.el6.i686.rpm C++ interface for GTK2 (a GUI library for X)
glibmm24-devel-2.22.1-1.el6.i686.rpm Headers for developing programs that will use glibmm24
glibmm24-doc-2.22.1-1.el6.i686.rpm Documentation for glibmm24, includes full API docs
glpk-4.40-1.1.el6.i686.rpm GNU Linear Programming Kit
glpk-devel-4.40-1.1.el6.i686.rpm Development headers and files for GLPK
glpk-doc-4.40-1.1.el6.i686.rpm Documentation for glpk
glpk-static-4.40-1.1.el6.i686.rpm Static version of GLPK libraries
glpk-utils-4.40-1.1.el6.i686.rpm GLPK-related utilities and examples
glx-utils-11.0.7-4.el6.i686.rpm GLX utilities
gmp-4.3.1-13.el6.i686.rpm A GNU arbitrary precision library
gmp-devel-4.3.1-13.el6.i686.rpm Development tools for the GNU MP arbitrary precision library
gmp-static-4.3.1-13.el6.i686.rpm Development tools for the GNU MP arbitrary precision library
gnome-applets-2.28.0-7.el6.centos.i686.rpm Small applications for the GNOME panel
gnome-backgrounds-2.28.0-2.el6.noarch.rpm Desktop backgrounds packaged with the GNOME desktop
Advertisement
Advertisement