eclipse-swt-3.6.1-6.13.el6.i686.rpm


Advertisement

Description

eclipse-swt - SWT Library for GTK+-2.0

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename eclipse-swt-3.6.1-6.13.el6.i686.rpm
Package name eclipse-swt
Package version 3.6.1
Package release 6.13.el6
Package architecture i686
Package type rpm
Category Text Editors/Integrated Development Environments (IDE)
Homepage http://www.eclipse.org/
License EPL
Maintainer -
Download size 2.07 MB
Installed size 2.69 MB
SWT Library for GTK+-2.0.

Alternatives

Package Version Architecture Repository
eclipse-swt-3.6.1-6.13.el6.x86_64.rpm 3.6.1 x86_64 CentOS
eclipse-swt - - -

Requires

Name Value
gtk2 -
jpackage-utils -
rtld(GNU_HASH) -
xulrunner >= 1.9

Provides

Name Value
eclipse-swt = 3.6.1-6.13.el6
eclipse-swt(x86-32) = 3.6.1-6.13.el6
libswt-atk-gtk-3655.so -
libswt-awt-gtk-3655.so -
libswt-cairo-gtk-3655.so -
libswt-glx-gtk-3655.so -
libswt-gnome-gtk-3655.so -
libswt-gtk-3655.so -
libswt-pi-gtk-3655.so -
libswt-xpcominit-gtk-3655.so -
libswt-xpcominit-gtk-3655.so(EXPORTED) -
libswt-xulrunner-gtk-3655.so -
libswt-xulrunner-gtk-3655.so(EXPORTED) -
libswt3-gtk2 = 3.6.1-6.13.el6

Conflicts

Name Value
mozilla -

Obsoletes

Name Value
libswt3-gtk2 < 3.3.2-20

Download

Type URL
Mirror mirror.centos.org
Binary Package eclipse-swt-3.6.1-6.13.el6.i686.rpm
Source Package eclipse-3.6.1-6.13.el6.src.rpm

Install Howto

Install eclipse-swt rpm package:

# yum install eclipse-swt

Files

Path
/usr/lib/eclipse/epl-v10.html
/usr/lib/eclipse/libswt-atk-gtk-3655.so
/usr/lib/eclipse/libswt-awt-gtk-3655.so
/usr/lib/eclipse/libswt-cairo-gtk-3655.so
/usr/lib/eclipse/libswt-glx-gtk-3655.so
/usr/lib/eclipse/libswt-gnome-gtk-3655.so
/usr/lib/eclipse/libswt-gtk-3655.so
/usr/lib/eclipse/libswt-pi-gtk-3655.so
/usr/lib/eclipse/libswt-xpcominit-gtk-3655.so
/usr/lib/eclipse/libswt-xulrunner-gtk-3655.so
/usr/lib/eclipse/notice.html
/usr/lib/eclipse/swt-gtk-3.6.1.jar
/usr/lib/eclipse/swt-gtk.jar
/usr/lib/eclipse/swt.jar
/usr/lib/eclipse/configuration/
/usr/lib/eclipse/configuration/org.eclipse.osgi/
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-atk-gtk-3655.so
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-awt-gtk-3655.so
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-cairo-gtk-3655.so
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-glx-gtk-3655.so
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-gnome-gtk-3655.so
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-gtk-3655.so
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-pi-gtk-3655.so
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-xpcominit-gtk-3655.so
/usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/113/1/.cp/libswt-xulrunner-gtk-3655.so
/usr/lib/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.6.1.v3655c.jar
/usr/lib/eclipse/plugins/org.eclipse.swt_3.6.1.v3655c.jar
/usr/lib/java/swt.jar

Changelog

2011-01-19 - Andrew Overholt <overholt@redhat.com> 1:3.6.1-6.13
- Drop patch to remove ant-trax (needed by test runs).
2011-01-19 - Andrew Overholt <overholt@redhat.com> 1:3.6.1-6.12
- Add two upstream patches to allow for running SDK JUnit tests.
2011-01-12 - Andrew Overholt <overholt@redhat.com> 1:3.6.1-6.11
- Bring in line with Fedora.
- Remove some stuff that is now done in eclipse-build.
- Fix sources URL.
- Add PDE dependency on zip for pdebuild script.
- Use new eclipse-build targets.
- Increase minimum required memory in eclipse.ini.
2011-01-11 - Andrew Overholt <overholt@redhat.com> 1:3.6.1-6.10
- Put ant.launching into JDT's dropins directory.
2011-01-11 - Andrew Overholt <overholt@redhat.com> 1:3.6.1-6.9
- Use apache-tomcat-apis JARs.
- Version objectweb-asm BR/R.
2011-01-10 - Chris Aniszczyk <overholt@redhat.com> 1:3.6.1-6.8
- Fix JSP API symlinks.
2010-12-15 - Alexander Kurtakov <akurtako@redhat.com> 1:3.6.1-6.7
- Install o.e.jdt.junit.core in jdt (rhbz#663207).
2010-12-13 - Severin Gehwolf <sgehwolf@redhat.com> 1:3.6.1-6
- Add Eclipse help XSS vulnerability fix (RH Bz #661901).
2010-12-01 - Jeff Johnston <jjohnstn@redhat.com> 1:3.6.1-5
- Remove work around for openjdk bug#647737 as openjdk has
posted its own work around and will shortly be fixing problem 
correctly.
2010-11-10 - Jeff Johnston <jjohnstn@redhat.com> 1:3.6.1-4
- Work around for openjdk bug#647737.

See Also

Package Description
eclipse-valgrind-0.6.1-1.el6.i686.rpm Valgrind Tools Integration for Eclipse
ecryptfs-utils-82-6.el6_1.3.i686.rpm The eCryptfs mount helper and support libraries
ecryptfs-utils-devel-82-6.el6_1.3.i686.rpm The eCryptfs userspace development package
ecryptfs-utils-python-82-6.el6_1.3.i686.rpm Python bindings for the eCryptfs utils
ed-1.1-3.3.el6.i686.rpm The GNU line editor
edac-utils-0.9-16.el6.i686.rpm Userspace helper for kernel EDAC drivers
edac-utils-devel-0.9-16.el6.i686.rpm Development files for edac-utils
efax-0.9a-8.el6.i686.rpm A program for faxing using a Class 1, 2 or 2.0 fax modem
efibootmgr-0.5.4-15.el6.i686.rpm EFI Boot Manager
eggdbus-0.6-3.el6.i686.rpm Experimental D-Bus bindings for GObject
eggdbus-devel-0.6-3.el6.i686.rpm Development files for EggDBus
eject-2.1.5-17.el6.i686.rpm A program that ejects removable media using software control
ekiga-3.2.6-4.el6.i686.rpm A Gnome based SIP/H323 teleconferencing application
elfutils-0.164-2.el6.i686.rpm A collection of utilities and DSOs to handle compiled objects
elfutils-devel-0.164-2.el6.i686.rpm Development libraries to handle compiled objects
Advertisement
Advertisement