compat-glibc-2.5-46.2.i686.rpm


Advertisement

Description

compat-glibc - Compatibility C library

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename compat-glibc-2.5-46.2.i686.rpm
Package name compat-glibc
Package version 2.5
Package release 46.2
Package architecture i686
Package type rpm
Category Development/Libraries
Homepage -
License LGPLv2+ and LGPLv2+ with exceptions and GPLv2+
Maintainer -
Download size 972.16 KB
Installed size 4.00 MB
This package contains stub shared libraries and static libraries
from Red Hat Enterprise Linux 5.
To compile and link against these compatibility libraries, use
gcc34 -I /usr/lib/i686-redhat-linux5E/include \
-B /usr/lib/i686-redhat-linux5E/lib/
or
gcc -fgnu89-inline \
-I /usr/lib/i686-redhat-linux5E/include \
-B /usr/lib/i686-redhat-linux5E/lib/

Alternatives

Package Version Architecture Repository
compat-glibc-2.5-46.2.x86_64.rpm 2.5 x86_64 CentOS
compat-glibc - - -

Requires

Name Value
compat-glibc-headers = 2.5-46.2
rtld(GNU_HASH) -

Provides

Name Value
compat-glibc = 2.5-46.2
compat-glibc(x86-32) = 2.5-46.2

Download

Type URL
Mirror mirror.centos.org
Binary Package compat-glibc-2.5-46.2.i686.rpm
Source Package compat-glibc-2.5-46.2.src.rpm

Install Howto

Install compat-glibc rpm package:

# yum install compat-glibc

Files

Path
/usr/lib/i686-redhat-linux5E/
/usr/lib/i686-redhat-linux5E/lib/Mcrt1.o
/usr/lib/i686-redhat-linux5E/lib/Scrt1.o
/usr/lib/i686-redhat-linux5E/lib/crt1.o
/usr/lib/i686-redhat-linux5E/lib/crti.o
/usr/lib/i686-redhat-linux5E/lib/crtn.o
/usr/lib/i686-redhat-linux5E/lib/gcrt1.o
/usr/lib/i686-redhat-linux5E/lib/libanl.a
/usr/lib/i686-redhat-linux5E/lib/libanl.so
/usr/lib/i686-redhat-linux5E/lib/libbsd-compat.a
/usr/lib/i686-redhat-linux5E/lib/libbsd.a
/usr/lib/i686-redhat-linux5E/lib/libc.a
/usr/lib/i686-redhat-linux5E/lib/libc.so
/usr/lib/i686-redhat-linux5E/lib/libc_nonshared.a
/usr/lib/i686-redhat-linux5E/lib/libc_stubs.a
/usr/lib/i686-redhat-linux5E/lib/libcidn.so
/usr/lib/i686-redhat-linux5E/lib/libcrypt.a
/usr/lib/i686-redhat-linux5E/lib/libcrypt.so
/usr/lib/i686-redhat-linux5E/lib/libdl.a
/usr/lib/i686-redhat-linux5E/lib/libdl.so
/usr/lib/i686-redhat-linux5E/lib/libg.a
/usr/lib/i686-redhat-linux5E/lib/libieee.a
/usr/lib/i686-redhat-linux5E/lib/libm.a
/usr/lib/i686-redhat-linux5E/lib/libm.so
/usr/lib/i686-redhat-linux5E/lib/libmcheck.a
/usr/lib/i686-redhat-linux5E/lib/libnsl.a
/usr/lib/i686-redhat-linux5E/lib/libnsl.so
/usr/lib/i686-redhat-linux5E/lib/libpthread.a
/usr/lib/i686-redhat-linux5E/lib/libpthread.so
/usr/lib/i686-redhat-linux5E/lib/libpthread_nonshared.a
/usr/lib/i686-redhat-linux5E/lib/libresolv.a
/usr/lib/i686-redhat-linux5E/lib/libresolv.so
/usr/lib/i686-redhat-linux5E/lib/librpcsvc.a
/usr/lib/i686-redhat-linux5E/lib/librt.a
/usr/lib/i686-redhat-linux5E/lib/librt.so
/usr/lib/i686-redhat-linux5E/lib/libthread_db.so
/usr/lib/i686-redhat-linux5E/lib/libutil.a
/usr/lib/i686-redhat-linux5E/lib/libutil.so

Changelog

2010-06-01 - Andreas Schwab <schwab@redhat.com> - 1:2.5-46.2
- Fix disabling of debuginfo package (#596915)
2010-05-27 - Andreas Schwab <schwab@redhat.com> - 1:2.5-46.1
- Fix license tag (#596135)
2009-12-18 - Jakub Jelinek <jakub@redhat.com> 2.5-46
- changed into compatibility package

See Also

Package Description
compat-glibc-headers-2.5-46.2.i686.rpm Header files for development using standard C libraries
compat-libcap1-1.10-1.i686.rpm Library for getting and setting POSIX.1e capabilities
compat-libf2c-34-3.4.6-19.el6.i686.rpm Fortran 77 compatibility runtime
compat-libgcc-296-2.96-144.el6.i686.rpm Compatibility 2.96-RH libgcc library
compat-libgfortran-41-4.1.2-39.el6.i686.rpm Compatibility Fortran 95 runtime library version 4.1.2
compat-libstdc++-296-2.96-144.el6.i686.rpm Compatibility 2.96-RH standard C++ libraries
compat-libstdc++-33-3.2.3-69.el6.i686.rpm Compatibility standard C++ libraries
compat-libtermcap-2.0.8-49.el6.i686.rpm A basic system library for accessing the termcap database
compat-libxcb-1.9-0.1.el6.i686.rpm A C binding to the X11 protocol
compat-openldap-2.3.43-2.el6.i686.rpm OpenLDAP compatibility shared libraries
compat-opensm-libs-3.3.5-3.el6.i686.rpm Back compatability libraries for the IB management stack
compat-readline5-5.2-17.1.el6.i686.rpm A library for editing typed command lines
compat-readline5-devel-5.2-17.1.el6.i686.rpm Files needed to develop programs which use the readline library
compat-readline5-static-5.2-17.1.el6.i686.rpm Static libraries for the readline library
compat-xcb-util-0.4.0-2.2.el6.i686.rpm Compatibility libraries atop libxcb
Advertisement
Advertisement