SDL-static-1.2.14-7.el6_7.1.i686.rpm


Advertisement

Description

SDL-static - Files needed to develop static Simple DirectMedia Layer applications

Property Value
Distribution CentOS 6
Repository CentOS i386
Package filename SDL-static-1.2.14-7.el6_7.1.i686.rpm
Package name SDL-static
Package version 1.2.14
Package release 7.el6_7.1
Package architecture i686
Package type rpm
Category Development/Libraries
Homepage http://www.libsdl.org/
License LGPLv2+
Maintainer -
Download size 213.57 KB
Installed size 656.69 KB
Simple DirectMedia Layer (SDL) is a cross-platform multimedia library
designed to provide fast access to the graphics frame buffer and audio
device. This package provides the static libraries needed for developing
static SDL applications.

Alternatives

Package Version Architecture Repository
SDL-static-1.2.14-7.el6_7.1.x86_64.rpm 1.2.14 x86_64 CentOS
SDL-static - - -

Requires

Name Value
SDL-devel = 1.2.14-7.el6_7.1

Provides

Name Value
SDL-static = 1.2.14-7.el6_7.1
SDL-static(x86-32) = 1.2.14-7.el6_7.1

Download

Type URL
Mirror mirror.centos.org
Binary Package SDL-static-1.2.14-7.el6_7.1.i686.rpm
Source Package SDL-1.2.14-7.el6_7.1.src.rpm

Install Howto

Install SDL-static rpm package:

# yum install SDL-static

Files

Path
/usr/lib/libSDL.a
/usr/lib/libSDLmain.a

Changelog

2015-11-04 - Wim Taymans <wtaymans@redhat.com> - 1.2.14-7.1
- Rebuild for z-stream
Resolves: #1277636
2015-10-01 - Wim Taymans <wtaymans@redhat.com> - 1.2.14-7
- Add dynamic symbol for _XGetRequest, which libX11 1.4.99.1 added
Resolves: #1205603
2015-05-12 - Wim Taymans <wtaymans@redhat.com> - 1.2.14-6
- Conflict with older libX11 that don't have _XGetRequest
Resolves: #1205603
2015-02-06 - Wim Taymans <wtaymans@redhat.com> - 1.2.14-5
- Rebuild for fastrack
Resolves: #1125304
2015-01-27 - Wim Taymans <wtaymans@redhat.com> - 1.2.14-4
- Do not harness backing store by default
- Adapt to libX11-1.5.99.901
Resolves: #1125304
2012-01-10 - Petr Pisar <ppisar@redhat.com> - 1.2.14-3
- Fix left button press event in windowed mode (sdl894, Resolves: #640682)
- Remove invalid configure arguments (Resolves: #640687)
- Kernel joystick structure has grown in unknown 2.6 Linux version (sdl900,
Resolves: #640694)
- Do not call memcpy() on overlapping areas (sdl1090, Resolves: #678569)
- Don't block SDL_WM_GrabInput() if window is not viewable (sdl1155,
Resolves: #733605)
2010-08-03 - Petr Pisar <ppisar@redhat.com> - 1.2.14-2
- Remove src/joystick/darwin/10.3.9-FIX/IOHIDLib.h because of license
(bug #619907)
2010-03-24 - Thomas Woerner <twoerner@redhat.com> 1.2.14-1
- rebase to 1.2.14
- fixed build for libtool 2.2.6 and newer
- fix from Josh Boyer <jwboyer@gmail.com>:
- disable ps3 video support that was added in 2.14.  It fails to
build on ppc/ppc64
2010-02-25 - Thomas Woerner <twoerner@redhat.com> 1.2.13-13
- added repackage.sh script to remove joyos2,h and symbian.zip (really)
- added comment about riva_mmio.h license
2010-01-25 - Thomas Woerner <twoerner@redhat.com> 1.2.13-12
- removed also symbian.zip from source archive, because of licensing issues

See Also

Package Description
SOAPpy-0.11.6-11.el6.noarch.rpm Full-featured SOAP library for Python
TurboGears2-2.0.3-4.el6.noarch.rpm Next generation Front-to-back web development megaframework built on Pylons
Xaw3d-1.5E-15.1.el6.i686.rpm A version of the MIT Athena widget set for X
Xaw3d-devel-1.5E-15.1.el6.i686.rpm Header files and static libraries for development using Xaw3d
a2ps-4.14-13.el6.i686.rpm Converts text and other types of files to PostScript
abrt-2.0.8-44.el6.centos.i686.rpm Automatic bug detection and reporting tool
abrt-addon-ccpp-2.0.8-44.el6.centos.i686.rpm abrt's C/C++ addon
abrt-addon-kerneloops-2.0.8-44.el6.centos.i686.rpm abrt's kerneloops addon
abrt-addon-python-2.0.8-44.el6.centos.i686.rpm abrt's addon for catching and analyzing Python exceptions
abrt-addon-vmcore-2.0.8-44.el6.centos.i686.rpm abrt's vmcore addon
abrt-cli-2.0.8-44.el6.centos.i686.rpm Virtual package to install all necessary packages for usage from command line environment
abrt-console-notification-2.0.8-44.el6.centos.i686.rpm ABRT console notification script
abrt-desktop-2.0.8-44.el6.centos.i686.rpm Virtual package to install all necessary packages for usage from desktop environment
abrt-devel-2.0.8-44.el6.centos.i686.rpm Development libraries for abrt
abrt-gui-2.0.8-44.el6.centos.i686.rpm abrt's gui
Advertisement
Advertisement