php-pecl-amqp-1.8.0-2.el5.remi.5.4.i386.rpm


Advertisement

Description

php-pecl-amqp - Communicate with any AMQP compliant server

Property Value
Distribution CentOS 5
Repository Les RPM de Remi i386
Package name php-pecl-amqp
Package version 1.8.0
Package release 2.el5.remi.5.4
Package architecture i386
Package type rpm
Installed size 351.74 KB
Download size 115.57 KB
Official Mirror rpms.famillecollet.com
This extension can communicate with any AMQP spec 0-9-1 compatible server,
such as RabbitMQ, OpenAMQP and Qpid, giving you the ability to create and
delete exchanges and queues, as well as publish to any exchange and consume
from any queue.
Package built for PHP 5.4.

Alternatives

Package Version Architecture Repository
php-pecl-amqp-1.9.0-1.el5.remi.5.4.i386.rpm 1.9.0 i386 Les RPM de Remi
php-pecl-amqp-1.9.0-1.el5.remi.5.4.x86_64.rpm 1.9.0 x86_64 Les RPM de Remi
php-pecl-amqp-1.9.0-0.2.beta2.el5.remi.5.6.i386.rpm 1.9.0 i386 Les RPM de Remi Testing
php-pecl-amqp-1.9.0-0.2.beta2.el5.remi.5.6.x86_64.rpm 1.9.0 x86_64 Les RPM de Remi Testing
php-pecl-amqp-1.9.0-0.1.beta1.el5.remi.5.6.i386.rpm 1.9.0 i386 Les RPM de Remi Testing
php-pecl-amqp-1.9.0-0.1.beta1.el5.remi.5.6.x86_64.rpm 1.9.0 x86_64 Les RPM de Remi Testing
php-pecl-amqp-1.8.0-2.el5.remi.5.4.x86_64.rpm 1.8.0 x86_64 Les RPM de Remi
php-pecl-amqp - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
librabbitmq-last >= 65536
librabbitmq.so.4 -
php(api) = 20100412
php(zend-abi) = 20100525
rtld(GNU_HASH) -

Provides

Name Value
amqp.so -
config(php-pecl-amqp) = 1.8.0-2.el5.remi.5.4
php-amqp = 1.8.0
php-pecl(amqp) = 1.8.0
php-pecl-amqp = 1.8.0-2.el5.remi.5.4

Obsoletes

Name Value
php53-pecl-amqp <= 1.8.0
php53u-pecl-amqp <= 1.8.0
php54-pecl-amqp <= 1.8.0
php54w-pecl-amqp <= 1.8.0

Download

Type URL
Binary Package php-pecl-amqp-1.8.0-2.el5.remi.5.4.i386.rpm
Source Package php-pecl-amqp-1.8.0-2.el5.remi.5.4.src.rpm

Install Howto

  1. Download the latest remi-release rpm from
    http://rpms.famillecollet.com/enterprise/5/remi/i386/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-pecl-amqp rpm package:
    # yum --enablerepo=remi install php-pecl-amqp

Files

Path
/etc/php-zts.d/amqp.ini
/etc/php.d/amqp.ini
/usr/lib/php-zts/modules/amqp.so
/usr/lib/php/modules/amqp.so
/usr/share/doc/pecl/amqp/CREDITS
/usr/share/doc/pecl/amqp/LICENSE
/usr/share/doc/pecl/amqp/benchmark.php
/usr/share/doc/pecl/amqp/stubs/AMQP.php
/usr/share/doc/pecl/amqp/stubs/AMQPBasicProperties.php
/usr/share/doc/pecl/amqp/stubs/AMQPChannel.php
/usr/share/doc/pecl/amqp/stubs/AMQPChannelException.php
/usr/share/doc/pecl/amqp/stubs/AMQPConnection.php
/usr/share/doc/pecl/amqp/stubs/AMQPConnectionException.php
/usr/share/doc/pecl/amqp/stubs/AMQPEnvelope.php
/usr/share/doc/pecl/amqp/stubs/AMQPException.php
/usr/share/doc/pecl/amqp/stubs/AMQPExchange.php
/usr/share/doc/pecl/amqp/stubs/AMQPExchangeException.php
/usr/share/doc/pecl/amqp/stubs/AMQPQueue.php
/usr/share/doc/pecl/amqp/stubs/AMQPQueueException.php
/var/lib/pear/pkgxml/php-pecl-amqp.xml

Changelog

2017-02-19 - Remi Collet <remi@remirepo.net> - 1.8.0-2
- ensure proper librabbitmq version is used
2017-02-17 - Remi Collet <remi@remirepo.net> - 1.8.0-1
- update to 1.8.0 (stable)
2016-12-01 - Remi Collet <remi@fedoraproject.org> - 1.8.0-0.3.beta2
- rebuild with PHP 7.1.0 GA
2016-11-07 - Remi Collet <remi@fedoraproject.org> - 1.8.0-0.2.beta2
- update to 1.8.0beta2
2016-11-01 - Remi Collet <remi@fedoraproject.org> - 1.8.0-0.1.beta1
- update to 1.8.0beta1
2016-09-14 - Remi Collet <remi@fedoraproject.org> - 1.7.1-2
- rebuild for PHP 7.1 new API version
2016-07-10 - Remi Collet <remi@fedoraproject.org> - 1.7.1-1
- Update to 1.7.1 (php 5 and 7, stable)
2016-04-26 - Remi Collet <remi@fedoraproject.org> - 1.7.0-1
- update to 1.7.0 (php 5 and 7, stable)
2016-03-04 - Remi Collet <remi@fedoraproject.org> - 1.7.0-0.3.alpha2
- adapt for F24
2015-12-26 - Remi Collet <remi@fedoraproject.org> - 1.7.0-0.2.alpha2
- update to 1.7.0alpha2

See Also

Package Description
php-pecl-apc-3.1.15-0.3.svn329913.el5.remi.i386.rpm APC caches and optimizes PHP intermediate code
php-pecl-apc-3.1.15-0.4.20130912.el5.remi.5.4.i386.rpm APC caches and optimizes PHP intermediate code
php-pecl-apc-devel-3.1.15-0.3.svn329913.el5.remi.i386.rpm APC developer files (header)
php-pecl-apc-devel-3.1.15-0.4.20130912.el5.remi.5.4.i386.rpm APC developer files (header)
php-pecl-apcu-4.0.11-1.el5.remi.5.4.i386.rpm APC User Cache
php-pecl-apcu-4.0.11-2.el5.remi.5.4.i386.rpm APC User Cache
php-pecl-apcu-devel-4.0.11-1.el5.remi.5.4.i386.rpm APCu developer files (header)
php-pecl-apcu-devel-4.0.11-2.el5.remi.5.4.i386.rpm APCu developer files (header)
php-pecl-apfd-1.0.0-1.el5.remi.5.4.i386.rpm Always Populate Form Data
php-pecl-apfd-1.0.1-1.el5.remi.5.4.i386.rpm Always Populate Form Data
php-pecl-apm-2.1.2-1.el5.remi.5.4.i386.rpm Alternative PHP Monitor
php-pecl-apm-2.1.3-1.el5.remi.5.4.i386.rpm Alternative PHP Monitor
php-pecl-ares-0.8.0-1.el5.remi.5.4.i386.rpm Asynchronous Resolver
php-pecl-bbcode-1.0.3-0.2.b1.el5.remi.i386.rpm BBCode parsing Extension
php-pecl-bbcode-1.0.3-0.4.b1.el5.remi.5.4.i386.rpm BBCode parsing Extension
Advertisement
Advertisement