php-herrera-io-version-1.1.1-1.el5.remi.noarch.rpm


Advertisement

Description

php-herrera-io-version - A library for creating, editing, and comparing semantic versioning numbers

Property Value
Distribution CentOS 5
Repository Les RPM de Remi i386
Package name php-herrera-io-version
Package version 1.1.1
Package release 1.el5.remi
Package architecture noarch
Package type rpm
Installed size 26.33 KB
Download size 9.96 KB
Official Mirror rpms.remirepo.net
A library for creating, editing, and comparing semantic versioning numbers.
Currently, v2.0.0 of the Semantic Versioning specification is supported.
To use this library, you just have to add, in your project:
require_once '/usr/share/php/Herrera/Version/autoload.php';

Alternatives

Package Version Architecture Repository
php-herrera-io-version-1.1.1-1.el5.remi.noarch.rpm 1.1.1 noarch Les RPM de Remi
php-herrera-io-version - - -

Requires

Name Value
php(language) >= 5.3.3
php-composer(symfony/class-loader) -
php-pcre -

Provides

Name Value
php-composer(herrera-io/version) = 1.1.1
php-herrera-io-version = 1.1.1-1.el5.remi

Download

Type URL
Binary Package php-herrera-io-version-1.1.1-1.el5.remi.noarch.rpm
Source Package php-herrera-io-version-1.1.1-1.el5.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/enterprise/5/remi/i386/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-herrera-io-version rpm package:
    # yum --enablerepo=remi install php-herrera-io-version

Files

Path
/usr/share/doc/php-herrera-io-version-1.1.1/LICENSE
/usr/share/doc/php-herrera-io-version-1.1.1/README.md
/usr/share/doc/php-herrera-io-version-1.1.1/composer.json
/usr/share/php/Herrera/
/usr/share/php/Herrera/Version/Builder.php
/usr/share/php/Herrera/Version/Comparator.php
/usr/share/php/Herrera/Version/Dumper.php
/usr/share/php/Herrera/Version/Parser.php
/usr/share/php/Herrera/Version/Validator.php
/usr/share/php/Herrera/Version/Version.php
/usr/share/php/Herrera/Version/autoload.php
/usr/share/php/Herrera/Version/Exception/InvalidIdentifierException.php
/usr/share/php/Herrera/Version/Exception/InvalidNumberException.php
/usr/share/php/Herrera/Version/Exception/InvalidStringRepresentationException.php
/usr/share/php/Herrera/Version/Exception/VersionException.php

Changelog

2015-10-21 - Remi Collet <remi@fedoraproject.org> - 1.1.1-1
- initial package

See Also

Package Description
php-horde-Horde-Alarm-2.2.7-1.el5.remi.noarch.rpm Horde Alarm Libraries
php-horde-Horde-Alarm-2.2.8-1.el5.remi.noarch.rpm Horde Alarm Libraries
php-horde-Horde-Argv-2.0.11-1.el5.remi.noarch.rpm Horde command-line argument parsing package
php-horde-Horde-Argv-2.0.12-1.el5.remi.noarch.rpm Horde command-line argument parsing package
php-horde-Horde-Auth-2.2.0-1.el5.remi.noarch.rpm Horde Authentication API
php-horde-Horde-Auth-2.2.1-1.el5.remi.noarch.rpm Horde Authentication API
php-horde-Horde-Autoloader-2.1.1-3.el5.remi.noarch.rpm Horde Autoloader
php-horde-Horde-Autoloader-2.1.2-1.el5.remi.noarch.rpm Horde Autoloader
php-horde-Horde-Browser-2.0.12-1.el5.remi.noarch.rpm Horde Browser API
php-horde-Horde-Browser-2.0.13-1.el5.remi.noarch.rpm Horde Browser API
php-horde-Horde-Cache-2.5.4-1.el5.remi.noarch.rpm Horde Caching API
php-horde-Horde-Cache-2.5.5-1.el5.remi.noarch.rpm Horde Caching API
php-horde-Horde-Cli-2.0.7-1.el5.remi.noarch.rpm Horde Command Line Interface API
php-horde-Horde-Cli-2.1.0-1.el5.remi.noarch.rpm Horde Command Line Interface API
php-horde-Horde-Compress-2.1.5-1.el5.remi.noarch.rpm Horde Compression API
Advertisement
Advertisement