php-herrera-io-phar-update-2.0.0-2.el5.remi.noarch.rpm


Advertisement

Description

php-herrera-io-phar-update - A library for self-updating Phars

Property Value
Distribution CentOS 5
Repository Les RPM de Remi i386
Package name php-herrera-io-phar-update
Package version 2.0.0
Package release 2.el5.remi
Package architecture noarch
Package type rpm
Installed size 19.08 KB
Download size 10.02 KB
Official Mirror rpms.remirepo.net
A library for self-updating Phars.
This library handles the updating of applications packaged as
distributable Phars. The modular design allows for a more
customizable update process.
To use this library, you just have to add, in your project:
require_once '/usr/share/php/Herrera/Phar/Update/autoload.php';

Alternatives

Package Version Architecture Repository
php-herrera-io-phar-update-2.0.0-2.el5.remi.noarch.rpm 2.0.0 noarch Les RPM de Remi
php-herrera-io-phar-update-2.0.0-1.el5.remi.noarch.rpm 2.0.0 noarch Les RPM de Remi
php-herrera-io-phar-update-2.0.0-1.el5.remi.noarch.rpm 2.0.0 noarch Les RPM de Remi
php-herrera-io-phar-update - - -

Requires

Name Value
php(language) >= 5.3.3
php-composer(herrera-io/json) < 2
php-composer(herrera-io/json) >= 1.0
php-composer(herrera-io/version) < 2
php-composer(herrera-io/version) >= 1.0
php-composer(symfony/class-loader) -
php-phar -
php-spl -

Provides

Name Value
php-composer(herrera-io/phar-update) = 2.0.0
php-herrera-io-phar-update = 2.0.0-2.el5.remi

Download

Type URL
Binary Package php-herrera-io-phar-update-2.0.0-2.el5.remi.noarch.rpm
Source Package php-herrera-io-phar-update-2.0.0-2.el5.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/enterprise/5/remi/i386/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-herrera-io-phar-update rpm package:
    # yum --enablerepo=remi install php-herrera-io-phar-update

Files

Path
/usr/share/doc/php-herrera-io-phar-update-2.0.0/LICENSE
/usr/share/doc/php-herrera-io-phar-update-2.0.0/README.md
/usr/share/doc/php-herrera-io-phar-update-2.0.0/composer.json
/usr/share/php-herrera-io-phar-update/res/schema.json
/usr/share/php/Herrera/Phar/
/usr/share/php/Herrera/Phar/Update/Manager.php
/usr/share/php/Herrera/Phar/Update/Manifest.php
/usr/share/php/Herrera/Phar/Update/Update.php
/usr/share/php/Herrera/Phar/Update/autoload.php
/usr/share/php/Herrera/Phar/Update/Exception/Exception.php
/usr/share/php/Herrera/Phar/Update/Exception/ExceptionInterface.php
/usr/share/php/Herrera/Phar/Update/Exception/FileException.php
/usr/share/php/Herrera/Phar/Update/Exception/InvalidArgumentException.php
/usr/share/php/Herrera/Phar/Update/Exception/LogicException.php

Changelog

2015-10-27 - Remi Collet <remi@fedoraproject.org> - 1.0.3-2
- fix resources installation
2015-10-21 - Remi Collet <remi@fedoraproject.org> - 1.0.3-1
- initial package

See Also

Package Description
php-herrera-io-phpunit-test-case-1.2.1-1.el5.remi.noarch.rpm PHPUnit test case class with additional functionality
php-herrera-io-version-1.1.1-1.el5.remi.noarch.rpm A library for creating, editing, and comparing semantic versioning numbers
php-horde-Horde-Alarm-2.2.7-1.el5.remi.noarch.rpm Horde Alarm Libraries
php-horde-Horde-Alarm-2.2.8-1.el5.remi.noarch.rpm Horde Alarm Libraries
php-horde-Horde-Argv-2.0.11-1.el5.remi.noarch.rpm Horde command-line argument parsing package
php-horde-Horde-Argv-2.0.12-1.el5.remi.noarch.rpm Horde command-line argument parsing package
php-horde-Horde-Auth-2.2.0-1.el5.remi.noarch.rpm Horde Authentication API
php-horde-Horde-Auth-2.2.1-1.el5.remi.noarch.rpm Horde Authentication API
php-horde-Horde-Autoloader-2.1.1-3.el5.remi.noarch.rpm Horde Autoloader
php-horde-Horde-Autoloader-2.1.2-1.el5.remi.noarch.rpm Horde Autoloader
php-horde-Horde-Browser-2.0.12-1.el5.remi.noarch.rpm Horde Browser API
php-horde-Horde-Browser-2.0.13-1.el5.remi.noarch.rpm Horde Browser API
php-horde-Horde-Cache-2.5.4-1.el5.remi.noarch.rpm Horde Caching API
php-horde-Horde-Cache-2.5.5-1.el5.remi.noarch.rpm Horde Caching API
php-horde-Horde-Cli-2.0.7-1.el5.remi.noarch.rpm Horde Command Line Interface API
Advertisement
Advertisement