rubygem-gem_plugin-0.2.2-2.PU_IAS.5.noarch.rpm


Advertisement

Description

rubygem-gem_plugin - A plugin system based only on rubygems that uses dependencies only

Property Value
Distribution CentOS 5
Repository PUIAS Unsupported x86_64
Package name rubygem-gem_plugin
Package version 0.2.2
Package release 2.PU_IAS.5
Package architecture noarch
Package type rpm
Installed size 266.85 KB
Download size 109.12 KB
Official Mirror springdale.math.ias.edu
A plugin system based only on rubygems that uses dependencies only

Alternatives

Package Version Architecture Repository
rubygem-gem_plugin-0.2.3-1.el5.rf.noarch.rpm 0.2.3 noarch Repoforge (RPMforge)
rubygem-gem_plugin-0.2.3-1.el5.rf.noarch.rpm 0.2.3 noarch Repoforge (RPMforge)
rubygem-gem_plugin-0.2.2-2.PU_IAS.5.noarch.rpm 0.2.2 noarch PUIAS Unsupported
rubygem-gem_plugin - - -

Requires

Name Value
/usr/bin/ruby -
rubygem(rake) >= 0.7
rubygems -

Provides

Name Value
rubygem(gem_plugin) = 0.2.2
rubygem-gem_plugin = 0.2.2-2.PU_IAS.5

Download

Type URL
Binary Package rubygem-gem_plugin-0.2.2-2.PU_IAS.5.noarch.rpm
Source Package rubygem-gem_plugin-0.2.2-2.PU_IAS.5.src.rpm

Install Howto

  1. Create the repository config file /etc/yum.repos.d/puias-unsupported.repo:
    [puias-unsupported]
    name=PUIAS Unsupported
    baseurl=http://springdale.math.ias.edu/data/puias/unsupported/5/x86_64/
    enabled=1
    gpgcheck=0
    
  2. Install rubygem-gem_plugin rpm package:
    # yum install rubygem-gem_plugin

Files

Path
/usr/bin/gpgen
/usr/lib/ruby/gems/1.8/cache/gem_plugin-0.2.2.gem
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/created.rid
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/fr_class_index.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/fr_file_index.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/fr_method_index.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/index.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/rdoc-style.css
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Base.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Manager.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/PluginNotLoaded.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin.src/M000001.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Base.src/M000002.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Base.src/M000003.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Base.src/M000004.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Manager.src/M000005.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Manager.src/M000006.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Manager.src/M000007.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Manager.src/M000008.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Manager.src/M000009.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Manager.src/M000010.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/classes/GemPlugin/Manager.src/M000011.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/files/README.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/rdoc/files/lib/gem_plugin_rb.html
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/created.rid
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Plugin-c.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/cdesc-GemPlugin.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Base/category%3d-c.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Base/cdesc-Base.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Base/inherited-c.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Base/new-c.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Manager/cdesc-Manager.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Manager/config-i.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Manager/create-i.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Manager/load-i.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Manager/loaded%3f-i.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Manager/new-c.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Manager/register-i.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/Manager/resource-i.yaml
/usr/lib/ruby/gems/1.8/doc/gem_plugin-0.2.2/ri/GemPlugin/PluginNotLoaded/cdesc-PluginNotLoaded.yaml
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/COPYING
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/LICENSE
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/README
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/Rakefile
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/bin/gpgen
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/created.rid
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/fr_class_index.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/fr_file_index.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/fr_method_index.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/index.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/rdoc-style.css
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Base.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Manager.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/PluginNotLoaded.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin.src/M000001.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Base.src/M000002.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Base.src/M000003.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Base.src/M000004.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Manager.src/M000005.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Manager.src/M000006.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Manager.src/M000007.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Manager.src/M000008.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Manager.src/M000009.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Manager.src/M000010.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/classes/GemPlugin/Manager.src/M000011.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/files/COPYING.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/files/LICENSE.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/files/README.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/doc/rdoc/files/lib/gem_plugin_rb.html
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/lib/gem_plugin.rb
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/resources/COPYING
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/resources/LICENSE
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/resources/README
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/resources/Rakefile
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/resources/lib/
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/resources/lib/project/init.rb
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/resources/resources/defaults.yaml
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/resources/tools/rakehelp.rb
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/test/test_plugins.rb
/usr/lib/ruby/gems/1.8/gems/gem_plugin-0.2.2/tools/rakehelp.rb
/usr/lib/ruby/gems/1.8/specifications/gem_plugin-0.2.2.gemspec

Changelog

2007-08-24 - Scott Seago <sseago@redhat.com> - 0.2.2-2
- rpmlint fixes
- added Ruby >= 1.8.6 Requires
2007-03-06 - <sseago@redhat.com> - 0.2.2-1
- Initial packaging.

See Also

Package Description
rubygem-mongrel-1.0.1-6.PU_IAS.5.x86_64.rpm A small fast HTTP library and server for Ruby apps
rubygem-rails-2.1.1-2.el5.noarch.rpm Web-application framework
rubygem-rake-0.8.3-1.PU_IAS.5.noarch.rpm Ruby based make-like utility
rubygems-1.3.1-1.el5.noarch.rpm The Ruby standard for packaging ruby libraries
sabayon-2.12.4-4.1.PU_IAS.5.x86_64.rpm Tool to maintain user profiles in a GNOME desktop
sabayon-apply-2.12.4-4.1.PU_IAS.5.x86_64.rpm The parts of sabayon needed on the client systems
siege-3.0.0-2.sdl5.x86_64.rpm HTTP regression testing and benchmarking utility
smolt-1.0-1.PU_IAS.5.noarch.rpm Fedora hardware profiler
smolt-firstboot-1.0-1.PU_IAS.5.noarch.rpm Fedora hardware profile firstboot
smolt-gui-1.0-1.PU_IAS.5.noarch.rpm Fedora hardware profiler gui
smolt-server-1.0-1.PU_IAS.5.noarch.rpm Fedora hardware profiler server
spamassassin-3.3.1-2.el5.x86_64.rpm Spam filter for email which can be invoked from mail delivery agents
spambayes-1.0.4-5.PU_IAS.5.noarch.rpm Bayesian anti-spam filter
speex-1.2beta2-1.x86_64.rpm An open-source, patent-free speech codec
speex-devel-1.2beta2-1.x86_64.rpm Speex development files
Advertisement
Advertisement