php-pecl-imagick-3.1.0b1-9.PU_IAS.5.x86_64.rpm


Advertisement

Description

php-pecl-imagick - Provides a wrapper to the ImageMagick library

Property Value
Distribution CentOS 5
Repository PUIAS Unsupported x86_64
Package name php-pecl-imagick
Package version 3.1.0b1
Package release 9.PU_IAS.5
Package architecture x86_64
Package type rpm
Installed size 344.87 KB
Download size 104.80 KB
Official Mirror springdale.math.ias.edu
imagick is a native php extension to create and modify images using the
ImageMagick API.
This extension requires ImageMagick version 6.2.4+ and PHP 5.1.3+.
IMPORTANT: Version 2.x API is not compatible with earlier versions.

Alternatives

Package Version Architecture Repository
php-pecl-imagick-3.4.3-1.el5.remi.5.4.i386.rpm 3.4.3 i386 Les RPM de Remi
php-pecl-imagick-3.4.3-1.el5.remi.5.4.x86_64.rpm 3.4.3 x86_64 Les RPM de Remi
php-pecl-imagick-3.4.3-0.8.RC4.el5.remi.5.4.i386.rpm 3.4.3 i386 Les RPM de Remi
php-pecl-imagick-3.4.3-0.8.RC4.el5.remi.5.4.x86_64.rpm 3.4.3 x86_64 Les RPM de Remi
php-pecl-imagick-3.4.3-0.1.RC1.el5.remi.5.4.i386.rpm 3.4.3 i386 Les RPM de Remi Testing
php-pecl-imagick-3.4.3-0.1.RC1.el5.remi.5.4.x86_64.rpm 3.4.3 x86_64 Les RPM de Remi Testing
php-pecl-imagick-3.4.0-0.6.RC6.el5.remi.5.4.i386.rpm 3.4.0 i386 Les RPM de Remi Testing
php-pecl-imagick-3.4.0-0.6.RC6.el5.remi.5.4.x86_64.rpm 3.4.0 x86_64 Les RPM de Remi Testing
php-pecl-imagick-2.2.1-3.el5.i386.rpm 2.2.1 i386 EPEL
php-pecl-imagick-2.2.1-3.el5.x86_64.rpm 2.2.1 x86_64 EPEL
php-pecl-imagick - - -

Requires

Name Value
/usr/bin/pecl -
config(php-pecl-imagick) = 3.1.0b1-9.PU_IAS.5
libMagick.so.10()(64bit) -
libWand.so.10()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
php(api) = 20041225
php(zend-abi) = 20060613
rtld(GNU_HASH) -

Provides

Name Value
config(php-pecl-imagick) = 3.1.0b1-9.PU_IAS.5
imagick.so()(64bit) -
php-pecl(imagick) = 3.1.0b1
php-pecl-imagick = 3.1.0b1-9.PU_IAS.5

Conflicts

Name Value
php-pecl-gmagick -

Download

Type URL
Binary Package php-pecl-imagick-3.1.0b1-9.PU_IAS.5.x86_64.rpm
Source Package php-pecl-imagick-3.1.0b1-9.PU_IAS.5.src.rpm

Install Howto

  1. Create the repository config file /etc/yum.repos.d/puias-unsupported.repo:
    [puias-unsupported]
    name=PUIAS Unsupported
    baseurl=http://springdale.math.ias.edu/data/puias/unsupported/5/x86_64/
    enabled=1
    gpgcheck=0
    
  2. Install php-pecl-imagick rpm package:
    # yum install php-pecl-imagick

Files

Path
/etc/php.d/imagick.ini
/usr/lib64/php/modules/imagick.so
/usr/share/doc/php-pecl-imagick-3.1.0b1/CREDITS
/usr/share/doc/php-pecl-imagick-3.1.0b1/INSTALL
/usr/share/doc/php-pecl-imagick-3.1.0b1/TODO
/usr/share/doc/php-pecl-imagick-3.1.0b1/examples/captcha.php
/usr/share/doc/php-pecl-imagick-3.1.0b1/examples/polygon.php
/usr/share/doc/php-pecl-imagick-3.1.0b1/examples/thumbnail.php
/usr/share/doc/php-pecl-imagick-3.1.0b1/examples/watermark.php
/usr/share/pear/.pkgxml/imagick.xml

Changelog

2011-02-09 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.0-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
2010-09-29 - jkeating - 3.0.0-8
- Rebuilt for gcc bug 634757
2010-09-16 - Pavel Alexeev <Pahan@Hubbitus.info> - 3.0.0-7
- Rebuild against new ImageMagick
2010-07-23 - Pavel Alexeev <Pahan@Hubbitus.info> - 3.0.0-6
- Update to 3.0.0
- Add Conflicts: php-pecl-gmagick - BZ#559675
- Delete new and unneeded files "rm -rf %{buildroot}/%{_includedir}/php/ext/%peclName/"
2010-05-15 - Pavel Alexeev <Pahan@Hubbitus.info> - 2.3.0-5
- New version 2.3.0
2010-03-24 - Mike McGrath <mmcgrath@redhat.com> - 2.2.2-4.1
- Rebuilt for broken dep fix
2009-07-26 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.2-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
2009-07-13 - Remi Collet <Fedora@FamilleCollet.com> - 2.2.2-3
- rebuild for new PHP 5.3.0 ABI (20090626)
2009-03-10 - Pavel Alexeev <Pahan@Hubbitus.info> - 2.2.2-2
- Rebuild due ImageMagick update
2009-02-28 - Pavel Alexeev <Pahan@Hubbitus.info> - 2.2.2-1
- Step to version 2.2.2

See Also

Package Description
php-pecl-json-1.2.1-1.PU_IAS.5.x86_64.rpm JSON is a PHP extension for JavaScript Object Notation
plone-3.0.6-1.PU_IAS.5.x86_64.rpm User friendly and powerful open source Content Management System
plone-PloneLdap-1.0-1.PU_IAS.5.x86_64.rpm The PloneLDAP product is intended to make it easier to use LDAP connections in a Plone website
polymake-2.3-2.el5.x86_64.rpm Algorithms around polytopes and polyhedra
puppet-0.25.4-1.PU_IAS.5.noarch.rpm A network tool for managing many disparate systems
puppet-server-0.25.4-1.PU_IAS.5.noarch.rpm Server for the puppet system management tool
pyOpenSSL-0.6-1.p24.7.2.2.0.x86_64.rpm Python wrapper module around the OpenSSL library
python-babel-0.9.4-1.PU_IAS.5.noarch.rpm Library for internationalizing Python applications
python-bibtex-1.2.4-7.PU_IAS.5.x86_64.rpm Python extension to parse BibTeX files
python-configobj-4.4.0-1.el5ipa.noarch.rpm Config file reading, writing, and validation
python-docutils-0.5-3.el5.noarch.rpm A system for processing plaintext documentation
python-feedparser-4.1-3.PU_IAS.5.noarch.rpm Parse RSS and Atom feeds in Python
python-genshi-0.5.1-1.PU_IAS.5.x86_64.rpm Toolkit for stream-based generation of output for the web
python-jinja2-2.2.1-1.sdl5.x86_64.rpm General purpose template engine
python-netgroup-0.11-1.PU_IAS.1.x86_64.rpm Python modules for querying netgroup information
Advertisement
Advertisement