perl-DBD-SQLite-1.14-3.PU_IAS.5.x86_64.rpm


Advertisement

Description

perl-DBD-SQLite - Self Contained RDBMS in a DBI Driver

Distribution: CentOS 5
Repository: PUIAS Unsupported x86_64
Package name: perl-DBD-SQLite
Package version: 1.14
Package release: 3.PU_IAS.5
Package architecture: x86_64
Package type: rpm
Installed size: 553.16 KB
Download size: 275.89 KB
Official Mirror: springdale.math.ias.edu
SQLite is a public domain RDBMS database engine that you can find at http://www.hwaci.com/sw/sqlite/. Rather than ask you to install SQLite first, because SQLite is public domain, DBD::SQLite includes the entire thing in the distribution. So in order to get a fast transaction capable RDBMS working for your perl project you simply have to install this module, and nothing else. As of version 1.09 it can use the external SQLite library (>= 3.1.3).

Provides

  • SQLite.so()(64bit)
  • perl(DBD::SQLite) = 1.14
  • perl(DBD::SQLite::db)
  • perl(DBD::SQLite::dr)
  • perl-DBD-SQLite = 1.14-3.PU_IAS.5

    Install Howto

    1. Create the repository config file /etc/yum.repos.d/puias-unsupported.repo:
      [puias-unsupported]
      name=PUIAS Unsupported
      baseurl=http://springdale.math.ias.edu/data/puias/unsupported/5/x86_64/
      enabled=1
      gpgcheck=0
      
    2. Install perl-DBD-SQLite rpm package:
      # yum install perl-DBD-SQLite

    Files

    • /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/DBD/SQLite.pm
    • /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/DBD/
    • /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/DBD/SQLite/SQLite.so
    • /usr/share/doc/perl-DBD-SQLite-1.14/Changes
    • /usr/share/doc/perl-DBD-SQLite-1.14/README
    • /usr/share/man/man3/DBD::SQLite.3pm.gz

    Changelog

    2008-07-15 - Marcela Maslanova <mmaslano@redhat.com> 1.14-3 - add rt32100 patch - same problem as in #245699

    2007-12-19 - Steven Pritchard <steve@kspei.com> 1.14-2 - Fix find option order. - Use fixperms macro instead of our own chmod incantation.

    2007-12-10 - Robin Norwood <rnorwood@redhat.com> - 1.14-1 - Update to latest upstream version: 1.14 - Remove patch - no longer needed.

    2007-10-15 - Tom "spot" Callaway <tcallawa@redhat.com> - 1.12-2.1 - correct license tag - add BR: perl(ExtUtils::MakeMaker)

    2006-09-14 - Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-2 - Rebuild for FC6.

    2006-04-11 - Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.12-1 - Update to 1.12.

    2006-04-05 - Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-4 - Patch to build with system sqlite 3.3.x (#183530). - Patch to avoid type information segv (#187873).

    2006-03-09 - Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-3 - DBD::SQLite fails to build with the current FC-5 sqlite version (3.3.3); see bugzilla entry #183530. Forcing package rebuild with the included version of sqlite (3.2.7).

    2006-02-18 - Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-2 - Rebuild for FC5 (perl 5.8.8).

    2005-12-02 - Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.11-1 - Update to 1.11.

    Advertisement
    Advertisement