logsurfer-1.8-8.sdl5.x86_64.rpm


Advertisement

Description

logsurfer - Powerful tool to observe logfiles

Property Value
Distribution CentOS 5
Repository PUIAS Unsupported x86_64
Package name logsurfer
Package version 1.8
Package release 8.sdl5
Package architecture x86_64
Package type rpm
Installed size 93.21 KB
Download size 54.00 KB
Official Mirror springdale.math.ias.edu
This program makes it possible to observe logfiles and to react on
special events, that can be defined by regular expressions, with a
defined action, e.g. to send a mail.

Alternatives

Package Version Architecture Repository
logsurfer-1.8-8.sdl5.i386.rpm 1.8 i386 PUIAS Unsupported
logsurfer - - -

Requires

Name Value
config(logsurfer) = 1.8-8.sdl5
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
config(logsurfer) = 1.8-8.sdl5
logsurf -
logsurfer = 1.8-8.sdl5

Download

Type URL
Binary Package logsurfer-1.8-8.sdl5.x86_64.rpm
Source Package logsurfer-1.8-8.sdl5.src.rpm

Install Howto

  1. Create the repository config file /etc/yum.repos.d/puias-unsupported.repo:
    [puias-unsupported]
    name=PUIAS Unsupported
    baseurl=http://springdale.math.ias.edu/data/puias/unsupported/5/x86_64/
    enabled=1
    gpgcheck=0
    
  2. Install logsurfer rpm package:
    # yum install logsurfer

Files

Path
/etc/logsurfer.conf
/usr/bin/logsurfer
/usr/share/doc/logsurfer-1.8/ChangeLog
/usr/share/doc/logsurfer-1.8/DISCLAIMER
/usr/share/doc/logsurfer-1.8/README
/usr/share/doc/logsurfer-1.8/TODO
/usr/share/doc/logsurfer-1.8/contrib/README
/usr/share/doc/logsurfer-1.8/contrib/prtime/README
/usr/share/doc/logsurfer-1.8/contrib/prtime/prtime.c
/usr/share/doc/logsurfer-1.8/contrib/start-mail/README
/usr/share/doc/logsurfer-1.8/contrib/start-mail/start-mail
/usr/share/man/man1/logsurfer.1.gz
/usr/share/man/man4/logsurfer.conf.4.gz

Changelog

2014-10-08 - Josko Plazonic <plazonic@princeton.edu>
- adapt for rhel type of distro
2012-09-10 - Greg.Freemyer@gmail.com
- change names of patches per opensuse guidelines
2012-09-05 - Greg.Freemyer@gmail.com
- run spec-cleaner
- add SLES support back in
2012-08-22 - Greg.Freemyer@gmail.com
- logsurfer-double-free-fix.diff - dropped patch - now in upstream
- upgrade to v1.8
Now just Logsurfer, not Logsurfer+ any more
A bug fix and a couple of extra command-line options:
- D command line option for daemon mode. Warning: closes stdin, stdout, & stderr, therefore no error messages
- F command line option to auto re-open log file
2011-10-17 - draht@suse.de
- logsurfer-double-free-fix.diff: fix for a double free
vulnerability in sec/exec.c
2010-02-26 - draht@suse.de
- rigorous cleanup of BuildRequires:
2010-02-26 - draht@suse.de
- logsurfer+-1.7.
2002-10-10 - draht@suse.de
- logsurfer-ob1-heap_plus_initialization.diff solves an off by one
overflow and a bug caused by uninitialized memory (security).
2001-05-17 - cihlar@suse.cz
- fixed cast warnings on ia64
2001-03-07 - cihlar@suse.cz
- update to version 1.5a

See Also

Package Description
logsurfer-doc-1.8-8.sdl5.x86_64.rpm Regex documentation from the full regex package
lshw-B.02.12.01-1.PU_IAS.5.x86_64.rpm Hardware lister
lshw-gui-B.02.12.01-1.PU_IAS.5.x86_64.rpm Graphical hardware lister
lua-5.1.2-1.PU_IAS.5.x86_64.rpm Powerful light-weight programming language
lua-devel-5.1.2-1.PU_IAS.5.x86_64.rpm Development files for lua
lzma-4.32.7-1.PU_IAS.5.x86_64.rpm LZMA utils
lzma-devel-4.32.7-1.PU_IAS.5.x86_64.rpm Devel libraries & headers for liblzmadec
lzma-libs-4.32.7-1.PU_IAS.5.x86_64.rpm Libraries for decoding LZMA compression
mail-notification-4.1-3.PU_IAS.5.x86_64.rpm Status icon that informs you if you have new mail
mail-notification-evolution-plugin-4.1-3.PU_IAS.5.x86_64.rpm Evolution plugin for Mail Notification
maxima-5.14.0-1.PU_IAS.4.x86_64.rpm Symbolic Computation Program
maxima-exec-clisp-5.14.0-1.PU_IAS.4.x86_64.rpm Maxima compiled with clisp
maxima-lang-es-5.14.0-1.PU_IAS.4.x86_64.rpm Maxima Spanish language pack
maxima-lang-es-utf8-5.14.0-1.PU_IAS.4.x86_64.rpm Maxima Spanish UTF-8 language pack
maxima-lang-pt-5.14.0-1.PU_IAS.4.x86_64.rpm Maxima Portuguese language pack
Advertisement
Advertisement