itk-3.3-0.4.RC1.PU_IAS.5.x86_64.rpm


Advertisement

Description

itk - Object oriented extensions to Tk

Property Value
Distribution CentOS 5
Repository PUIAS Unsupported x86_64
Package name itk
Package version 3.3
Package release 0.4.RC1.PU_IAS.5
Package architecture x86_64
Package type rpm
Installed size 96.07 KB
Download size 55.89 KB
Official Mirror springdale.math.ias.edu
[incr Tk] is Tk extension that provides object-oriented features that are
missing from the Tk extension to Tcl.  The OO features provided by itk are
useful for building megawidgets.

Alternatives

Package Version Architecture Repository
itk-3.3-0.4.RC1.el5.x86_64.rpm 3.3 x86_64 EPEL
itk-3.3-0.4.RC1.el5.i386.rpm 3.3 i386 EPEL
itk-3.3-0.4.RC1.el5.i386.rpm 3.3 i386 EPEL
itk-3.3-0.4.RC1.PU_IAS.5.i386.rpm 3.3 i386 PUIAS Unsupported
itk - - -

Requires

Name Value
itcl -
libX11.so.6()(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
rtld(GNU_HASH) -
tk -

Provides

Name Value
itk = 3.3-0.4.RC1.PU_IAS.5
libitk3.3.so()(64bit) -

Download

Type URL
Binary Package itk-3.3-0.4.RC1.PU_IAS.5.x86_64.rpm
Source Package itk-3.3-0.4.RC1.PU_IAS.5.src.rpm

Install Howto

  1. Create the repository config file /etc/yum.repos.d/puias-unsupported.repo:
    [puias-unsupported]
    name=PUIAS Unsupported
    baseurl=http://springdale.math.ias.edu/data/puias/unsupported/5/x86_64/
    enabled=1
    gpgcheck=0
    
  2. Install itk rpm package:
    # yum install itk

Files

Path
/usr/lib64/itk3.3/Archetype.itk
/usr/lib64/itk3.3/Toplevel.itk
/usr/lib64/itk3.3/Widget.itk
/usr/lib64/itk3.3/itk.tcl
/usr/lib64/itk3.3/libitk3.3.so
/usr/lib64/itk3.3/pkgIndex.tcl
/usr/lib64/itk3.3/tclIndex
/usr/share/doc/itk-3.3/README
/usr/share/doc/itk-3.3/license.terms
/usr/share/man/mann/Archetype.n.gz
/usr/share/man/mann/Toplevel.n.gz
/usr/share/man/mann/Widget.n.gz
/usr/share/man/mann/itk.n.gz
/usr/share/man/mann/itkvars.n.gz
/usr/share/man/mann/usual.n.gz

Changelog

2006-08-28 - Wart <wart at kobold.org> - 3.3-0.4.RC1
- Rebuild for Fedora Extras
2006-06-01 - Wart <wart at kobold.org> - 3.3-0.3.RC1
- Fixed Requires: for -devel subpackage
2006-01-11 - Wart <wart at kobold.org> - 3.3-0.2.RC1
- Fix quoting bug that is exposed by bash >= 3.1
2006-01-09 - Wart <wart at kobold.org> - 3.3-0.1.RC1
- New itk package from newly separated itk upstream sources.

See Also

Package Description
itk-devel-3.3-0.4.RC1.PU_IAS.5.x86_64.rpm Development headers and libraries for linking against itk
john-1.7.8-1.el5.x86_64.rpm John the Ripper password cracker
js-1.60-1.PU_IAS.1.x86_64.rpm JavaScript interpreter
js-devel-1.60-1.PU_IAS.1.x86_64.rpm Header files, libraries and development documentation for js
jsMath-3.6c-1.PU_IAS.5.noarch.rpm A Javascript Based Method of Including Mathematics in Web Pages
jsMath-fonts-3.6c-1.PU_IAS.5.noarch.rpm jsMath fonts
jsMath-fonts-sprite-3.6c-1.PU_IAS.5.noarch.rpm jsMath sprite fonts
keepassx-0.3.3-1.PU_IAS.1.x86_64.rpm KeePassX Cross Platform Password Manager
kmod-drbd-8.3.4-2.x86_64.rpm drbd kernel module(s)
kmod-drbd-xen-8.3.4-2.x86_64.rpm drbd kernel module(s)
kmod-e1000e-1.2.8-0.1.2.6.18_194.8.1.el5.x86_64.rpm e1000e kernel module(s)
kmod-gspca-1.00.20-0.2.PU_IAS.5.x86_64.rpm gspca kernel module(s)
kmod-gspca-xen-1.00.20-0.2.PU_IAS.5.x86_64.rpm gspca kernel module(s)
kmod-ocfs2-1.4.4-3.el5.x86_64.rpm ocfs2 kernel module(s)
kmod-ocfs2-xen-1.4.4-3.el5.x86_64.rpm ocfs2 kernel module(s)
Advertisement
Advertisement