rubygems-1.3.1-1.el5.noarch.rpm


Advertisement

Description

rubygems - The Ruby standard for packaging ruby libraries

Property Value
Distribution CentOS 5
Repository PUIAS Unsupported i386
Package name rubygems
Package version 1.3.1
Package release 1.el5
Package architecture noarch
Package type rpm
Installed size 568.56 KB
Download size 172.23 KB
Official Mirror springdale.math.ias.edu
RubyGems is the Ruby standard for publishing and managing third party
libraries.

Alternatives

Package Version Architecture Repository
rubygems-1.3.2-2.el5.rf.noarch.rpm 1.3.2 noarch Repoforge (RPMforge)
rubygems-1.3.2-2.el5.rf.noarch.rpm 1.3.2 noarch Repoforge (RPMforge)
rubygems-1.3.1-1.ep.noarch.rpm 1.3.1 noarch End Point
rubygems-1.3.1-1.ep.noarch.rpm 1.3.1 noarch End Point
rubygems-1.3.1-1.el5.noarch.rpm 1.3.1 noarch PUIAS Unsupported
rubygems-1.3.1-1.el5.noarch.rpm 1.3.1 noarch EPEL
rubygems-1.3.1-1.el5.noarch.rpm 1.3.1 noarch EPEL
rubygems - - -

Requires

Name Value
/usr/bin/ruby -
ruby(abi) = 1.8
ruby-rdoc -

Provides

Name Value
ruby(rubygems) = 1.3.1
rubygems = 1.3.1-1.el5

Download

Type URL
Binary Package rubygems-1.3.1-1.el5.noarch.rpm
Source Package rubygems-1.3.1-1.el5.src.rpm

Install Howto

  1. Create the repository config file /etc/yum.repos.d/puias-unsupported.repo:
    [puias-unsupported]
    name=PUIAS Unsupported
    baseurl=http://springdale.math.ias.edu/data/puias/unsupported/5/i386/
    enabled=1
    gpgcheck=0
    
  2. Install rubygems rpm package:
    # yum install rubygems

Files

Path
/usr/bin/gem
/usr/lib/ruby/gems/
/usr/lib/ruby/gems/1.8/
/usr/lib/ruby/gems/1.8/cache/
/usr/lib/ruby/gems/1.8/doc/
/usr/lib/ruby/gems/1.8/gems/
/usr/lib/ruby/gems/1.8/specifications/
/usr/lib/ruby/site_ruby/1.8/rubygems.rb
/usr/lib/ruby/site_ruby/1.8/ubygems.rb
/usr/lib/ruby/site_ruby/1.8/lib/
/usr/lib/ruby/site_ruby/1.8/rbconfig/datadir.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/builder.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/config_file.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/defaults.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/dependency.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/dependency_list.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/doc_manager.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/exceptions.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/ext.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/format.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/gem_openssl.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/gem_path_searcher.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/indexer.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/install_update_options.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/installer.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/local_remote_options.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/old_format.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/package.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/platform.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/remote_fetcher.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/require_paths_builder.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/requirement.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/rubygems_version.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/security.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/server.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/source_index.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/source_info_cache_entry.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/spec_fetcher.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/specification.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/test_utilities.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/timer.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/uninstaller.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/user_interaction.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/validator.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/version.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/version_option.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/build_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/cert_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/check_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/cleanup_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/contents_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/dependency_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/environment_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/fetch_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/generate_index_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/help_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/list_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/lock_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/mirror_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/outdated_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/pristine_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/query_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/rdoc_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/search_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/server_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/sources_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/specification_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/stale_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/uninstall_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/unpack_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/update_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/commands/which_command.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/digest/digest_adapter.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/digest/md5.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/digest/sha1.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/digest/sha2.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/ext/builder.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/ext/configure_builder.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/ext/ext_conf_builder.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/ext/rake_builder.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/package/f_sync_dir.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/package/tar_header.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/package/tar_input.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/package/tar_output.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/package/tar_reader.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/package/tar_writer.rb
/usr/lib/ruby/site_ruby/1.8/rubygems/package/tar_reader/entry.rb
/usr/share/doc/rubygems-1.3.1/ChangeLog
/usr/share/doc/rubygems-1.3.1/GPL.txt
/usr/share/doc/rubygems-1.3.1/LICENSE.txt
/usr/share/doc/rubygems-1.3.1/README
/usr/share/doc/rubygems-1.3.1/TODO

Changelog

2008-11-09 - Jeroen van Meeuwen <kanarip@kanarip.com> - 1.3.1-1
- New upstream version
2008-09-16 - David Lutterkort <dlutter@redhat.com> - 1.2.0-2
- Bump release because I forgot to check in newer patch
2008-09-16 - David Lutterkort <dlutter@redhat.com> - 1.2.0-1
- Updated for new setup.rb
- Simplified by removing conditionals that were needed for EL-4;
there's just no way we can support that with newer rubygems
2008-09-03 - Tom "spot" Callaway <tcallawa@redhat.com> - 0.9.4-2
- fix license tag
2007-07-27 - David Lutterkort <dlutter@redhat.com> - 0.9.4-1
- Conditionalize so it builds on RHEL4
2007-02-27 - David Lutterkort <dlutter@redhat.com> - 0.9.2-1
- New version
- Add patch0 to fix multilib sensitivity of Gem::dir (bz 227400)
2007-01-18 - David Lutterkort <dlutter@redhat.com> - 0.9.1-1
- New version; include LICENSE.txt and GPL.txt
- avoid '..' in gem_dir to work around a bug in gem installer
- add ruby-rdoc to requirements
2007-01-02 - David Lutterkort <dlutter@redhat.com> - 0.9.0-2
- Fix gem_dir to be arch independent
- Mention dual licensing in License field
2006-12-22 - David Lutterkort <dlutter@redhat.com> - 0.9.0-1
- Updated to 0.9.0
- Changed to agree with Fedora Extras guidelines
2006-01-09 - David Lutterkort <dlutter@redhat.com> - 0.8.11-1
- Updated for 0.8.11

See Also

Package Description
sabayon-2.12.4-4.1.PU_IAS.5.i386.rpm Tool to maintain user profiles in a GNOME desktop
sabayon-apply-2.12.4-4.1.PU_IAS.5.i386.rpm The parts of sabayon needed on the client systems
siege-3.0.0-2.sdl5.i386.rpm HTTP regression testing and benchmarking utility
smolt-1.0-1.PU_IAS.5.noarch.rpm Fedora hardware profiler
smolt-firstboot-1.0-1.PU_IAS.5.noarch.rpm Fedora hardware profile firstboot
smolt-gui-1.0-1.PU_IAS.5.noarch.rpm Fedora hardware profiler gui
smolt-server-1.0-1.PU_IAS.5.noarch.rpm Fedora hardware profiler server
spamassassin-3.3.1-2.el5.i386.rpm Spam filter for email which can be invoked from mail delivery agents
spambayes-1.0.4-5.PU_IAS.5.noarch.rpm Bayesian anti-spam filter
speex-1.2beta2-1.i386.rpm An open-source, patent-free speech codec
speex-devel-1.2beta2-1.i386.rpm Speex development files
svgalib-1.9.25-3.sdl5.i386.rpm Low-level fullscreen SVGA graphics library
svgalib-devel-1.9.25-3.sdl5.i386.rpm Development tools for the SVGAlib graphics library
syslog-ng-2.0.6-2.1.PU_IAS.5.i386.rpm Syslog replacement daemon
tcllib-1.9-2.el5.noarch.rpm The standard Tcl library
Advertisement
Advertisement