mod_wsgi-2.4-2.PU_IAS.5.i386.rpm


Advertisement

Description

mod_wsgi - A WSGI interface for Python web applications in Apache

Distribution: CentOS 5
Repository: PUIAS Unsupported i386
Package name: mod_wsgi
Package version: 2.4
Package release: 2.PU_IAS.5
Package architecture: i386
Package type: rpm
Installed size: 141.65 KB
Download size: 61.29 KB
Official Mirror: springdale.math.ias.edu
The mod_wsgi adapter is an Apache module that provides a WSGI compliant interface for hosting Python based web applications within Apache. The adapter is written completely in C code against the Apache C runtime and for hosting WSGI applications within Apache has a lower overhead than using existing WSGI adapters for mod_python or CGI.

Alternatives

Provides

  • config(mod_wsgi) = 2.4-2.PU_IAS.5
  • mod_wsgi = 2.4-2.PU_IAS.5
  • mod_wsgi.so

    Download

    Install Howto

    1. Create the repository config file /etc/yum.repos.d/puias-unsupported.repo:
      [puias-unsupported]
      name=PUIAS Unsupported
      baseurl=http://springdale.math.ias.edu/data/puias/unsupported/5/i386/
      enabled=1
      gpgcheck=0
      
    2. Install mod_wsgi rpm package:
      # yum install mod_wsgi

    Files

    • /etc/httpd/conf.d/wsgi.conf
    • /usr/lib/httpd/modules/mod_wsgi.so
    • /usr/share/doc/mod_wsgi-2.4/LICENCE
    • /usr/share/doc/mod_wsgi-2.4/README

    Changelog

    2008-10-08 - James Bowes <jbowes@redhat.com> 2.1-2 - Remove requires on httpd-devel

    2008-07-02 - James Bowes <jbowes@redhat.com> 2.1-1 - Update to 2.1

    2008-06-16 - Ricky Zhou <ricky@fedoraproject.org> 1.3-4 - Build against the shared python lib.

    2008-02-19 - Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.3-3 - Autorebuild for GCC 4.3

    2008-01-06 - James Bowes <jbowes@redhat.com> 1.3-2 - Require httpd

    2008-01-05 - James Bowes <jbowes@redhat.com> 1.3-1 - Update to 1.3

    2007-09-30 - James Bowes <jbowes@redhat.com> 1.0-1 - Initial packaging for Fedora

    Advertisement
    Advertisement