libfame-devel-0.9.1-12.PU_IAS.5.x86_64.rpm


Advertisement

Description

libfame-devel - Development files and static libraries for libfame

Property Value
Distribution CentOS 5
Repository PUIAS Server x86_64
Package name libfame-devel
Package version 0.9.1
Package release 12.PU_IAS.5
Package architecture x86_64
Package type rpm
Installed size 478.23 KB
Download size 165.58 KB
Official Mirror springdale.math.ias.edu
A library for fast (real-time) MPEG video encoding, written in C and assembly.
It currently allows encoding of fast MPEG-1 video, as well as MPEG-4 (OpenDivX
compatible) rectangular and arbitrary shaped video.
This package contains the files necessary to build programs that use the
libfame library.

Alternatives

Package Version Architecture Repository
libfame-devel-0.9.1-12.el5.rf.i386.rpm 0.9.1 i386 Repoforge (RPMforge)
libfame-devel-0.9.1-12.el5.rf.x86_64.rpm 0.9.1 x86_64 Repoforge (RPMforge)
libfame-devel-0.9.1-12.PU_IAS.5.i386.rpm 0.9.1 i386 PUIAS Server
libfame-devel-0.9.1-9.rf.i386.rpm 0.9.1 i386 Scientific Linux Cyrillic Edition
libfame-devel - - -

Requires

Name Value
libfame = 0.9.1
libfame-0.9.so.1()(64bit) -

Provides

Name Value
libfame-devel = 0.9.1-12.PU_IAS.5

Download

Type URL
Binary Package libfame-devel-0.9.1-12.PU_IAS.5.x86_64.rpm
Source Package libfame-0.9.1-12.PU_IAS.5.src.rpm

Install Howto

  1. Create the repository config file /etc/yum.repos.d/puias-server.repo:
    [puias-server]
    name=PUIAS Server
    baseurl=http://springdale.math.ias.edu/data/puias/5/en/os/x86_64/ServerAddons/
    enabled=1
    gpgcheck=0
    
  2. Install libfame-devel rpm package:
    # yum install libfame-devel

Files

Path
/usr/bin/libfame-config
/usr/include/fame.h
/usr/include/fame_bitbuffer.h
/usr/include/fame_decoder.h
/usr/include/fame_decoder_mpeg.h
/usr/include/fame_encoder.h
/usr/include/fame_encoder_mpeg.h
/usr/include/fame_malloc.h
/usr/include/fame_monitor.h
/usr/include/fame_motion.h
/usr/include/fame_motion_fourstep.h
/usr/include/fame_motion_none.h
/usr/include/fame_motion_pmvfast.h
/usr/include/fame_profile.h
/usr/include/fame_profile_mpeg.h
/usr/include/fame_profile_mpeg1.h
/usr/include/fame_profile_mpeg4_shape.h
/usr/include/fame_profile_mpeg4_simple.h
/usr/include/fame_profile_stats.h
/usr/include/fame_rate.h
/usr/include/fame_rate_1param.h
/usr/include/fame_rate_simple.h
/usr/include/fame_shape.h
/usr/include/fame_syntax.h
/usr/include/fame_syntax_mpeg1.h
/usr/include/fame_syntax_mpeg4.h
/usr/include/fame_version.h
/usr/include/libfame
/usr/lib64/libfame.a
/usr/lib64/libfame.so
/usr/share/aclocal/libfame.m4
/usr/share/man/man3/fame_close.3.gz
/usr/share/man/man3/fame_encode_frame.3.gz
/usr/share/man/man3/fame_encode_slice.3.gz
/usr/share/man/man3/fame_end_frame.3.gz
/usr/share/man/man3/fame_get_object.3.gz
/usr/share/man/man3/fame_init.3.gz
/usr/share/man/man3/fame_open.3.gz
/usr/share/man/man3/fame_register.3.gz
/usr/share/man/man3/fame_start_frame.3.gz
/usr/share/man/man3/fame_unregister.3.gz

Changelog

See libfame-0.9.1-12.PU_IAS.5.x86_64.rpm changelog.

See Also

Package Description
libgda-3.0.1-6.PU_IAS.5.1.x86_64.rpm Library for writing gnome database programs
libgda-devel-3.0.1-6.PU_IAS.5.1.x86_64.rpm Development libraries and header files for libgda
libgda-freetds-3.0.1-6.PU_IAS.5.1.x86_64.rpm FreeTDS provider for libgda
libgda-freetds-devel-3.0.1-6.PU_IAS.5.1.x86_64.rpm FreeTDS provider for libgda pkgconfig file
libgda-ldap-3.0.1-6.PU_IAS.5.1.x86_64.rpm LDAP provider for libgda
libgda-ldap-devel-3.0.1-6.PU_IAS.5.1.x86_64.rpm LDAP provider for libgda pkgconfig file
libgda-mdb-3.0.1-6.PU_IAS.5.1.x86_64.rpm MDB provider for libgda
libgda-mdb-devel-3.0.1-6.PU_IAS.5.1.x86_64.rpm MDB provider for libgda pkgconfig file
libgda-mysql-3.0.1-6.PU_IAS.5.1.x86_64.rpm MySQL provider for libgda
libgda-mysql-devel-3.0.1-6.PU_IAS.5.1.x86_64.rpm MySQL provider for libgda pkgconfig file
libgda-odbc-3.0.1-6.PU_IAS.5.1.x86_64.rpm ODBC provider for libgda
libgda-odbc-devel-3.0.1-6.PU_IAS.5.1.x86_64.rpm ODBC provider for libgda pkgconfig file
libgda-postgres-3.0.1-6.PU_IAS.5.1.x86_64.rpm PostgreSQL provider for libgda
libgda-postgres-devel-3.0.1-6.PU_IAS.5.1.x86_64.rpm PostgreSQL provider for libgda pkgconfig file
libgda-sqlite-3.0.1-6.PU_IAS.5.1.x86_64.rpm SQLite provider for libgda
Advertisement
Advertisement