faad2-2.7-7.PU_IAS.5.i386.rpm


Advertisement

Description

faad2 - Library and frontend for decoding MPEG2/4 AAC

Distribution: CentOS 5
Repository: PUIAS Server i386
Package name: faad2
Package version: 2.7
Package release: 7.PU_IAS.5
Package architecture: i386
Package type: rpm
Installed size: 315.17 KB
Download size: 194.32 KB
Official Mirror: springdale.math.ias.edu
FAAD 2 is a LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder, completely written from scratch.

Alternatives

Provides

  • faad2 = 2.7-7.PU_IAS.5
  • libfaad.so.2

    Download

    Install Howto

    1. Create the repository config file /etc/yum.repos.d/puias-server.repo:
      [puias-server]
      name=PUIAS Server
      baseurl=http://springdale.math.ias.edu/data/puias/5/en/os/i386/ServerAddons/
      enabled=1
      gpgcheck=0
      
    2. Install faad2 rpm package:
      # yum install faad2

    Files

    • /usr/bin/faad
    • /usr/lib/libfaad.so.2
    • /usr/lib/libfaad.so.2.0.0
    • /usr/share/doc/faad2-2.7/AUTHORS
    • /usr/share/doc/faad2-2.7/COPYING
    • /usr/share/doc/faad2-2.7/ChangeLog
    • /usr/share/doc/faad2-2.7/NEWS
    • /usr/share/doc/faad2-2.7/README
    • /usr/share/doc/faad2-2.7/README.linux
    • /usr/share/doc/faad2-2.7/TODO
    • /usr/share/man/manm/faad.man.gz

    Changelog

    2007-01-08 - Matthias Saou <http://freshrpms.net/> 2.5-2 - 5076/thias - Add patch to remove backwards compatibility in the header so that we can easily identify and patch all programs requiring a rebuild.

    2006-12-15 - Matthias Saou <http://freshrpms.net/> 2.5-1 - Update to 2.5. - Completely remove xmms/bmp plugin, it's a real mess anyway. Use audacious. - Rip out libmp4v2 too, it's best as a separate package. - Add libsysfs-devel build requirement, as it seems configure checks for it.

    2006-04-12 - Matthias Saou <http://freshrpms.net/> 2.0-8 - Include patch to #include <sys/types.h> in mp4.h to fix building against the included libmp4v2 (faac, maybe others).

    2006-04-10 - Matthias Saou <http://freshrpms.net/> 2.0-7 - Remove explicit xmms requirement, since we really only require the libs.

    2006-03-17 - Matthias Saou <http://freshrpms.net/> 2.0-6 - Release bump to drop the disttag number in FC5 build.

    2006-01-02 - Dries Verachtert <dries@ulyssis.org> 2.0-5 - Also install mp4ff_int_types.h because it is needed by mp4ff.h, thanks to Ramses Smeyers.

    2005-05-05 - Matthias Saou <http://freshrpms.net/> 2.0-4 - (Re-?)Add 64bit and symbol patches, thanks to Nicholas Miell.

    2005-04-20 - Matthias Saou <http://freshrpms.net/> 2.0-3 - Downgrade to 2.0 with gcc 3.4 and 4 patches from dev.gentoo.org, the libmp4v2 is now internal again, no need for the external mpeg4ip mess... should fix many issues, like gtkpod AAC support.

    2004-11-03 - Matthias Saou <http://freshrpms.net/> 2.0-2.20040923 - Use the snapshot from 20040923 that videolan provides.

    2004-11-02 - Matthias Saou <http://freshrpms.net/> 2.0-2.15092004 - Update to 15092004 snapshot to fix compilation on FC3. - Disable static libs since they fail to be stripped :-( #88417. - Remove merged makefile separator patch.

    Advertisement
    Advertisement