python-nose-0.10.3-1.PU_IAS.5.noarch.rpm


Advertisement

Description

python-nose - A discovery-based unittest extension for Python

Property Value
Distribution CentOS 5
Repository PUIAS Computational x86_64
Package name python-nose
Package version 0.10.3
Package release 1.PU_IAS.5
Package architecture noarch
Package type rpm
Installed size 1.12 MB
Download size 283.78 KB
Official Mirror springdale.math.ias.edu
nose: a discovery-based unittest extension.
nose provides an alternate test discovery and running process for unittest,
one that is intended to mimic the behavior of py.test as much as is
reasonably possible without resorting to too much magic.

Alternatives

Package Version Architecture Repository
python-nose-0.11.3-2.el5.noarch.rpm 0.11.3 noarch EPEL
python-nose-0.11.3-2.el5.noarch.rpm 0.11.3 noarch EPEL
python-nose-0.11.3-1.el5.noarch.rpm 0.11.3 noarch FlexBox
python-nose-0.11.3-1.el5.noarch.rpm 0.11.3 noarch FlexBox
python-nose-0.10.4-1.el5.rf.noarch.rpm 0.10.4 noarch Repoforge (RPMforge)
python-nose-0.10.4-1.el5.rf.noarch.rpm 0.10.4 noarch Repoforge (RPMforge)
python-nose-0.10.4-1.el5.art.noarch.rpm 0.10.4 noarch Atomic
python-nose-0.10.4-1.el5.art.noarch.rpm 0.10.4 noarch Atomic
python-nose-0.10.3-1.PU_IAS.5.noarch.rpm 0.10.3 noarch PUIAS Computational
python-nose-0.10.3-1.PU_IAS.5.noarch.rpm 0.10.3 noarch PUIAS Server
python-nose-0.10.3-1.PU_IAS.5.noarch.rpm 0.10.3 noarch PUIAS Server
python-nose-0.10.3-1.PU_IAS.5.noarch.rpm 0.10.3 noarch PUIAS Unsupported
python-nose-0.10.3-1.PU_IAS.5.noarch.rpm 0.10.3 noarch PUIAS Unsupported
python-nose - - -

Requires

Name Value
/usr/bin/python -
python(abi) = 2.4
python-setuptools -

Provides

Name Value
python-nose = 0.10.3-1.PU_IAS.5

Download

Type URL
Binary Package python-nose-0.10.3-1.PU_IAS.5.noarch.rpm
Source Package python-nose-0.10.3-1.PU_IAS.5.src.rpm

Install Howto

  1. Create the repository config file /etc/yum.repos.d/puias-computational.repo:
    [puias-computational]
    name=PUIAS Computational
    baseurl=http://springdale.math.ias.edu/data/puias/computational/5/x86_64/
    enabled=1
    gpgcheck=0
    
  2. Install python-nose rpm package:
    # yum install python-nose

Files

Path
/usr/bin/nosetests
/usr/lib/python2.4/site-packages/nose/__init__.py
/usr/lib/python2.4/site-packages/nose/__init__.pyc
/usr/lib/python2.4/site-packages/nose/__init__.pyo
/usr/lib/python2.4/site-packages/nose/case.py
/usr/lib/python2.4/site-packages/nose/case.pyc
/usr/lib/python2.4/site-packages/nose/case.pyo
/usr/lib/python2.4/site-packages/nose/commands.py
/usr/lib/python2.4/site-packages/nose/commands.pyc
/usr/lib/python2.4/site-packages/nose/commands.pyo
/usr/lib/python2.4/site-packages/nose/config.py
/usr/lib/python2.4/site-packages/nose/config.pyc
/usr/lib/python2.4/site-packages/nose/config.pyo
/usr/lib/python2.4/site-packages/nose/core.py
/usr/lib/python2.4/site-packages/nose/core.pyc
/usr/lib/python2.4/site-packages/nose/core.pyo
/usr/lib/python2.4/site-packages/nose/exc.py
/usr/lib/python2.4/site-packages/nose/exc.pyc
/usr/lib/python2.4/site-packages/nose/exc.pyo
/usr/lib/python2.4/site-packages/nose/failure.py
/usr/lib/python2.4/site-packages/nose/failure.pyc
/usr/lib/python2.4/site-packages/nose/failure.pyo
/usr/lib/python2.4/site-packages/nose/importer.py
/usr/lib/python2.4/site-packages/nose/importer.pyc
/usr/lib/python2.4/site-packages/nose/importer.pyo
/usr/lib/python2.4/site-packages/nose/inspector.py
/usr/lib/python2.4/site-packages/nose/inspector.pyc
/usr/lib/python2.4/site-packages/nose/inspector.pyo
/usr/lib/python2.4/site-packages/nose/loader.py
/usr/lib/python2.4/site-packages/nose/loader.pyc
/usr/lib/python2.4/site-packages/nose/loader.pyo
/usr/lib/python2.4/site-packages/nose/proxy.py
/usr/lib/python2.4/site-packages/nose/proxy.pyc
/usr/lib/python2.4/site-packages/nose/proxy.pyo
/usr/lib/python2.4/site-packages/nose/result.py
/usr/lib/python2.4/site-packages/nose/result.pyc
/usr/lib/python2.4/site-packages/nose/result.pyo
/usr/lib/python2.4/site-packages/nose/selector.py
/usr/lib/python2.4/site-packages/nose/selector.pyc
/usr/lib/python2.4/site-packages/nose/selector.pyo
/usr/lib/python2.4/site-packages/nose/suite.py
/usr/lib/python2.4/site-packages/nose/suite.pyc
/usr/lib/python2.4/site-packages/nose/suite.pyo
/usr/lib/python2.4/site-packages/nose/tools.py
/usr/lib/python2.4/site-packages/nose/tools.pyc
/usr/lib/python2.4/site-packages/nose/tools.pyo
/usr/lib/python2.4/site-packages/nose/twistedtools.py
/usr/lib/python2.4/site-packages/nose/twistedtools.pyc
/usr/lib/python2.4/site-packages/nose/twistedtools.pyo
/usr/lib/python2.4/site-packages/nose/util.py
/usr/lib/python2.4/site-packages/nose/util.pyc
/usr/lib/python2.4/site-packages/nose/util.pyo
/usr/lib/python2.4/site-packages/nose-0.10.3-py2.4.egg-info/PKG-INFO
/usr/lib/python2.4/site-packages/nose-0.10.3-py2.4.egg-info/SOURCES.txt
/usr/lib/python2.4/site-packages/nose-0.10.3-py2.4.egg-info/dependency_links.txt
/usr/lib/python2.4/site-packages/nose-0.10.3-py2.4.egg-info/entry_points.txt
/usr/lib/python2.4/site-packages/nose-0.10.3-py2.4.egg-info/top_level.txt
/usr/lib/python2.4/site-packages/nose/ext/__init__.py
/usr/lib/python2.4/site-packages/nose/ext/__init__.pyc
/usr/lib/python2.4/site-packages/nose/ext/__init__.pyo
/usr/lib/python2.4/site-packages/nose/ext/dtcompat.py
/usr/lib/python2.4/site-packages/nose/ext/dtcompat.pyc
/usr/lib/python2.4/site-packages/nose/ext/dtcompat.pyo
/usr/lib/python2.4/site-packages/nose/plugins/__init__.py
/usr/lib/python2.4/site-packages/nose/plugins/__init__.pyc
/usr/lib/python2.4/site-packages/nose/plugins/__init__.pyo
/usr/lib/python2.4/site-packages/nose/plugins/attrib.py
/usr/lib/python2.4/site-packages/nose/plugins/attrib.pyc
/usr/lib/python2.4/site-packages/nose/plugins/attrib.pyo
/usr/lib/python2.4/site-packages/nose/plugins/base.py
/usr/lib/python2.4/site-packages/nose/plugins/base.pyc
/usr/lib/python2.4/site-packages/nose/plugins/base.pyo
/usr/lib/python2.4/site-packages/nose/plugins/builtin.py
/usr/lib/python2.4/site-packages/nose/plugins/builtin.pyc
/usr/lib/python2.4/site-packages/nose/plugins/builtin.pyo
/usr/lib/python2.4/site-packages/nose/plugins/capture.py
/usr/lib/python2.4/site-packages/nose/plugins/capture.pyc
/usr/lib/python2.4/site-packages/nose/plugins/capture.pyo
/usr/lib/python2.4/site-packages/nose/plugins/cover.py
/usr/lib/python2.4/site-packages/nose/plugins/cover.pyc
/usr/lib/python2.4/site-packages/nose/plugins/cover.pyo
/usr/lib/python2.4/site-packages/nose/plugins/debug.py
/usr/lib/python2.4/site-packages/nose/plugins/debug.pyc
/usr/lib/python2.4/site-packages/nose/plugins/debug.pyo
/usr/lib/python2.4/site-packages/nose/plugins/deprecated.py
/usr/lib/python2.4/site-packages/nose/plugins/deprecated.pyc
/usr/lib/python2.4/site-packages/nose/plugins/deprecated.pyo
/usr/lib/python2.4/site-packages/nose/plugins/doctests.py
/usr/lib/python2.4/site-packages/nose/plugins/doctests.pyc
/usr/lib/python2.4/site-packages/nose/plugins/doctests.pyo
/usr/lib/python2.4/site-packages/nose/plugins/errorclass.py
/usr/lib/python2.4/site-packages/nose/plugins/errorclass.pyc
/usr/lib/python2.4/site-packages/nose/plugins/errorclass.pyo
/usr/lib/python2.4/site-packages/nose/plugins/failuredetail.py
/usr/lib/python2.4/site-packages/nose/plugins/failuredetail.pyc
/usr/lib/python2.4/site-packages/nose/plugins/failuredetail.pyo
/usr/lib/python2.4/site-packages/nose/plugins/isolate.py
/usr/lib/python2.4/site-packages/nose/plugins/isolate.pyc
/usr/lib/python2.4/site-packages/nose/plugins/isolate.pyo
/usr/lib/python2.4/site-packages/nose/plugins/manager.py
/usr/lib/python2.4/site-packages/nose/plugins/manager.pyc
/usr/lib/python2.4/site-packages/nose/plugins/manager.pyo
/usr/lib/python2.4/site-packages/nose/plugins/plugintest.py
/usr/lib/python2.4/site-packages/nose/plugins/plugintest.pyc
/usr/lib/python2.4/site-packages/nose/plugins/plugintest.pyo
/usr/lib/python2.4/site-packages/nose/plugins/prof.py
/usr/lib/python2.4/site-packages/nose/plugins/prof.pyc
/usr/lib/python2.4/site-packages/nose/plugins/prof.pyo
/usr/lib/python2.4/site-packages/nose/plugins/skip.py
/usr/lib/python2.4/site-packages/nose/plugins/skip.pyc
/usr/lib/python2.4/site-packages/nose/plugins/skip.pyo
/usr/lib/python2.4/site-packages/nose/plugins/testid.py
/usr/lib/python2.4/site-packages/nose/plugins/testid.pyc
/usr/lib/python2.4/site-packages/nose/plugins/testid.pyo
/usr/share/doc/python-nose-0.10.3/AUTHORS
/usr/share/doc/python-nose-0.10.3/CHANGELOG
/usr/share/doc/python-nose-0.10.3/NEWS
/usr/share/doc/python-nose-0.10.3/README.txt
/usr/share/doc/python-nose-0.10.3/lgpl.txt
/usr/share/man/man1/nosetests.1.gz

Changelog

2008-08-02 - Luke Macken <lmacken@redhat.com> 0.10.3-1
- Update to 0.10.3
2008-02-28 - Luke Macken <lmacken@redhat.com> 0.10.1-1
- Update to 0.10.1
2007-12-03 - Luke Macken <lmacken@redhat.com> 0.10.0-2
- Add python-setuptools to Requires (Bug #408491)
2007-11-27 - Luke Macken <lmacken@redhat.com> 0.10.0-1
- 0.10.0
2007-09-02 - Luke Macken <lmacken@redhat.com> 0.10.0-0.3.b1
- Update for python-setuptools changes in rawhide
2007-08-21 - Luke Macken <lmacken@redhat.com> 0.10.0-0.2.b1
- 0.10.0b1
- Update license tag to LGPLv2
2007-06-20 - Luke Macken <lmacken@redhat.com> 0.10.0-0.1.a2
- 0.10.0a2
2007-06-02 - Luke Macken <lmacken@redhat.com> 0.9.3-1
- Latest upstream release
- Remove python-nose-0.9.2-mandir.patch
2007-03-03 - Luke Macken <lmacken@redhat.com> 0.9.2-1
- Add nosetests(1) manpage, and python-nose-0.9.2-mandir.patch to put it in
the correct location.
- 0.9.2
2006-12-09 - Luke Macken <lmacken@redhat.com> 0.9.1-2
- Rebuild for python 2.5

See Also

Package Description
python-pygments-1.4-3.el5.noarch.rpm Syntax highlighting engine written in Python
python26-2.6.8-2.el5.x86_64.rpm An interpreted, interactive, object-oriented programming language
python26-Beaver-31-2.sdl5.noarch.rpm python daemon that munches on logs and sends their contents to logstash
python26-Cython-0.18-4.el5.x86_64.rpm A language for writing Python extension modules
python26-HTSeq-0.5.4p5-1.el5.x86_64.rpm A framework to process and analyze data from high-throughput sequencing (HTS) assays
python26-argparse-1.2.1-3.el5.noarch.rpm Optparse inspired command line parser for Python
python26-babel-0.9.5-2.el5.noarch.rpm Library for internationalizing Python applications
python26-biopython-1.58-1.el5.x86_64.rpm Python tools for computational molecular biology
python26-boto-2.25.0-2.el5.noarch.rpm A simple lightweight interface to Amazon Web Services
python26-conf_d-0.0.4-1.el5.noarch.rpm read configuration files, conf.d style
python26-daemon-1.5.2-1.sdl5.noarch.rpm Library to implement a well-behaved Unix daemon process
python26-dateutil-1.4.1-7.sdl5.noarch.rpm Powerful extensions to the standard datetime module
python26-devel-2.6.8-2.el5.x86_64.rpm The libraries and header files needed for Python development
python26-distribute-0.6.34-4.sdl5.noarch.rpm Easily build and distribute Python packages
python26-docutils-0.6-1.el5.noarch.rpm A system for processing plaintext documentation
Advertisement
Advertisement