perl-Params-Validate-0.88-3.el5.x86_64.rpm


Advertisement

Description

perl-Params-Validate - Params-Validate Perl module

Distribution: CentOS 5
Repository: PUIAS Computational x86_64
Package name: perl-Params-Validate
Package version: 0.88
Package release: 3.el5
Package architecture: x86_64
Package type: rpm
Installed size: 148.46 KB
Download size: 71.43 KB
Official Mirror: springdale.math.ias.edu
The Params::Validate module allows you to validate method or function call parameters to an arbitrary level of specificity. At the simplest level, it is capable of validating the required parameters were given and that no unspecified additional parameters were passed in. It is also capable of determining that a parameter is of a specific type, that it is an object of a certain class hierarchy, that it possesses certain methods, or applying validation callbacks to arguments.

Provides

  • Validate.so()(64bit)
  • perl(Attribute::Params::Validate) = 1.7
  • perl(Params::Validate)
  • perl(Params::Validate) = 0.88
  • perl-Params-Validate = 0.88-3.el5

    Install Howto

    1. Create the repository config file /etc/yum.repos.d/puias-computational.repo:
      [puias-computational]
      name=PUIAS Computational
      baseurl=http://springdale.math.ias.edu/data/puias/computational/5/x86_64/
      enabled=1
      gpgcheck=0
      
    2. Install perl-Params-Validate rpm package:
      # yum install perl-Params-Validate

    Files

    • /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Attribute/
    • /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Attribute/Params/Validate.pm
    • /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Params/Validate.pm
    • /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Params/ValidatePP.pm
    • /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/Params/ValidateXS.pm
    • /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Params/
    • /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/auto/Params/Validate/Validate.so
    • /usr/share/doc/perl-Params-Validate-0.88/Changes
    • /usr/share/doc/perl-Params-Validate-0.88/LICENSE
    • /usr/share/doc/perl-Params-Validate-0.88/README
    • /usr/share/doc/perl-Params-Validate-0.88/TODO
    • /usr/share/man/man3/Attribute::Params::Validate.3pm.gz
    • /usr/share/man/man3/Params::Validate.3pm.gz
    • /usr/share/man/man3/Params::ValidatePP.3pm.gz
    • /usr/share/man/man3/Params::ValidateXS.3pm.gz

    Changelog

    2007-09-06 - Ralf Corsépius <rc040203@freenet.de> - 0.88-3 - Update license tag.

    2007-08-22 - Ralf Corsépius <rc040203@freenet.de> - 0.88-2 - Mass rebuild.

    2007-03-12 - Ralf Corsépius <rc040203@freenet.de> - 0.88-1 - BR: perl(ExtUtils::MakeMaker). - Upstream update.

    2007-01-20 - Ralf Corsépius <rc040203@freenet.de> - 0.87-1 - Upstream update.

    2006-09-05 - Ralf Corsépius <rc040203@freenet.de> - 0.86-2 - Mass rebuild.

    2006-08-13 - Ralf Corsépius <rc040203@freenet.de> - 0.86-1 - Upstream update.

    2006-06-28 - Ralf Corsépius <rc040203@freenet.de> - 0.85-1 - Upstream update.

    2006-06-05 - Ralf Corsépius <rc040203@freenet.de> - 0.84-1 - Upstream update.

    2006-05-21 - Ralf Corsépius <rc040203@freenet.de> - 0.82-1 - Upstream update.

    2006-04-04 - Ralf Corsépius <rc040203@freenet.de> - 0.81-1 - Upstream update.

    Advertisement
    Advertisement