puppet-server-0.25.5-2.ep.noarch.rpm


Advertisement

Description

puppet-server - Server for the puppet system management tool

Property Value
Distribution CentOS 5
Repository End Point i386
Package name puppet-server
Package version 0.25.5
Package release 2.ep
Package architecture noarch
Package type rpm
Installed size 16.25 KB
Download size 19.93 KB
Official Mirror packages.endpoint.com
Provides the central puppet server daemon which provides manifests to clients.
The server can also function as a certificate authority and file server.

Alternatives

Package Version Architecture Repository
puppet-server-2.7.20-1.el5.rf.noarch.rpm 2.7.20 noarch Repoforge (RPMforge)
puppet-server-2.7.20-1.el5.rf.noarch.rpm 2.7.20 noarch Repoforge (RPMforge)
puppet-server-2.7.9-1.el5.rf.noarch.rpm 2.7.9 noarch Repoforge (RPMforge)
puppet-server-2.7.9-1.el5.rf.noarch.rpm 2.7.9 noarch Repoforge (RPMforge)
puppet-server-2.7.5-1.el5.rf.noarch.rpm 2.7.5 noarch Repoforge (RPMforge)
puppet-server-2.7.5-1.el5.rf.noarch.rpm 2.7.5 noarch Repoforge (RPMforge)
puppet-server-2.7.3-2.ep.noarch.rpm 2.7.3 noarch End Point
puppet-server-2.7.3-2.ep.noarch.rpm 2.7.3 noarch End Point
puppet-server-2.6.6-1.ep.noarch.rpm 2.6.6 noarch End Point
puppet-server-2.6.6-1.ep.noarch.rpm 2.6.6 noarch End Point
puppet-server-0.25.5-2.ep.noarch.rpm 0.25.5 noarch End Point
puppet-server-0.25.5-1.ep.noarch.rpm 0.25.5 noarch End Point
puppet-server-0.25.5-1.ep.noarch.rpm 0.25.5 noarch End Point
puppet-server-0.25.4-1.PU_IAS.5.noarch.rpm 0.25.4 noarch PUIAS Unsupported
puppet-server-0.25.4-1.PU_IAS.5.noarch.rpm 0.25.4 noarch PUIAS Unsupported
puppet-server-0.25.1-2.ep.noarch.rpm 0.25.1 noarch End Point
puppet-server-0.25.1-2.ep.noarch.rpm 0.25.1 noarch End Point
puppet-server-0.25.0-2.ep.noarch.rpm 0.25.0 noarch End Point
puppet-server-0.25.0-2.ep.noarch.rpm 0.25.0 noarch End Point
puppet-server-0.24.7-4.ep.noarch.rpm 0.24.7 noarch End Point
puppet-server-0.24.7-4.ep.noarch.rpm 0.24.7 noarch End Point
puppet-server-0.24.6-1.ep.i386.rpm 0.24.6 i386 End Point
puppet-server - - -

Requires

Name Value
/bin/bash -
/usr/bin/ruby -
chkconfig -
initscripts -
puppet = 0.25.5-2.ep

Provides

Name Value
config(puppet-server) = 0.25.5-2.ep
puppet-server = 0.25.5-2.ep

Download

Type URL
Binary Package puppet-server-0.25.5-2.ep.noarch.rpm
Source Package puppet-0.25.5-2.ep.src.rpm

Install Howto

  1. Download latest endpoint-release rpm from https://packages.endpoint.com/rhel/5/os/i386/
  2. Install endpoint-release rpm:
    # rpm -Uvh endpoint-release*rpm
  3. Install puppet-server rpm package:
    # yum install puppet-server

Files

Path
/etc/puppet/fileserver.conf
/etc/puppet/puppetmasterd.conf
/etc/puppet/manifests/
/etc/rc.d/init.d/puppetmaster
/etc/sysconfig/puppetmaster
/usr/sbin/puppetmasterd
/usr/sbin/puppetqd
/usr/sbin/puppetrun
/usr/share/man/man8/filebucket.8.gz
/usr/share/man/man8/puppetmasterd.8.gz
/usr/share/man/man8/puppetrun.8.gz

Changelog

2011-07-27 - Josh Williams <hosting@endpoint.com> - 0.25.5-1
- Update to 0.25.5
2009-10-20 - Todd Zullinger <tmz@pobox.com> - 0.25.1-1
- Update to 0.25.1
- Include the pi program and man page (R.I.Pienaar)
2009-10-17 - Todd Zullinger <tmz@pobox.com> - 0.25.1-0.2.rc2
- Update to 0.25.1rc2
2009-09-22 - Todd Zullinger <tmz@pobox.com> - 0.25.1-0.1.rc1
- Update to 0.25.1rc1
- Move puppetca to puppet package, it has uses on client systems
- Drop redundant %doc from manpage %file listings
2009-09-04 - Todd Zullinger <tmz@pobox.com> - 0.25.0-1
- Update to 0.25.0
- Fix permissions on /var/log/puppet (#495096)
- Install emacs mode and vim syntax files (#491437)
- Install ext/ directory in %{_datadir}/puppet (/usr/share/puppet)
2009-05-04 - Todd Zullinger <tmz@pobox.com> - 0.25.0-0.1.beta1
- Update to 0.25.0beta1
- Make Augeas and SELinux requirements build time options
2009-03-23 - Todd Zullinger <tmz@pobox.com> - 0.24.8-1
- Update to 0.24.8
- Quiet output from %pre
- Use upstream install script
- Increase required facter version to >= 1.5
2008-12-16 - Todd Zullinger <tmz@pobox.com> - 0.24.7-4
- Remove redundant useradd from %pre
2008-12-16 - Jeroen van Meeuwen <kanarip@kanarip.com> - 0.24.7-3
- New upstream version
- Set a static uid and gid (#472073, #471918, #471919)
- Add a conditional requirement on libselinux-ruby for Fedora >= 9
- Add a dependency on ruby-augeas
2008-10-22 - Todd Zullinger <tmz@pobox.com> - 0.24.6-1
- Update to 0.24.6
- Require ruby-shadow on Fedora and RHEL >= 5
- Simplify Fedora/RHEL version checks for ruby(abi) and BuildArch
- Require chkconfig and initstripts for preun, post, and postun scripts
- Conditionally restart puppet in %postun
- Ensure %preun, %post, and %postun scripts exit cleanly
- Create puppet user/group according to Fedora packaging guidelines
- Quiet a few rpmlint complaints
- Remove useless %pbuild macro
- Make specfile more like the Fedora/EPEL template

See Also

Package Description
python-apt-0.5.15lorg3.2-4.i386.rpm Python bindings for libapt-pkg
python-configobj-4.6.0-1.noarch.rpm Config file reading, writing, and validation
python-docutils-0.7-3.ep.noarch.rpm System for processing plaintext documentation
python-rrdtool-1.2.23-1.rf.i386.rpm Python RRDtool bindings
python-setuptools-0.6.14-4.ep.noarch.rpm Easily build and distribute Python packages
qstat-2.11-5.i386.rpm Real-time Game Server Status for FPS game servers
radiusclient-0.3.2-1.i386.rpm framework and library for writing RADIUS clients
radiusclient-devel-0.3.2-1.i386.rpm Header files, libraries and development documentation for radiusclient
recode-3.6-24.ep.i386.rpm Conversion between character sets and surfaces
recode-devel-3.6-24.ep.i386.rpm Header files and static libraries for development using recode
roundcubemail-0.2-3.beta.noarch.rpm Round Cube Webmail is a browser-based multilingual IMAP client
roundcubemail-0.2-6.stable.ep.noarch.rpm Round Cube Webmail is a browser-based multilingual IMAP client
roundcubemail-0.3.1-1.ep.noarch.rpm Round Cube Webmail is a browser-based multilingual IMAP client
rpmdevtools-5.3-1.noarch.rpm RPM Development Tools
rpmlint-0.84-2.noarch.rpm Tool for checking common errors in RPM packages
Advertisement
Advertisement